Problème d'entrée-sortie avec apt


#1

Bonjour,

J’ai installé il y a peu debian 10 sur mon pc et depuis aujourd’hui quand je fais un

apt-get upgrade

j’obtiens une erreur avec plein de dépendances insatisfaites :

Les paquets suivants contiennent des dépendances non satisfaites :
 acl : Dépend: libacl1 (= 2.2.53-4) mais il n'est pas installé
       Dépend: libattr1 (>= 1:2.4.46-8) mais il n'est pas installé
       Dépend: libc6 (>= 2.14) mais il n'est pas installé
 adduser : Dépend: passwd
           Dépend: debconf (>= 0.5) mais il n'est pas installé ou
                    debconf-2.0
 adwaita-icon-theme : Dépend: hicolor-icon-theme mais il n'est pas installé
                      Dépend: gtk-update-icon-cache
                      Dépend: librsvg2-common mais il n'est pas installé
 alsa-utils : Dépend: kmod (>= 17-1~)
              Dépend: lsb-base (>= 3.0-9) mais il n'est pas installé
              Dépend: whiptail ou
                       dialog mais il n'est pas installé
              Dépend: libasound2 (>= 1.1.1) mais il n'est pas installé
              Dépend: libc6 (>= 2.27) mais il n'est pas installé
              Dépend: libfftw3-single3 (>= 3.3.5) mais il n'est pas installé
              Dépend: libncursesw6 (>= 6) mais il n'est pas installé
              Dépend: libsamplerate0 (>= 0.1.7) mais il n'est pas installé
              Dépend: libtinfo6 (>= 6) mais il n'est pas installé
 anacron : Dépend: debianutils (>= 1.7)
           Dépend: lsb-base (>= 3.0-10) mais il n'est pas installé
           Dépend: libc6 (>= 2.7) mais il n'est pas installé
           Recommande: cron ou
                       cron-daemon
           Recommande: rsyslog mais il n'est pas installé ou
                       system-log-daemon
 ant : Dépend: default-jre-headless (>= 2:1.8) mais il n'est pas installé ou
                java8-runtime-headless
 apparmor : Dépend: debconf mais il n'est pas installé
            Dépend: lsb-base mais il n'est pas installé
            Dépend: debconf (>= 0.5) mais il n'est pas installé ou
                     debconf-2.0
            Dépend: python3:any
            Dépend: libc6 (>= 2.17) mais il n'est pas installé
 apt : Dépend: gpgv ou
                gpgv2 mais il n'est pas installé ou
                gpgv1
       Dépend: debian-archive-keyring mais il n'est pas installé
       Dépend: libapt-pkg5.0 (>= 1.7.0~alpha3~) mais il n'est pas installé
       Dépend: libc6 (>= 2.15) mais il n'est pas installé
       Dépend: libgcc1 (>= 1:3.0) mais il n'est pas installé
       Dépend: libgnutls30 (>= 3.6.6) mais il n'est pas installé
       Dépend: libseccomp2 (>= 1.0.1) mais il n'est pas installé
       Dépend: libstdc++6 (>= 5.2) mais il n'est pas installé
       Recommande: ca-certificates mais il n'est pas installé
 apt-listchanges : Dépend: python3-apt (>= 0.7.93) mais il n'est pas installé
                   Dépend: python3-debconf mais il n'est pas installé
                   Dépend: sensible-utils mais il n'est pas installé
                   Dépend: ucf (>= 0.28) mais il n'est pas installé
                   Dépend: debconf (>= 0.5) mais il n'est pas installé ou
                            debconf-2.0
                   Dépend: python3:any (>= 3.5~)
 apt-utils : Dépend: libapt-inst2.0 (>= 1.0.5) mais il n'est pas installé
             Dépend: libapt-pkg5.0 (>= 1.3~rc2) mais il n'est pas installé
             Dépend: libc6 (>= 2.14) mais il n'est pas installé
             Dépend: libdb5.3 mais il n'est pas installé
             Dépend: libgcc1 (>= 1:3.0) mais il n'est pas installé
             Dépend: libstdc++6 (>= 5.2) mais il n'est pas installé
 aspell : Dépend: libaspell15 (= 0.60.7~20110707-6) mais il n'est pas installé
          Dépend: libc6 (>= 2.14) mais il n'est pas installé
          Dépend: libgcc1 (>= 1:3.0) mais il n'est pas installé
          Dépend: libncursesw6 (>= 6) mais il n'est pas installé
          Dépend: libstdc++6 (>= 5) mais il n'est pas installé
          Dépend: libtinfo6 (>= 6) mais il n'est pas installé
          Dépend: dictionaries-common (> 0.40) mais il n'est pas installé
 aspell-en : Dépend: dictionaries-common (>= 0.49.2) mais il n'est pas installé
 aspell-fr : Dépend: dictionaries-common (>= 1.23~) mais il n'est pas installé
 at-spi2-core : Dépend: libatspi2.0-0 (>= 2.9.90) mais il n'est pas installé
                Dépend: libc6 (>= 2.7) mais il n'est pas installé
                Dépend: libdbus-1-3 (>= 1.9.14) mais il n'est pas installé
                Dépend: libglib2.0-0 (>= 2.37.3) mais il n'est pas installé
                Dépend: libx11-6 mais il n'est pas installé
                Dépend: libxtst6 mais il n'est pas installé
 atril : Dépend: libatrildocument3 (= 1.20.3-1) mais il n'est pas installé
         Dépend: libatrilview3 (= 1.20.3-1) mais il n'est pas installé
         Dépend: shared-mime-info
         Dépend: dconf-gsettings-backend mais il n'est pas installé ou
                  gsettings-backend
         Dépend: libatk1.0-0 (>= 1.12.4) mais il n'est pas installé
         Dépend: libc6 (>= 2.4) mais il n'est pas installé
         Dépend: libcairo-gobject2 (>= 1.10.0) mais il n'est pas installé
         Dépend: libcairo2 (>= 1.2.4) mais il n'est pas installé
         Dépend: libcaja-extension1 (>= 1.6.3) mais il n'est pas installé
         Dépend: libgail-3-0 (>= 3.0.0) mais il n'est pas installé
         Dépend: libgdk-pixbuf2.0-0 (>= 2.22.0) mais il n'est pas installé
         Dépend: libglib2.0-0 (>= 2.37.3) mais il n'est pas installé
         Dépend: libgtk-3-0 (>= 3.21.4) mais il n'est pas installé
         Dépend: libice6 (>= 1:1.0.0) mais il n'est pas installé
         Dépend: libjavascriptcoregtk-4.0-18 mais il n'est pas installé
         Dépend: libpango-1.0-0 (>= 1.14.0) mais il n'est pas installé
         Dépend: libpangocairo-1.0-0 (>= 1.14.0) mais il n'est pas installé
         Dépend: libsecret-1-0 (>= 0.7) mais il n'est pas installé
         Dépend: libsm6 mais il n'est pas installé
         Dépend: libsoup2.4-1 (>= 2.4.0) mais il n'est pas installé
         Dépend: libwebkit2gtk-4.0-37 (>= 2.5) mais il n'est pas installé
         Dépend: libx11-6 mais il n'est pas installé
         Dépend: libxml2 (>= 2.7.4) mais il n'est pas installé
         Dépend: zlib1g (>= 1:1.1.4) mais il n'est pas installé
         Recommande: default-dbus-session-bus ou
                     dbus-session-bus
         Recommande: gvfs mais il n'est pas installé
 autoconf : Dépend: perl (> 5.005) mais il n'est pas installé
            Dépend: m4 (>= 1.4.13)
            Dépend: debianutils (>= 1.8)
 avahi-daemon : Dépend: libavahi-common3 (>= 0.6.16) mais il n'est pas installé
                Dépend: libavahi-core7 (>= 0.6.24) mais il n'est pas installé
                Dépend: libc6 (>= 2.27) mais il n'est pas installé
                Dépend: libcap2 (>= 1:2.10) mais il n'est pas installé
                Dépend: libdaemon0 (>= 0.14) mais il n'est pas installé
                Dépend: libdbus-1-3 (>= 1.9.14) mais il n'est pas installé
                Dépend: libexpat1 (>= 2.0.1) mais il n'est pas installé
                Dépend: dbus (>= 0.60)
                Dépend: lsb-base (>= 3.0-6) mais il n'est pas installé
                Dépend: bind9-host mais il n'est pas installé ou
                         host
                Recommande: libnss-mdns mais il n'est pas installé

E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

Même chose avec un update :

Lecture des listes de paquets... Erreur !
E: Erreur de lecture - read (5: Erreur d'entrée/sortie)
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
E: Le fichier de cache des paquets est corrompu

Relancer la commande donne la même chose.
Plus possible d’installer un paquet.
Même quand j’ouvre synaptic, celui-ci me dit :

E: Erreur de lecture - read (5: Erreur d'entrée/sortie)
E: Erreur interne en recalculant le cache des dépendances (3). Veuillez envoyer un rapport d'anomalie.

Hier tout allait bien.
Quelqu’un aurait-il une solution ?


#2

Salut
je commencerai par faire un nettoyage

sudo apt clean

et mettre à jour les listes pour voir les dépôts

sudo apt update

Ensuite il est peut etre utile de faire un full-upgrade pour installer les nouveaux paquets

sudo apt full-upgrade

#3

Bonjour,

Si tu as toujours des erreurs d’entrée/sortie avec les commandes indiquées par @grandtoubab, il faudra vérifier le système de fichiers (fsck) et le disque (smartctl).


#4

Ca pas la peine, quand on a des problèmes apt, on gère en ligne de commande.

Pour fournir le retour d’une commande, c’est mieux de copier non seulement les erreurs, mais toute la sortie y compris les choses qui se passent bien, et idéalement, le prompt avec la commande tapée au début rajoute du contexte utile.

Eventuellement, si ça râle toujours avec ça, réessayer sudo apt-get dist-upgrade et sudo aptitude dist-upgrade quand l’un ne passe pas un probléme de dépendances, parfois un autre le passe.
[edit: et l’état du sources.list serait utile, aussi.]


#5

Bonjour,

J’ai essayé les solutions de @grandtoubab. J’obtiens toujours les mêmes erreurs, ainsi qu’avec les commandes de @mattotop.
En ce qui concerne le système de fichier, j’ai lancé fsck et j’obtiens :

root@debian:/home/famille# fsck
fsck de util-linux 2.33.1
e2fsck 1.44.5 (15-Dec-2018)
/dev/sda1 is mounted.
e2fsck: Cannot continue, aborting.

Je ne sais pas exactement ce que ça signifie…

Je n’ai pas aptitude ni smartctl et il est toujours impossible d’installer des paquets
Sinon, voilà mon sources.list :

# deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 xfce-CD Binary-1 20190706-10:24]/ buster main

#deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 xfce-CD Binary-1 20190706-10:24]/ buster main

deb http://deb.debian.org/debian/ buster main
deb-src http://deb.debian.org/debian/ buster main

deb http://security.debian.org/debian-security buster/updates main
deb-src http://security.debian.org/debian-security buster/updates main

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main
deb-src http://deb.debian.org/debian/ buster-updates main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to #configure apt package sources,
# see the sources.list(5) manual.

Voilà. Merci déjà pour vos premières réponses.


#6

Il faut démarrer en mode de récupération (recovery) pour pouvoir lancer fsck sur ta partition système.


#7

Je me trompe peut être, mais je ne crois pas.
L’install provoque peut être une erreur sur les paquets qui posaient déjà probléme, mais normalement, les nouveaux que tu demandes d’installer s’installent.
Normalement.
Sinon, essaye un truc, déplace ton sources.list et tous les fichiers de /etc/apt/sources.list.d/ ailleurs, fais un apt update, ensuite tu remets les fichiers .list à leur place, et re apt-update, puis apt install pour mettre les choses au propre.

C’est @Bruno1 qui suggérait d’examiner tes partitions avec fsck, mai s il faut préciser quelle partition.
Comme tu ne précisais pas, il a testé sur /dev/sda1, qui semble être ta partition root, en cours d’utilisation, donc il refuse de faire un scan sur le disque.
Pour scanner ta partition avec fsck, il faut rebooter en recovery, comme il dit.
Mais quelles partitions as tu ?


#8

Bonsoir

À voir le prompt :

je pense que les variables d’environnement
(dont le PATH) ne doivent sans doute pas êtres celles attendues.

Si, depuis ton compte utilisateur non privilégié famille,
tu es passé sous le compte root en utilisant la commande su
tu as sans doute oublié d’utiliser l’option login de cette commande
qui peut être raccoucie en entrant un simple tiret (-)


En résumé, depuis ton compte utilisateur famille,
si tu veux accéder aux privilèges du compte root
et profiter de l’environnement spécifique à ce compte,
entre plutôt la ligne de commandes suivante :

su -

(n’oublie pas le tiret)

Tu seras alors dans le répertoire personnel du compte root
ce qui fait que le prompt sera alors :

root@debian:~#

et le contenu de la variable PATH permettra au compte root
d’accéder à tous les programmes dont il a besoin pour administrer le système.