Problème d'installation de driver CS4235 sous Debian


#1

Bonsoir à tous,

Je suis un tout jeune sur debian, et actuellement je galère à installer un driver de son. Ma carte son est intégrée à la carte mère, c’est un chip Crystal CS4235 qui n’est apparemment pas reconnu par ALSA.

A chaque démarrage, j’ai un message d’information qui me dit "error while initializing the sound driver : device/dev/dsp can’t be opened (no such file or directory).

J’ai tenté la façon d’alexis de lattre mais ça n’a rien donné, j’ai tenté de configurer alsa mais ça ne reconnait pas la carte son.
Je trouve la référence de la carte sur le site d’alsa, mais après pour installer les driver/util/lib je ne sais pas comment m’y prendre.

Si vous avez un peu de temps pour m’expliquer… merci beaucoup :slightly_smiling:


#2

Dans la config de ton noyau, tu n’as pas trouvé ta carte ?


#3

non, il y a la CS4236 mais pas la 4235.
Ma carte n’est pas reconnue par aucune des méthodes :confused:
Chez alsa pourtant elle est dans la liste des cartes compatibles.

alsa-project.org/alsa-doc/in … gic#matrix

Le nom du module est apparemment cs4236. Comment on installe un tel module ?


#4

As-tu essayé de laisser de côté Alsa et de passer par esound ?
c’est considéré, je crois, comme moins “pointu” mais ça fonctionne où Alsa ne veut rien savoir, des fois !


#5

Je veux bien te montrer comment je fais pour installer un module mais c’est la méthode Alexis de Lattre “Old fashion” autant dire une méthode préhistorique. Je préfère que les “PhD” du forum te répondent. Mais tu devras juste attendre que les dernières vapeurs d’alcool du réveillon aient quitté leur organisme… :wink:


#6

le module, c’est snd-cs4236 .
Tu peux essayer de compiler alsa séparément avec le module-assistant (m-a).


#7

Merci pour les réponses.
Alors déjà, Linux et moi c’est une histoire qui est toute jeune, alors pardonnez mes ignorances.

Esound, je ne connais pas. Je vais me renseigner.
PhD = ? ça doit être un terme barbare désignant les vieux fanatiques de la ligne de commande j’imagine :smiley:

[quote]le module, c’est snd-cs4236 .
Tu peux essayer de compiler alsa séparément avec le module-assistant (m-a).[/quote]

Comment j’installe un tel module ?


#8

[quote]les vieux fanatiques[/quote] :laughing: :laughing: :laughing:


#9

“Philosophical Degree”, c’est le niveau d’étude des Docteurs dans les pays anglo-saxons :wink:


#10

Merci pour l’explication =) lol


#11

le module, c’est son nom. Alors normalement, il est déjà dispo dans ton noyau, ce que tu vérifies avec:
modinfo snd-cs4236
ensuite
modprobe snd-cs4236
si c’est bon, tu le rajoutes dans /etc/modules, et tu fais le reste de ta config.


#12

lorsque je tape modprobe snd-cs4236 il me met une erreur :

FATAL : Error inserting snd-cs4236 (le lien) : no such device
FATAL : Error running install command for snd-cs4236

Ya p’têtre un autre problème c’est pour ça que j’y arrive pas depuis trois jours :whistle:


#13

D’ailleurs avec alsaconf il y est bien le module cs4236, mais pourtant il ne trouve toujours rien… :confused:?:


#14

Je suis un gland… dans le bios le sound était sur Disabled…

Je galère depuis ce week end pour ça, alors que c’était pas activé…
Pourtant c’est bizarre que j’ai un message d’erreur au démarrage de KDE alors que la carte était désactivée ?

Merci pour vos réponses, y me reste à copier le module, et voir si ça marche. je vous tiens au courant…


#15

Essaye de télecharger les sources d’alsa, et de les décompiler dans ton répertoir /usr/src/
ensuite va dans le sous-répertoire …/modules/alsa-driver/
puis, en root, execute le programme qui s’y trouve ./snddevices
cela devrait créer les liens /dev qui te manquent. Parfois cette manip’ suffit, parfois non.
Si ça ne fonctionne toujours pas, il va falloir que tu te tappes une recompilation de kernel… J’en ai bavé aussi avec ma carte son cs46xx, et la solution que j’ai trouvé, qui fonctionne, c’était de refaire un nouveau kernel en mettant bien les paramètres qu’il faut pour qu’il trouve ma carte son. Ah oui, le problème en fait, ne venait pas d’alsa, mais de ma carte son, qui n’était pas reconnue par le système (fais un lspci pour savoir).


#16

Merci Damsss pour tes explications, mais j’en aurai pas besoin !
Je viens de relancer KDE pour voir si j’avais toujours le même message, et je ne l’ai plus, la carte son doit fonctionner.

D’ailleurs en console, lsmod me donne tout bon je pense.

snd-cs4236 Used by : 0
C’est normal ?

Je vais tenter de trouver des enceintes pour tester directement :slightly_smiling:

Pour ceux que ça intéresse, j’ai fait :

Avec Vi, dans modules.conf (situé dans /etc/modules.conf), j’ai ajouté les lignes (j’avais trouvé ça dans un tuto sur le net) :

ALSA native device support

alias char-major-116 snd
options snd snd_major=116 snd_cards_limit=1
alias snd-card-0 snd-cs4236

OSS/Free setup

alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Après ça, un petit modprobe snd-cs4236 et c’est parti !


#17

Bon… ben, je vais éplucher les patates… :laughing:


#18

Lol mais non, merci pour les conseils.
J’ai pas besoin de son sur cette machine, mais je me force à apprendre les bases (j’en connais pas beaucoup), et installer un driver, pour moi, grand windowsien (chuis technicien de maintenance, sous windaube), c’est le B-A-BA, alors ça me frustre de pas savoir le faire sous Linux.
M’enfin on a tous débuté par quelque chose, et je suis content d’y être arrivé. J’adore l’ambiance des forums Linuxiens, c’est une ambiance de partage, ça change. Alors merci pour ton apport, y pourra peut etre éclairer quelqu’un qui aura le meme problème :slightly_smiling:


#19

Bon, le son marche, par contre à chaque fois que je redémarre, je l’ai plus et je dois relancer alsaconf.

Comment je fais pour le fixer ?


#20
devrait résoudre ton pb de mémorisation des paramètres.

devrait résoudre ton pb de mémorisation des paramètres.