Problème d'installation de Thonny sur Raspberry Pi

apt
jessie
wheezy
Tags: #<Tag:0x00007fa92f724a18> #<Tag:0x00007fa92f724798> #<Tag:0x00007fa92f7244c8>

#1

Bonjour a tous,
je suis nouveau dans le domaine du Raspberry et j’aimerai codé du Python sur l’application Thonny.
Or mon problème est que celui ci n’est pas installé sur mon Raspberry de base. J’ai donc voulu essayé de le télécharger ce qui m’a donné :

pi@raspberrypi ~ $ sudo apt-get install thonny
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
E: Impossible de trouver le paquet thonny

Je me suis donc demandé si ça n’était pas du au fait que j’étais sur une ancienne version de Debian ( wheezy), j’ai donc voulu passer a une version plus récente :

image

Je n’y comprends rien
Merci de vos réponses


#2

Voici la suite :
image


#3

Je ne dis pas qu’on ai aucune compétence pour te répondre, mais il n’y a pas un forum raspian qui pourrait mieux te répondre ?
Sinon, je ne peux rien faire personnellement avec tes captures d’écran (de merde, pardonne moi du terme), ou on ne peut rien copier/coller pour essayer de regarder sur les sites pourquoi l’accés aux dépots ne se fait pas.
Pas moyen d’avoir des copies textuelles plutôt que des screens (de merde, je le redis) ? :smiley:

Trés ancienne.
Ce n’est pas forcément une mauvaise idée d’upgrader, mais il va peut être faloir y aller pas à pas, et garder un backup par précaution.


#4

ça marche as tu le lien de ce forum car il y en a vraiment plusieurs.
Les captures d’écrans étaient obligés car le forum ne me permettait pas de mettre plus de 2 liens dans le post.
Merci pour ta réponse


#5

J’avais oublié ça.
Si tu englobe ça entre deux triplettes de backticks ``` comme ça, je crois que ce n’est pas vu comme liens (et en plus la mise en forme texte est propre).
Genre:

deb http://archive.debian.org/debian/ wheezy main
deb-src http://archive.debian.org/debian/ wheezy main
deb http://archive.debian.org/debian-archive/debian-security/ wheezy updates/main

Que je viens de trouver sur cet article qui traite justement de ton probléme.


#7

Merci pour ta réponse et pour l’article mais mon problème est que je ne peux pas modifier le fichier sources.list


#8

Je viens de voir qu’il était pur debian, mais c’est peut être transposable raspian.

Pourquoi ?


#9

Quand je le modifie et l’enregistre il me met le message d’erreur “Impossible d’ouvrir le fichier en écriture”


#10

Avec quel éditeur ?
Sous quel identifiant ?


#11

Je veux dire, avec su - ou sudo, déjà, il faut que tu sois root pour modifier le fichier.


#12

Si je rentre la commande sudo gedit etc/apt/sources.list il me dit : sudo: gedit: command not found


#13

Ben oui. Normal que gedit ne soit pas installé sur un raspi.
Plutôt *sudo nano /etc/apt/sources.list.


#14

D’accord je savais pas je débute comme je disais. ça marche mais c’est comme si c’était un nouveau fichier car il me l’ouvre vide


#16

Je l’enregistre en fomat DOS, MAC ?


#17

Tu ne l’enregistres pas:
tu as du copier le point à la fin de mon instruction:
sudo nano /etc/apt/sources.list
de mon post d’avant, donc tu dois être en train de travailler sur le fichier sources.list. (avec le . à la fin).

Bref, quitte l’editeur sans sauvegarder et relance sans le .


#18

J’avais fait sudo nano etc/apt/sources.list j’avais oublié / avant etc


#19

ça a fonctionné mais sudo apt-get update me donne encore des erreurs


#20

Ouais, ben on va pas les deviner, et merci d’éviter les screens si tu peux copier/coller.


#21

je vais les envoyer 2 sec


#22

On ne va pas non plus inventer ce que tu as fait dans le sources.list, si tu veux qu’on t’aide, il faut aussi que tu nous dises ce que tu fais et ce que tu vois.