Problème d'installation GRUB Debian 12

Tags: #<Tag:0x00007f63f2184810> #<Tag:0x00007f63f21846f8> #<Tag:0x00007f63f2184540> #<Tag:0x00007f63f2184450>

Suite à mon précédent post, je me suis tenté de refaire une installation propre pour régler mes soucis.
L’installation se déroule correctement jusqu’au message « Executing grub-install dummy » apparaisse à la toute fin.
J’ai tout tenté, j’ai passé mon disque de MBR vers GPT, il y a seulement DEBIAN dessus, pas de double OS, le partitionnement assisté, non assisté, la désactivation du secure boot au démarrage, un reformatage propre, refait une clée USB d’installation pensant que celle-ci était défectueuse, rien, j’avoue que je bloque un peu.
C’est un SSD Kingston de 256GB, une carte mère ASRock J5005-ITX avec un processeur Intel® Quad-Core Pentium J5005 j’ai donc pris la version officielle de Debian 12 en AMD64.

Je vous remercie d’avance pour votre aide.
image

Pour connaître la cause de l’erreur lors de l’exécution de la commande grub-install il faut regarder dans les logs de l’installateur, soit via la console tty4 (Ctrl+Alt+F4) soit dans le fichier /var/log/syslog depuis la console tty2 (Ctrl+Alt+F2) ou tty3.

Il s’agit visiblement d’une installation de GRUB pour l’amorçage EFI, des causes possibles sont :

  • pas de partition système EFI (mais le partitionneur aurait dû le signaler) ou pas assez d’espace libre
  • erreur lors de la mise à jour des variables EFI dans la NVRAM de la carte mère (contournement possible : installation expert + installer GRUB dans le chemin de support amovible + ne pas mettre à jour les variables EFI)

Merci encore pour ta réponse.
Voici le message et la console lié à l’erreur que je rencontre.
IMG_7357
IMG_7358

Vu, l’erreur est causée par l’impossibilité d’enregistrer le chargeur d’amorçage dans les variables de boot EFI à cause d’un espace libre insuffisant dans la mémoire non vollatile (NVRAM) de de la carte mère.

Cause possible : des logs enregistrés dans cette mémoire qui occupent trop d’espace. Problème : l’installateur n’a pas le module efi_pstore qui permet d’accéder à cet espace pour vérifier et supprimer les logs le cas échéant. Pour y accéder il faudrait lancer un système live, ou bien chrooter le système en cours d’installation pour charger le module puis monter pstore à la main. Je passe.

Contournement possible : le noyau produit cette erreur s’il reste moins de la moitié d’espace libre dans la NVRAM. Il est possible de désactiver cette sécurité en passant le paramètre efi_no_storage_paranoia à la ligne de commande de l’installateur dans le menu de GRUB, mais c’est à tes risques et périls, la documentation du noyau avertit que cela peut « briquer » la carte mère si son firmware UEFI est défectueux.

Autre possibilité : lancer l’installation « expert » et lors de l’installation de GRUB, choisir

  • mettre à jour la mémoire non volatile : non pour éviter l’erreur
  • installer dans le chemin de support amovible : oui pour compenser l’absence d’entrée de boot EFI dans la NVRAM

J’ai une question d’ailleurs à ce sujet. Je met tout le temps cette histoire de mémoire volatile à non.
Est-ce un problème globalement?

Un chargeur d’amorçage EFI comme GRUB ne peut normalement pas être lancé depuis son emplacement normal (/EFI/<vendor>/xxx.efi) par le firmware UEFI sans avoir été enregistré dans les variables de boot EFI. Seul le chargeur installé dans le « chemin de support amovible » /EFI/boot/boot<arch>.efi peut être lancé sans être enregistré dans les variables de boot EFI, mais pour y installer GRUB il faut sélectionner l’option correspondante.

1 J'aime

Bonjour Pascal et merci pour toutes ces réponses.
Est-il possible d’avoir plus de détails sur ta solution, j’ai lancé en version live Debian mais je ne sais comment modifier les paramètres.
Merci à toi

j’ai la meme chose ! et est ce qu’on fait ?

J’avoue que c’est un peu complexe. J’ai tenté le lancement sur une clé usb live mais je ne savais pas quoi modifier.
J’ai tenté une réinstallation en forçant la création des partitions et d’augmenter la taille de l’EFI. J’espère que ça t’aidera…

Laquelle ? J’en ai exposé plusieurs et je n’ai pas le courage de toutes les détailler (surtout pas celle à base de chroot).

on y a un soucis 1024M pour boot est la problème

j’ai réussi ! car il faut 2 partition pour /boot et / donc ca marche :slight_smile:

Pas normal, il faut /boot et /boot/efi éventuellement.

non /boot pas efi

Donc je redis 2 /boot c’est non

linux - unable to install GRUB in dummy on debian stretch in DELL PRECISION 5510 - Super User

C’est un dual ton lien, rien à voir avec ce que tu présente

Pourriez-vous éviter de polluer la discussion avec des échanges sans rapport ?

@dawlers , Peux-tu nous donner le détail exact de ton partitionnement s’il te plait?

Pour quoi faire ? La dernière photo d’écran de @dawlers montre clairement que le message d’erreur n’a rien à voir avec le partitionnement.