Probleme ecriture avec Transmission

Tags: #<Tag:0x00007fd6e734b208>

Bonjour a la communauté !

Me voilà bien embeté, je vous explique :

J’ai deux raspberry un qui sert de NAS et un qui fait tourner transmission, respectivement RPINAS et RPISD.

Transmission doit enregistré sur RPINAS via un reseau smb mais il me dits que je n’ai pas les droits en ecriture…

Alors que hors transmission le RPISD et windows peuvent lire et ecrire dans le dossier partagé.

J’ai ajouté l’user debian-transmission a pi meme probleme.

Quelqu’un aurait une solution ?

Merci a tous (:

Bienvenue sur le forum,

Est-ce que tu peux nous donner le retour de la commande mount sur le raspi qui exécuter transmission ?

La voici :

pi@raspberrypi:~/share/stockage/torrent $ sudo mount
/dev/mmcblk0p2 on / type ext4 (rw,noatime)
devtmpfs on /dev type devtmpfs (rw,relatime,size=188260k,nr_inodes=47065,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=28,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
//192.168.1.3/public on /home/pi/share type cifs (rw,relatime,vers=3.1.1,cache=strict,username=pi,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.1.3,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=4194304,wsize=4194304,bsize=1048576,echo_interval=60,actimeo=1)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=44252k,mode=700,uid=1000,gid=1000)

Tu le montes comment ? Avec une ligne dans /etc/fstab ou avec un script ou une commande ?
Si c’est une ligne dans fstab, donne-la-moi, si c’est un script ou une commande, envoie-là. Pense à masquer les mots de passe.

pour l’instant juste avec mount, il m’est deja arrivé avec une mauvaise syntaxe de planter le RPi au demarrage… Du coup j’ai peur !

Voici la ligne ( user et code sont du tuto ) :

sudo mount -t cifs -o username=pi,password=raspberry //192.168.1.230/commun /home/pi/lien_raspi1

Alors, tu peux ajouter les options file_mode=0775,dir_mode=0775,gid=$(getent group debian-transmission | cut -d':' -f3). Ça te fait la commande suivante :

sudo mount -t cifs -o username=pi,password=raspberry,file_mode=0664,dir_mode=0775,gid=$(getent group debian-transmission | cut -d':' -f3) //192.168.1.230/commun /home/pi/lien_raspi1

Si tu le places dans fstab, pense à remplacer $(getent group debian-transmission | cut -d':' -f3) par la valeur retournée par cette commande.

En fait, la modification d’option que je fais écrase la valeur par défaut que tu peux voir dans le retour de la commande mount. Le client cifs ne gère pas les droits du serveur, ce qui fait que tu dois surcharger par des droits locaux que tu définis dans les options de montage. Là, je donne accès en lecture écriture à root et au groupe du démon transmission et en lecture seule aux autres.

ok, comme ca ca devrait etre correct ?

~/share/stockage/torrent $ sudo mount
/dev/mmcblk0p2 on / type ext4 (rw,noatime)
devtmpfs on /dev type devtmpfs (rw,relatime,size=188260k,nr_inodes=47065,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=28,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
//192.168.1.3/public on /home/pi/share type cifs (rw,relatime,vers=3.1.1,cache=strict,username=pi,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.1.3,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=4194304,wsize=4194304,bsize=1048576,echo_interval=60,actimeo=1)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=44252k,mode=700,uid=1000,gid=1000)
//192.168.1.3/public on /home/pi/share type cifs (rw,relatime,vers=3.1.1,cache=strict,username=pi,uid=0,noforceuid,gid=114,forcegid,addr=192.168.1.3,file_mode=0664,dir_mode=0775,soft,nounix,serverino,mapposix,rsize=4194304,wsize=4194304,bsize=1048576,echo_interval=60,actimeo=1)

Ok, ca a l’air de bien se passer !

J’ai pas tout compris par contre pour la ligne a ajouter dans le fstab

Alors, pour le fstab, il faut ajouter la ligne suivante :

//192.168.1.230/commun /home/pi/lien_raspi1 cifs username=pi,password=raspberry,file_mode=0664,dir_mode=0775,gid=<group>

où il faut remplacer « <group> » par le retour de la commande :

getent group debian-transmission | cut -d':' -f3

Apres reboot mon emplacement samba ne s’est pas monté… Il n’y a pas un souci avec l’emplacement qui se monte avant la connexion au reseau ?

Alors, deux choses. Déjà, est-ce que le point de montage est correctement défini dans fstab ? Pour ça, il faut lancer mount /home/pi/lien_raspi1 et voir ce que retourne la commande. Si ça fonctionne, c’est que le problème vient effectivement du fait que le réseau est activé après la tentative de montage. Sinon, c’est qu’il faut corriger quelque chose dans le fstab.
Et puis, point positif, ton raspi boot toujours.

Mince c’est la commande getent group debian-transmission | cut -d':' -f3 qui pose souci…

La reponse qui pour moi etait 114 serait une « bad option » : bad option: gid="<114>"

Pourtant :

pi@raspberrypi:~ $ getent group debian-transmission | cut -d':' -f3
114

Ben oui, tu as mis gid=<114> au lieu de gid=114.

Rhoooo merde…

Du coup ca devrait etre fonctionel !

Merci beaucoup pour ton aide !

Salut Almtesh

Encore un souci apres le reboot :

pi@raspberrypi:~ $ sudo mount /home/pi/share/
mount error(16): Device or resource busy
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Une idée du souci ?