Problème GRUB ( dual boot windows 10 & Debian 9 stable )

Tags: #<Tag:0x00007fae4a00e380>

Bonjour à tous, j’aurais besoin d’un peu d’aide :slight_smile:

( Je suis nouveau sur le forum et J’ai décidé de passer sous le noyau linux avec Debian 9 version stable. c’est la première fois que j’utilise linux et j’essaye d’appréhender ce nouvel os )

cependant je ne peux plus le lancer car il ne s’affiche pas dans le bios UEFI ni en legacy
seul windows apparaît… j’ai pourtant désactiver les options génantes ( fast boot ) et je n’ai pas de secure boot.

Ma configuration :
Lenovo y700-15isk
Windows 10 Famille & Debian 9 stable ( installé en dual boot via clé usb bootable )
1 ssd ( GPT : partition Debian & Windows ) + 1 disque dur de stockage HDD
intel core i5 6300HQ
Périphérique de démarrage : /device/HarddiskVolume3

  • J’ai donc voulu installer Debian en dual boot sur mon SSD ou windows et déjà installé
  • J’ai donc changer la table de partition de mon disque pour le mettre en GPT
  • J’ai donc créer une partition dédié à débian depuis windows 10
  • J’ai poursuivis l’installation mais cependant à la fin de l’installation : je n’ai pas directement retirer la clef USB bootable de Debian comme demander et j’ai reboot directement avec la clé dans le PC
    ( je ne sais pas si le problème peut venir de là )

J’ai donc chercher sur internet des solutions mais en vain :

  • J’ai désactiver toutes les options " fast boot "
  • J’ai entré cette ligne de commande qui a été prévu dans ma situation " C:\Windows\system32>bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi
    retournant : L’opération à réussi.

Cependant rien n’a changer je vous colle le résultat de bcdedit /enum
( je ne sais pas si cela vous sera utile ) :

Gestionnaire de démarrage Windows

identificateur {bootmgr}
device partition=\Device\HarddiskVolume3
path \EFI\debian\grubx64.efi
description Windows Boot Manager
locale fr-FR
inherit {globalsettings}
default {current}
resumeobject {06914b6e-5dfc-11e9-b09f-f301da03d483}
displayorder {current}
toolsdisplayorder {memdiag}
timeout 30

Chargeur de démarrage Windows

identificateur {current}
device partition=C:
path \Windows\system32\winload.efi
description Windows 10
locale fr-FR
inherit {bootloadersettings}
recoverysequence {06914b70-5dfc-11e9-b09f-f301da03d483}
displaymessageoverride Recovery
recoveryenabled Yes
isolatedcontext Yes
allowedinmemorysettings 0x15000075
osdevice partition=C:
systemroot \Windows
resumeobject {06914b6e-5dfc-11e9-b09f-f301da03d483}
nx OptIn
bootmenupolicy Standard

J’espère pouvoir trouver quelqu’un qui a déjà été confronté à mon problème ou qui puisse m’aider car j’aimerais vraiment travailler sur Debian qui a l’air d’être un os adapté pour mes projets dans le futur :slight_smile:

Merci à vous !!!

Salut,
Alors j’avoue que le terme GPT me parle. Je voulais le dual boot avec windows au lieu de Grub. Avec le peu d’experience que j’ai, en effet je le precise,j’ai fait fausse route.
Pour ma part, j’ai la chance d’avoir plusieurs disques, mais au pire fais une partition dédié a Linux.
Quand tu veux changer d’OS, tu boot soit sur un disque dans mon cas, ou sur une partition éventuellement.

Salut, merci de ta réponse @anon16237994 :slight_smile:

Mon disque était avant en MBR qui apparemment ne permet que de le partitionné 4 fois ce qui le limiter dans son utilisation il fallait donc le mettre en GPT pour pouvoir installé Linux.

et j’ai déjà créer une partition dédié à Linux :grin: et une autre à Windows.
Je ne sais pas en général combien de temps pourrais-je recevoir une réponse peut-être devrais-je réinstaller Debian

Nan, en fait tu t’en fout du MBR ou GPT et de mes genoux !
Tu as clairement une install Win, une install Linux, switch a travers le bios. Normalement tu peux indiquer au bios de boot sur tel ou tel disque.
Je m’explique :

  • Dual boot a la ubuntu/win via l’interface windows, c’est possible, mais c’est chaud et pis en plus c’est le mal
  • Dual boot via grub, ca marche, mais a long terme, tu te leve avec ton café a la main et il te lache sans raisons
  • chaque install a son disque, quand tu veux switch, tu tapote la touche au boot qui va sur ton bios et tu lui dit de booté la ou tu veux.

Le menu de démarrage me propose seulement Windows c’est ça le problème :frowning:

À mon avis, il vaut mieux que tu sois patient ; Des membres compétents avec ces notions d’amorçage verront ton message probablement demain.

@anon16237994 & @anon44391915

Merci pour vos réponses je vais me tenir à cela et poursuivre mes recherches pour résoudre ce problème

J’aimerais ajouter que je n’avais pas désactiver dans mes options d’alimentation " Activité le démarrage rapide "

J’ai finalement réinstaller Debian 9 et plus aucun soucis.
GRUB est effectif avec le dual boot windows 10 et debian 9 !

1 J'aime

GPT permet d’outre passer la limitation des 4 partitions primaires, de plus il ne me semble que MBR n’est plus utilisé sur les systèmes Windows préinstallé sur des PC moderne car non compatible avec l’uefi et oblige l’utilisation d’amorçage de type bios.

Farpètement.

Et des 4,3 milliards de secteurs, soit 2 Tio avec des secteurs logiques de 512 octets.

GPT permet aussi de définir des UUID et noms de partitions (PARTUUID et PARTLABEL) utilisables dans /etc/fstab et indépendants des UUID et étiquettes de contenu (UUID et LABEL) donc persistants en cas de reformatage.

Plus précisément, c’est une restriction de Windows qui exige le format GPT pour l’amorçage EFI et le format DOS/MBR pour l’amorçage BIOS/legacy. La spécification UEFI officielle supporte les deux formats pour l’amorçage (mais pas certains firmwares UEFI non conformes, hélas), ainsi que le BIOS (sauf BIOS non conforme).

Debian n’a pas de telle restriction.

@anon16237994 : Donc non, on ne s’en fout pas de MBR ou GPT quand on doit composer avec Windows ou un firmware UEFI/BIOS non conforme.

Ben si ton windows est en MBR en ou GTP, sauf erreur de ma part, Debian s’en bat les steaks non ?
Pour l’installation de Debian, c’est effectivement au niveau du bios qu’il faut faire quelques modification pour le démarrage sans UEFI et dans le contexte du sujet ouvert, je ne pense pas avoir tors.
Pour ma part, je ne souhaite pas que le démarrage de Windows soit pris en charge par Grub, je dis a mon bios de démarrer sur tel ou tel disque et c’est en ce sens que mon message allait :slight_smile:
(J’ai connu des temps ou grub effacait le MBR, et quand tu débute et que Grub part en cacahuette sans explications, c’est pas facile a prendre en charge.)

Pas si on veut lancer Windows depuis GRUB.

Donc tu t’en bats les steaks. Il ne faut pas généraliser.

Le contexte du sujet manque si cruellement d’informations sur la façon dont Windows et Debian ont été installés que je ne me risquerais pas à émettre un avis. C’est d’ailleurs pour cela que j’ai renoncé à intervenir plus tôt.

“Je pense” que tu te trompes, a partir du moment ou l’UEFI est désactivé dans le bios, grub (v2 je crois) s’installera que tu sois en MBR ou pas.

Quel est le rapport avec ce que j’ai écrit ? Je parle de lancer Windows depuis GRUB, pas d’installer GRUB.

GRUB peut s’installer dans tous les cas, avec ou sans UEFI, en DOS/MBR ou en GPT. Mais pour qu’il puisse lancer Windows il faut installer la bonne variante EFI ou BIOS. Or le mode d’amorçage de Windows est lié au type de table de partition du disque sur lequel il est installé (GPT = EFI et DOS/MBR = BIOS).

En conclusion : lancer Windows sur un disque GPT impose GRUB EFI, et lancer Windows sur un disque DOS/MBR impose GRUB BIOS.

Ho, excuses, je ferai attention aux termes employés la prochaine fois. En gros quand t’installe Debian, t’install grub aussi … En mode debutant avec un disque ou USB, l’install refuse de continuer si UEFI est activé dans le bios, tu as un placard rouge qui t’en informe, donc rien a voir avec MBR ou GPT. Bref, je pense que je me fais mal comprendre, j’arrête !

Oui, et le mode d’amorçage BIOS ou EFI de l’installateur Debian détermine la variante de GRUB correspondante qui sera installée. Il faut donc amorcer Debian dans le même mode que Windows pour pouvoir lancer Windows depuis GRUB. Sinon la sélection de l’un ou l’autre devra se faire via le menu de démarrage du firmware UEFI.

Je n’ai jamais constaté ce comportement, et bien évidemment l’installation de Debian est possible en mode EFI. Qu’appelles-tu “mode débutant” ? Quel est le message exact ?

Merci pour le complément d’informations, j’avais éludé la partie sur le nombre de secteur max.
Concernant l’autre point il est vrai que j’ai pris un raccourci, c’est très bien de l’avoir précisé.

Partition GPT on peur mettre plusieurs primaires
Mon Portable Acer Core I7 CP 2,70 GHZ Dual Core 4Go de Ram
Mais, avec un disque dur de 1To 5400 tours/min avec un Windaube !!! 10 édition familiale mais, j’ai un Windows 7 Pro installé sur mon PC donc, je vais peut -être l’installer à la place
En fait j’ai téléchargé une ISO de Ubuntu et j’ai crée une clé USB bootable ainsi
Avec un live-cd et avec Gparted j’ai réduit la partition Windows au maximum et j’ai récupéré 500 Mg pour Ubuntu.
J’ai installé en mode legacy… et,ça n’a pas marché donc, je suis revenu au mode UEFI et au boot je ne pouvais pas avoir Ubuntu
J’ai étudié la structure du disque dur et là j’ai installé le boot de Ubuntu en mode bios_grub et, j’ai partitionné le disque…et installé le système mais, ça ne marchait pas …Impossible d’avoir Ubuntu…
En redémarrant le portable, au boot de Windows j’ai appuyé sur la touche F5 et là, j’ai vu la partition système Windows et la partition Système Ubuntu Eurêka , j’ai pu démarré Ubuntu et dans le menu du Grub, j’ai vu Ubuntu, Windows et Setup…
J’ai sélectionné le le menu Setup… Le Système a redémarré et et entré dans le bios et je pu choisir Ubuntu en premier et ça marche!!!
Ci ça peut aider…