Probleme installation imprimante xerox phaser 6000B

bonjour , je viens d installer le driver
Xerox_Phaser_6010N.ppd
j ai suivis le tuto de xerox et j ai l imprimante qui est bien installé sauf que quand je lance l impression il ce passe rien !
par contre sur cpus.org j ai en état :
Inoccupée - “File “/usr/lib/cups/filter/Xerox_Phaser_6000_6010/XRM_MF” not available: No such file or directory”
donc je sais pas si c est normal ? pas de fichier dans le répertoire ?
Capture%20d%E2%80%99%C3%A9cran%20du%202020-03-24%2016-57-48
et sur debian ça a l air OK, sauf que les tache ne s imprime pas , il me dit imprimante prête mais les taches reste en attente .
voila si quelqu un pouvait m aider je suis nouveau en linux mais je me débrouille pas mas , ceci dit très content de la version 10 en gnome fluide et rapide et stable
merci

Bonsoir,

Bienvenue sur Debian.

Tout d’abord, où avez-vous téléchargé le fichier PPD ? Car je ne trouve que 6000_French_CUPS_PPD.tar sur le site de Xerox, et il contient le fichier Xerox_Phaser_6000B.ppd qui semble plus adéquat pour votre modèle d’imprimante ?

bonjour, j ai téléchargé le fichier sur le site de xerox en cherchant sur Google que je suis tombé sur celui la qui serait apparemment compatible pour Linux , mais je vais essayer le votre fichier qui correspond plus a mon imprimante , je vous tiens au courant .
merci

donc je viens d essayer en changeant le fichier , toujours , mème problème
Capture%20d%E2%80%99%C3%A9cran%20du%202020-03-25%2013-23-18
toujours , a état , le message not available no such file or directory voir la photo
quan je lance une impression j ai un message :
l impression a était arrête sur phaser 6000B
donc si vous pouviez m éclairer merci . ps : le fichier je vais le chercher dans répertoire modèles/xérox

Effectivement le fichier PPD contient une référence au fichier
/usr/lib/cups/filter/Xerox_Phaser_6000_6010/XRM_MF
, qui n’existe pas.

Il faut en fait télécharger la version anglaise, qui contient un paquet DEB que tu dois installer manuellement.
Le problème, c’est qu’il s’agit d’un vieux paquet 32 bits alors que ton système est certainement en 64 bits. Donc ouvre un terminal, puis ajoute l’architecture 32 bits sur ton système avec ceci :

sudo  dpkg --add-architecture i386

Puis installe le paquet :

sudo dpkg -i /chemin/vers/ton/fichier/xerox-phaser-6000-6010_1.0-1_i386.deb

Puis extrais le fichier
/usr/share/ppd/Xerox/Xerox_Phaser_6000B.ppd.gz
dans le répertoire de ton choix.
Enfin réinstalle l’imprimante en venant chercher ce fichier PPD. Ce fichier contient cette fois une référence au fichier
/usr/lib/cups/filter/xrhkazmf
qui est bien installé par le paquet DEB.

En résumé, le fichier PPD en français est erroné, il te faut donc installer la version anglaise. On voit d’abord si ça marche et on pourra, si tu le souhaites, franciser ton pilote a posteriori.

bon j ai un probleme dans le terminal quand je rentre l commande

sudo dpkg --add-architecture i386

et que je rentre mon mot de passe j ai ca comme réponse :

lio n'apparaît pas dans le fichier sudoers. Cet événement sera signalé

donc ce que je fait je rentre la commande SU , il me demande le mot de passe , c est ok , sauf que je passe en root@lio donc ca doit être bon , mais lorsque je rentre la commande

dpkg --add-architecture i386

il se passe rien .
après le dossier xerox-phaser-6000-6010_1.0-1_i386.deb je les mis dans le dossier modeles xerox mais pas par la commande , est ce que ça a une incidence ?
et aussi j ai extrait dans le meme dossier les 2 dossier control.tar.gz et data.tar.gz et le fichier Debian-binary et usr/share/ppd/Xerox/Xerox_Phaser_6000B.ppd.gz, mais pas par la commande le tout dans le dossier modèles XEROX , est ce que c est bon ou faut il le faire par la commande ? merci

Ce n’est pas grave, tu n’as pas configuré sudo, mais tu as trouvé la parade en passant superutilisateur avec su.

C’est normal.

Pour le reste, suis mes commandes s’il te plaît et évite les bidouilles plus qu’hasardeuses.

bon je viens de tapez la commande et voici le problème
Capture%20d%E2%80%99%C3%A9cran%20du%202020-03-25%2019-49-05

Erreur classique. Au lieu de taper su, tape su -

j ai toujours une erreur !

Tu te trompes dans le chemin de ton fichier… Ce ne serait pas Modèles[...] au lieu de /Modèles[...] ?

je comprends pas , j enlève le slash ? je mets [xerox] ? je suis nouveau sur linux et je connais pas toutes les fonctions
merci de m éclairer

Mais je ne sais pas où tu as mis ton fichier… Où est-il exactement ?
S’il est dans le dossier Modèles, dans ton dossier /home/lio :

  • si tu veux n’indiquer que le chemin relatif, alors c’est Modèles/xerox/xerox-phaser[etc.].deb
  • si tu veux indiquer le chemin absolu, ce qui peut éviter des confusions, alors : /home/lio/Modèles/xerox/xerox-phaser[etc.].deb

le problème , c est que je suis en root car quand je tape la commande LS j ai rien qui apparaît aucun répertoire le problème vient pas de la ?

Capture%20d%E2%80%99%C3%A9cran%20du%202020-03-25%2021-02-33

Capture%20d%E2%80%99%C3%A9cran%20du%202020-03-25%2021-04-20

Capture%20d%E2%80%99%C3%A9cran%20du%202020-03-25%2021-16-59

Il faut installer les paquets manquants pour l’architecture i386 :
# apt install libc6:i386 libcups2:i386

Si ça ne fonctionne pas il faudra alors peut-être modifier vite fait ton fichier de dépôts.

Plutôt que des copies d’écran, copie nous le texte des commandes et de leur résultat. C’est plus léger.

voici le résultat :
lio@lio-sa58:~$ su -
Mot de passe : 
root@lio-sa58:~# 
root@lio-sa58:~# apt install libc6:i386 libcups2:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libcups2:i386 est déjà la version la plus récente (2.2.10-6+deb10u2).
libcups2:i386 passé en « installé manuellement ».
libc6:i386 est déjà la version la plus récente (2.28-10).
libc6:i386 passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
root@lio-sa58:~# dpkg -i /home/lio/Modèles/xerox/xerox-phaser-6000-6010_1.0-1_i386.deb
(Lecture de la base de données... 188999 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../xerox-phaser-6000-6010_1.0-1_i386.deb ...
Dépaquetage de xerox-phaser-6000-6010:i386 (1.0-1) sur (1.0-1) ...
Paramétrage de xerox-phaser-6000-6010:i386 (1.0-1) ...
root@lio-sa58:~# 

voila , je sais pas si c est bon ?

merci

C’est bizarre que libc6:i386 et libcups2:i386 soient déjà installés… Ce n’était pas le cas l’avant dernière fois ! Tu es sûr que tu ne les as pas installés entre tes 2 derniers messages ?

Sinon, l’installation du paquet DEB s’est déroulée normalement. Tu n’as plus qu’à aller copier /usr/share/ppd/Xerox/Xerox_Phaser_6000B.ppd.gz dans le dossier de ton choix, le décompresser, puis aller le chercher lorsque tu installes ton imprimante dans CUPS.

le seul truc que j ai fait c est essayer ça :

root@lio-sa58:~# apt -i /home/lio/Modèles/xerox/xerox-phaser-6000-6010_1.0-1_i386.deb
E: L'option « i » de la ligne de commande [-i] n'est pas reconnue quand elle est utilisée avec d'autres options.
root@lio-sa58:~# apt-get install /home/lio/Modèles/xerox/xerox-phaser-6000-6010_1.0-1_i386.deb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 xerox-phaser-6000-6010:i386 : Dépend: libc6:i386 (>= 2.3.2) mais il n'est pas installé
                               Dépend: libcups2:i386 (>= 1.2.7) mais il n'est pas installé ou
                                        libcupsys2:i386 (>= 1.2.7) mais il n'est pas installable ou
                                        libcupsys2-gnutls10:i386 (>= 1.1.23-1) mais il n'est pas installable
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
root@lio-sa58:~# 
root@lio-sa58:~# apt remove /home/lio/Modèles/xerox/xerox-phaser-6000-6010_1.0-1_i386.deb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 xerox-phaser-6000-6010:i386 : Dépend: libc6:i386 (>= 2.3.2) mais il n'est pas installé
                               Dépend: libcups2:i386 (>= 1.2.7) mais il n'est pas installé ou
                                        libcupsys2:i386 (>= 1.2.7) mais il n'est pas installable ou
                                        libcupsys2-gnutls10:i386 (>= 1.1.23-1) mais il n'est pas installable
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
root@lio-sa58:~# 
root@lio-sa58:~# /home/lio/Modèles/xerox/xerox-phaser-6000-6010_1.0-1_i386.deb
-bash: /home/lio/Modèles/xerox/xerox-phaser-6000-6010_1.0-1_i386.deb: Permission non accordée
root@lio-sa58:~# apt remove /home/lio/Modèles/xerox/xerox-phaser-6000-6010_1.0-1_i386.deb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 xerox-phaser-6000-6010:i386 : Dépend: libc6:i386 (>= 2.3.2) mais il n'est pas installé
                               Dépend: libcups2:i386 (>= 1.2.7) mais il n'est pas installé ou
                                        libcupsys2:i386 (>= 1.2.7) mais il n'est pas installable ou
                                        libcupsys2-gnutls10:i386 (>= 1.1.23-1) mais il n'est pas installable
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
root@lio-sa58:~#

après hier Debian m a fait une mise a jour du système . et je vois qu aujourd’hui j en ai une autre .
pour copier le fichier il me faut le faire avec les commandes ? c est CP , c,est ça ? devant la commande je mets le répertoire ou il ce trouve ?

2 solutions :

  • soit avec ton gestionnaire de fichiers (tu ne devrais pas avoir besoin d’être root pour aller dans /usr/share)
  • soit en ligne de commande : cp /usr/share/ppd/Xerox/Xerox_Phaser_6000B.ppd.gz /home/lio/
    puis gunzip Xerox_Phaser_6000B.ppd.gz (pour décompresser)