Problème kernel linux et ryzen 5 2500u sur Lenovo Ideapad 330S-15ARR Ultrabook 15 Gris (Ryzen 5, RAM 8 Go, 1 To + SSD 128 Go, AMD Radeon Vega 8, Windows 10)


#1

Bonjour,
Premièrement excusez moi si je m’y suis mal pris je suis nouveau sur le forum,
J’ai un problème j’ai récemment acheté un pc portable en ryzen 5, problème il est livré avec notre cher ami windows 10 que j’ai la plus grande envie de virer, au grub d’installation de debian, je clique sur installer et là black screen, j’ai tout essayé apparemment ça viendrait d’un problème de compatibilité avec le kernel mais la plupart des infos trouvées là dessus, en anglais, se contredise toutes d’un forum a l’autre, si vous pouvez m’aider ce serait génial ca va faire 2 semaines que je me coltine ce foutu windows, merci d’avance.


#2

Bonjour,

Il faudrait peut-être essayer avec un installation de Buster, rien que pour voir si c’est bien un problème de noyau ou pas.


#3

Merci de ta réponse qu’est ce que va changer Buster exactement ? il utilise un nouveau kernel ?


#4

Il s’agit de l’actuelle testing, qui passe en stable cette année si j’ai bien compris. Du coup elle est déjà plutôt stable et permet effectivement d’avoir un noyau plus frais dès l’installation.

Si tu veux te faire une idée : https://packages.debian.org/search?keywords=linux-image-amd64


#5

merci je viens de télécharger une image je vais test je tiens au ju


#6

Bon j’ai essayé, pareil pas l’impression que ça fonctionne cette fois ça reste carrément bloqué au grub…


#7

As-tu essayé déjà avec un système live, qu’entends tu par bloqué au moment du GRUB.


#8

Oui, je suis bloqué au menu ou on choisi l’install ou le live ect… peut importe que ce soit en live ou en install ca black screen… :confused:


#9

Tu peux lancer l’installateur ? C’est l’installateur qui se bloque ou le premier démarrage ?


#10

Non, c’est l’installateur au moment ou tu choisis le mode d’installation peut importe ou je vais, en graphique, text ou expert peut importe ça black screen au moment ou je sélectionne un mode


#11

J’ai eu le même problème avec un ordi à la maison. Je connais deux distribs qui marchent avec ce CPU et les deux sont des distributions à modification permanente ce qui est moyen :

  • Suse Tumbleweed. Je déteste ce machin qui est bien différent à gérer d’une Debian mais dont je dois reconnaître qu’il marche au petit poil :wink:
  • Siduction (basée sur unstable). J’ai essayé sur l’ordi de mes gosses (un vieux portable) et j’ai eu des petits soucis, peut-être parce que l’ordi est trop vieux. Pour avoir siduction, il faut se connecter sur le forum et demander à ce qu’ils te préparent une iso toute fraîche.

T’inquiète pas, ça va marcher.


#12

merci pour l’info @lanig mais le truc c’est que c’est mon nouveau pc principal et j’ai envie de garder une disto stable avec une grosse communauté ect… j’ai pas envie de partir sur un système galère a entretenir donc j’aimerais rester sois sur ubuntu, soit sur debian, a la limite arch est intéressant mais il est assez compliqué d’approche d’ailleur arch est sur quelle base ?


#13

Un simple recherche t’aurais apporté la réponse, c’est une base propre à Archlinux :innocent:

Pour ce qui est de ton souci si une install en mode expert sans interface graphique depuis une ISO buster (c’est à dire ce qui se fait de plus récent, tout en restant assez simple … exit le bootstrap ou autre) alors c’est que Debian ne permet pas l’utilisation des firmwares adaptés pour l’instant à ton CPU mais j’ai tout de même un doute sur le fait que ce soit le CPU qui implique cet écran noir durant l’installation.

https://cdimage.debian.org/images/unofficial/non-free/images-including-firmware/


#14

j’aimerais rester sois sur ubuntu, soit sur debian

Alors, il faut essayer les bêtas de la prochaine ubuntu. Ceci dit, Suse a une grosse communauté et n’est pas du tout galère à gérer, depuis 8 mois qu’elle est sur l’ordi de mon épouse, la seule gestion que je fais c’est “zypper dup”.

mais j’ai tout de même un doute sur le fait que ce soit le CPU qui implique cet écran noir durant l’installation

Plus exactement, c’est la carte graphique intégré RX vega qui pose problème.
Plus d’infos, en particulier les kernels à utiliser, là https://forum.siduction.org/index.php?topic=7198.msg59154#msg59154.


#15

@Clochette oui c’est vrai que j’aurais pu me débrouiller pour ça ,après réflexion excuse ma question idiote ^^
j’ai essayé avec le dernier buster même problème je sais pas si ça vient réellement du cpu j’essaie de rassembler les infos que je trouve, ce que je sais c’est que mon image est bonne et que ça ne fonctionne pas, j’ai pas plus d’infos et niveau kernel j’y connais rien :confused:
@lanig je doute pas du fait que suze fonctionne bien mais j’ai mes marques sur les autres et je prefère, quand aux kernel apparement 4.19 regles les soucis mais je sais pas comment changer de kernel sur une iso


#16

Sachant que le kernel fourni par Debian 10 est le 4.19

https://packages.debian.org/buster/linux-image-amd64

mise à part tenter l’install avec le lien que je t’ai fourni précédemment jen e vois pas, les weekly-build sont parfois casse gueu… mais devrais utiliser le dernier kernel normalement (pas sur de ça tout de même).

Après il te restera la méthode bootstrap via un live cd fonctionnel :confused: mais c’est pas aussi user-friendly


#17

@SepiOz

Salut !

Ton histoire me rappelle un problème que j’avais rencontré avec un portable ASUS
qui venait du BIOS :

Pour pouvoir booter/exécuter le disque installateur

BIOS > Security > I/O interface security

New card interface ⇒ LOCKED au lieu de UNLOCKED

ou de façon temporaire au moment de choisir l’install/Live dans le menu GRUB du CD,
il fallait passer des paramètres de boot : noacpi nolapic noapic

Je n’ai pas meilleurs souvenirs/notes que cela à te fournir,
mais ça donnera peut-être des idées aux autres contributeurs

Good Luck !


#18

Une autre piste,

encore une histoire de “BIOS” => EFI a (parfois?) un paramètre “SECURE BOOT” qu’il faut désactiver pour installer autre chose que du Win ou un OS qui a payé pour être accepté par ce système de spoliation monopolistique :wc: :passport_control:


#19

merci a tous et excusez la réponse un peu tardive, j’ai essayer buster mais rien de concluant les live cd non plus ne fonctionne pas, au niveau du bios, j’ai deja fais le tour et rien n’y fait je l’install en mode legacy pas en uefi, je sais pas pourquoi mais sinon ca ne boot pas du tout, et je vois pas a quoi correspondrait ton new card interface = locked
je vais essayer quand même le noacpi noapic nolapic ensemble car je les ai essayer séparément mais pas ensemble…
je continue de chercher merci…


#20

Lors de l’expérience à la quelle je fais référence – portable ASUS X71SL (10 ans d’age) –
1 point qui pourrait être intéressant pour toi :

J’avais tenté une installation d’Ubuntu (pas retenu car instable)
mais tu pourrais tester Ubuntu en Live,
car le Live (il y a 18 mois) comportait des options de boot dans le Menu du DVD Install/Live

ça pourrait te donner des indications supplémentaires.

Il serait tout de même surprenant que cette machine soit “inbootable” sur CD

As-tu testé d’autres Live-CD ?

Pour le kernel,
je suis en testing et à jour => 4.19.0-1-amd64

Donc si ton info est bonne alors pas de problème avec testing = Buster

Tu pourrais aussi tester l’iso mini-gui de sparky-linux 5 (rolling avec testing)
https://sparkylinux.org/download/rolling/#minimal

ça marche bien, le Live utilise OpenBox => leger et rapide, ensuite après installation tu peux choisir parmi 25 Environnements différents (j’utilise XFCE)

pour l’install il vaut mieux choisir l’installateur simple (je n’ai jamais réussi l’intall avec l’autre)