Probleme mise a jour


#1

bonjour

a chaque fois que j’installe ou met a jour mon systéme une erreur apparait:

E: Cette installation va temporairement nécessiter l’enlèvement du paquet essentiel e2fsprogs en raison d’une boucle entre les champs Conflicts et Pre-Depends. C’est souvent une mauvaise chose, mais si vous souhaitez réellement le faire, activez l’option APT::Force-LoopBreak.
E: Internal Error, Could not early remove e2fsprogs

e2fsprogs, sert , si j’ai bien compris , a gerer les partitions ext2 , les miennes sont en ext3 .
puis je desinstaller ce programme ou le remplacer par un autre ?

merci d’avance


#2

bon, ext3 est de l’ext2 avec juste un journal, mais fondamentalement, c’est le même format. Tu as donc impèrativement besoin de e2fsprogs.
Par ailleurs, même si on n’utilise ni ext2 ni ext3, le paquet contient le systême “mkfs”, qui est necessaire pour brancher tous les autres formats.

Bon, as tu mis à jour tes réferentiels:
apt-get update

As tu essayé toutes les solutions d’install:
apt-get install e2fsprogs --reinstall
apt-get upgrade
apt-get dselect-upgrade
et finalement:
apt-get -f install

peux tu fournir ton /etc/apt/sources.list (éventuellement aussi les preferences) ?