Problême MRU/MTU avec PPPOE


#1

Voilà, je suis en train de reconfigurer une connection internet PPPOE, et aprés avoir règlé un problême d’authentification, j’en susi arrivé à ce problême là:Feb 14 12:20:51 routeur pppd[2481]: Plugin rp-pppoe.so loaded. Feb 14 12:20:51 routeur pppd[2482]: pppd 2.4.3 started by root, uid 0 Feb 14 12:20:52 routeur pppd[2482]: PPP session is 4853 Feb 14 12:20:52 routeur pppd[2482]: Using interface ppp0 Feb 14 12:20:52 routeur pppd[2482]: Connect: ppp0 <--> eth1 Feb 14 12:20:52 routeur pppd[2482]: Couldn't increase MTU to 1500 Feb 14 12:20:52 routeur pppd[2482]: Couldn't increase MRU to 1500 Feb 14 12:20:52 routeur pppd[2482]: Couldn't increase MTU to 1500 Feb 14 12:20:52 routeur pppd[2482]: Couldn't increase MRU to 1500 Feb 14 12:20:58 routeur pppd[2482]: Connection terminated. Feb 14 12:20:58 routeur pppd[2482]: Modem hangup
pourtant, dans mon peers/provider, j’ai ça:

user "fti/XXXXXXXX@fti" mtu 1452 mru 1452 lock ipparam provider debug noipdefault defaultroute replacedefaultroute hide-password #lcp-echo-interval 30 #lcp-echo-failure 4 noauth persist usepeerdns plugin rp-pppoe.so eth1
J’ai vérifié, c’est bien le fichier de config utilisé, j’ai testé aussi 1492, j’ai aussi modifié ça dans le fichier principal d’options, et rien n’y fait.
Quelqu’un a une idée ?


#2

slt matt,

Feb 14 12:20:51 routeur pppd[2481]: Plugin rp-pppoe.so loaded.
Feb 14 12:20:51 routeur pppd[2482]: pppd 2.4.3 started by root, uid 0

Client initialized; begin kernel init

Feb 14 12:20:52 routeur pppd[2482]: PPP session is 4853
Feb 14 12:20:52 routeur pppd[2482]: Using interface ppp0
Feb 14 12:20:52 routeur pppd[2482]: Connect: ppp0 <--> eth1
Feb 14 12:20:52 routeur pppd[2482]: Couldn't increase MTU to 1500
Feb 14 12:20:52 routeur pppd[2482]: Couldn't increase MRU to 1500
Feb 14 12:20:52 routeur pppd[2482]: Couldn't increase MTU to 1500
Feb 14 12:20:52 routeur pppd[2482]: Couldn't increase MRU to 1500

Kernel driver initialized; establish connection with peer.
The MTU and MRU are limited to 1492 (see the DSL HOWTO).

Feb 14 12:20:58 routeur pppd[2482]: Connection terminated.
Feb 14 12:20:58 routeur pppd[2482]: Modem hangup 

Je pense que ton interface eth1 a un mtu trop elevé par rapport a ton modem adsl “1452”

#ifconfig 

Et regarde le mtu.

Essaie ca.

/usr/sbin/pppoe -I eth1 -T 80 -m 1452

ou ca ;

usr/sbin/pppoe -I eth1 -T 80 -m 1412

#3

vu, j’avais pas pensé à la taille des paquets de la carte physique.
Je regarderais demain midi au boulot.


#4

bon, c’était pas ça, c’etait pppoeconf: j’ai fixé les mtu avec ifconfig sur mon eth1 et ça continuait à planter.
Alors j’ai installé pppoe (qui n’avait pas été installé par “pppoeconf”), j’ai modifié pour mettre une ligne ‘pty “pppoe -I eth1 -T 80 -m 1412”’, commenté la ligne “plugin rp-pppoe.so”, et maintenant ça marche (aprés une heure au telephone avec wanadoo pour récupèrer les bons codes…).


#5

Nickel :slightly_smiling: