Problème pour l'installation de Java 1.5 sous Ubuntu[Résolu]


#1

Bonjour,

j’ai un problème pour l’installation de Java 1.5.
J’ai suivi les conseils donnés mais lorsque je tape:

j’ai

Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait Aucune version du paquet sun-j2sdk1.5 n'est disponible, mais il existe dans la base de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète ou qu'il n'est disponible que sur une autre source E: Aucun paquet ne correspond au paquet sun-j2sdk1.5
Est ce que quelqu’un saurait d’ou vient le problème?

PS:avant de faire cette commande,j’ai fait

Merci d’avance


#2

t’es sur que c’est pas plutot sun-j2se5.0-jdk-binary voir sun-j2se6.0-jdk-binary ?


#3

Sur le site de Ubuntu c’est la commande que j’ai écrit qui est spécifié mais je ne comprends pas pourquoi ça marche pas


#4

as tu fait un petit ‘apt-cache search jdk’, pour voir si la version actuelle du paquet n’est pas la 1.7, ou qqchose comme ça et trouver le bon nom du paquet ?


#5

Bonjour,

voici le résultat de cette commande

~$ apt-cache search jdk
libc6-i686 - GNU C Library: Shared libraries [i686 optimized]
libgnujaxp-java - free implementation of jaxp api
free-java-sdk - Complete Java SDK environment consisting of free Java tools
libcommons-lang-java - Extension of the java.lang package
libnbio2-java - NBIO: Nonblocking I/O for Java, Version 2
libpgjava - Java database (JDBC) driver for PostgreSQL
mmake - Makefile generator for Java programs
usepackage - utility to manage environment variables from within dotfiles
jde - JDEE, Java Development Environment for Emacs(en)

#6

C’est surement une question de dépôt car le jdk de sun est non-free.
Sinon, tu peux le télécharger sur le site de sun et l’installer à la main.
Si j’ai bonne mémoire, quelqu’un sur le site avait fait un paquet debian…

Il existe des alternatives open source au jdk de sun mais force est de constater qu’elles ne sont pas vraiment encore tout à fait au point.

Bàt

François


#7

Alors la je comfirme, java n’est pas libre et ça doit être dans un depot non-free. Mais perso j’ai jamais trouvé le bon depot.
Sinon, j’ai télécharge un fichier j2re1.4.2_10 sur le site de sun, et ça a marché presque tout seul. J’ai juste fait un lien symbolique avec un fichier de plugin en *.so vers mozilla et firefox et c’etait bon.


#8

J’ai éventuellement fait des paquets sun-j2sdk1.4 et sun-j2re1.5 disponibles sur

deb boisson.homeip.net/sarge/ ./