Probleme reseau ethernet


#1

Salut.
Je viens d’installé en netinstall Debian testing sur mon portable. tout s’est bien passé (enfin presque mais j’ai pu me debrouillé). Ma carte reseau marché nickel, je pouvais allé sur le net… Jusqu’a ce que j’essaye d’installé ma carte wifi. je suis arrivé en grande partie à l’installé, mais j’ai un probleme de bouton (enfin j’ai laissé tombé pour le moment).
Mais en installant ma carte wifi, ca ma apporté un probleme au niveau de ma carte ethernet.
Donc j’ai desactivé ma carte wifi via la commande “modprove -r ipw2200” et toujours le meme probléme, pas de net, pas moyen de pingué le routeur…

Voila le fichier “/etc/network/interfaces”

[code]auto lo
iface lo inet loopback

mapping eth0
script grep
map eth0

allow-hotplug eth0
iface eth0 inet static
network 192.168.0.0
broadcast 192.168.0.255
# dns-* options are implementde by the resolvconf package, if installed
dns-nameservers 192.168.0.1
adresse 192.168.0.101
netmask 255.255.255.0
gateway 192.168.0.1

auto eth0
[/code]

voila aussi ce que me retourne la commande “dmesg”:

[...] lo: Disabled Privacy extensions ADDRCONF(NETDEV_UP): eth0: link is not ready IPV6 over IPv4 tunneling driver mtrr: no more MTRRs available mtrr: no more MTRRs available mtrr: no more MTRRs available mtrr: no more MTRRs available synaptics: using relaxed packet validation

Woila si quelqu’un peut m’aider.

MErci


#2

il faut regarder du coté de ce qu’il ya en ram

par exemple, ainsi que la table de routage

Cdlt,


#3

ed, voila se que me renvoie la commande "ifconfig -a "

eth0    Lien encap: Ethernet   HWaddr 00:16:36:03:B5:04
          inet adr: 192.168.0.101 Bcast:192.168.0.255 Masque: 255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500   Metric: 1
          [...]
          Interruption: 10

eth1   Lien encap: Ethernet   HWaddr 00:13:CE:9F:43:37
         UP BROADCAST MULTICAST  MTU:1500   Metric: 1
         [...]
         Interruption:11 Adresse de base:0x6000 Mémoire:b0218000-b0218fff

lo      Lien encap: Boucle locale
        inet adr:127.0.0.1   Masque: 255.0.0.0
        adr inet: ::1/128  Scope:Hôte
        UP   LOOPBACK RUNNING MTU:16436  Metric:1
        [...]
        collisions:0  lg file transmission:0

sit0   Lien encap:IPv6-IPv4
        NOARP   MTU:1480  Metric:1
        [...][/code]

et la commande "netstat -nrAinet" me renvoie ca:

[code]table de routage IP noyau
desination     Passerelle     Genmask       Indic   MSS Fenétre  irtt  Iface
192.168.0.0   0.0.0.0        255.255.255.0   U      0    0        0   eth0
0.0.0.0       192.168.0.1   0.0.0.0          UG     0    0        0    eth0

Je precise que l’adresse de mon routeur est 192.168.0.1, et le dhcp est désactivé.


#4

Bon je ne suis pas arrivé à trouvé d’ou provené le probléme. Donc j’ai réinstallé debian (je sais que C pas la meilleur solution, mais bon).

L’installation en netinstall s’est bien passé (noyau 2.6.15-1-486).

Une fois débian demarrée, je teste pour voir si internet fonctionne (aucun soucis, ca marche nickel) donc je commence à configurée ma carte son ainsi que ma carte graphique (toujours aucun soucis) et j’en arrive à la carte wifi.
Lors du demarrage, j’ai constaté que “ipw2200” ne se chargé pas à cause du firmware, donc j’ai copier les fichiers du firmware dans “/usr/lib/hotplug/firmware/”.

Je redemarre debian, ipw2200 se charge bien, par contre y’a un temp d’attente au niveau de “starting MTA” (que je n’avais pas avant d’avoir installé le firmware)… Une fois arrivé sous Gnome, je test internet, et la grosse surprise plus de net.
Je fais un “ifconfig” est la j’ai “eth0” (ma carte ethernet), “eth1” ( ma carte wifi, mais je trouve bizar qu’elle soit nomée eth1) et “lo” (boucle locale)

Donc si quelqu’un avait une solution, je pense que C un probléme de confli entre ma carte reseau et ma carte wifi, mais la je bloque…

Merci


#5

Elles ont des adresses IP différentes ?
Regarde quelle est ta passerelle par défaut.
Sinon tu peux désactiver ta wifi en faisant un ifdown eth1 et réessaie pour voir si internet passe sur la carte filaire.


#6

j’ai bien désactivé la carte wifi, mais toujours pareil, le fait de mettre le firmware et qu’il se charge au demarrage cause un probleme…

Woila ce que j’ai dans mon “/var/log/messages”


#7

un peu bref :mrgreen:


#8

[quote=“FRéDaNGeL”]j’ai bien désactivé la carte wifi, mais toujours pareil, le fait de mettre le firmware et qu’il se charge au demarrage cause un probleme…

Woila ce que j’ai dans mon “/var/log/messages”[/quote]

Pourquoi dis-tu que c’est le firmware qui pose problème ?


#9

[quote=“fsoumil”][quote=“FRéDaNGeL”]j’ai bien désactivé la carte wifi, mais toujours pareil, le fait de mettre le firmware et qu’il se charge au demarrage cause un probleme…

Woila ce que j’ai dans mon “/var/log/messages”[/quote]

Pourquoi dis-tu que c’est le firmware qui pose problème ?[/quote]

Je sais pas. C’est vrai que je doute fort que ce soi le firmware qui cause ce probléme.
Par contre je pense que le fais de mettre le firmware et que la carte wifi s’initialise bien, cause un conflit entre la carte ethernet et la carte wifi.


#10

Est-ce que tu arrives encore à faire fonctionner ta carte ethernet lorsque tu désactives ta wifi ?
Les modules reseau sont charges par udev ou via /etc/modules ?


#11

Non, ca bloque toujours

Je pense que c’est udev, car dans “/etc/modules” y’a rien qui est en rapport avec le reseau.


#12

je propose, tout à fait au pif (en regardant certains des messages d’erreur) de desactiver carrément l’IPV6:
avec noyau 2.6 il faut créer un fichier /etc/modprobe.d/off, ou on met les modules qu’on veut bannir, avec dedans, dans le cas du net-pf-10 (c.à.d. l’ipv6):alias net-pf-10 off
ça peut servir aussi pour mettre “off” des modules qui râlent au démarrage, et qui n’ont rien à faire là. Chez moi, j’avais hw_random, et je ne voulais pas voir se charger les modules rivafb ni nvidiafb, qui entraient en conflit avec le module nvidia propriètaire, par exemple.


#13

Ok, donc si je comprends bien, tu n’as pas plus du tout de réseau sur ta machine (ni ethernet ni wifi)… Je sais, je mets du temps à comprendre (Je suis belge :smiley: )
Que te dis ifconfig ?
et /etc/init.d/networking restart ?
et ton /etc/network/interfaces il contient quoi ?

François


#14

et au fait, ton fichier /etc/network/interfaces, c’est en recopiant que tu as mis un e à addresse ?
Parceque sinon, je te rapelles que c’est address avec 2 ‘d’, mais sans e.:mrgreen:


#15

[quote=“MattOTop”]et au fait, ton fichier /etc/network/interfaces, c’est en recopiant que tu as mis un e à addresse ?
Parceque sinon, je te rapelles que c’est address avec 2 ‘d’, mais sans e.:mrgreen:[/quote]
Oui oui c’est en recopiant.

[quote=“MattOTop”]je propose, tout à fait au pif (en regardant certains des messages d’erreur) de desactiver carrément l’IPV6:
avec noyau 2.6 il faut créer un fichier /etc/modprobe.d/off, ou on met les modules qu’on veut bannir, avec dedans, dans le cas du net-pf-10 (c.à.d. l’ipv6):

ça peut servir aussi pour mettre “off” des modules qui râlent au démarrage, et qui n’ont rien à faire là. Chez moi, j’avais hw_random, et je ne voulais pas voir se charger les modules rivafb ni nvidiafb, qui entraient en conflit avec le module nvidia propriètaire, par exemple.[/quote]
Toujours pareil, par contre l’IPv6 n’a pas l’air de s’activée.

[quote=“fsoumil”]
Ok, donc si je comprends bien, tu n’as pas plus du tout de réseau sur ta machine (ni ethernet ni wifi)… Je sais, je mets du temps à comprendre (Je suis belge Very Happy )
Que te dis ifconfig ?
et /etc/init.d/networking restart ?
et ton /etc/network/interfaces il contient quoi ?

François.[/quote]

ifconfig :

[code]eth0 Lien encap:Ethernet HWaddr 00:16:36:03:B5:04
inet adr:192.168.0.101 Bcast:192.168.0.255 Masque:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interruption:10

eth1 Lien encap:Ethernet HWaddr 00:13:CE:9F:43:37
inet adr:192.168.0.103 Bcast:192.168.0.255 Masque:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interruption:11 Adresse de base:0xa000 Mémoire:b0218000-b0218fff

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:148 errors:0 dropped:0 overruns:0 frame:0
TX packets:148 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:10038 (9.8 KiB) TX bytes:10038 (9.8 KiB)[/code]

/etc/init.d/networking restart :

Reconfiguring network interfaces...ifup: interface lo already configured done.

/etc/network/interfaces :

[code]# This is a list of hotpluggable network interfaces.

They will be activated automatically by the hotplug subsystem.

mapping eth0
script grep
map eth0

The primary network interface

allow-hotplug eth0
iface eth0 inet static
address 192.168.0.101
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 192.168.0.1

iface eth1 inet static
address 192.168.0.103
netmask 255.255.255.0
gateway 192.168.0.1

auto eth1

auto eth0[/code]

voila.


#16

eth0 et eth1 ne peuvent pas être sur la même frange:
mets en une sur 192.168.1.XXX pour voir.


#17

[quote=“MattOTop”]eth0 et eth1 ne peuvent pas être sur la même frange:
mets en une sur 192.168.1.XXX pour voir.[/quote]

Avant d’apportée les modifications, j’ai rebooté, et j’ai se message:

Sinon apres j’ai changé eth1 de frange. Voila le nouveau /etc/network/interfaces :

[code]# This is a list of hotpluggable network interfaces.

They will be activated automatically by the hotplug subsystem.

mapping eth0
script grep
map eth0

The primary network interface

allow-hotplug eth0
iface eth0 inet static
address 192.168.0.101
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1

dns-* options are implemented by the resolvconf package, if installed

dns-nameservers 192.168.0.1

iface eth1 inet static
address 192.168.1.103
netmask 255.255.255.0
gateway 192.168.1.1

auto eth1

auto eth0[/code]

Ensuite je fais:
/etc/init.d/networking restart
Et ca me renvoie:

Reconfiguring network interfaces...SIOCDERT: No such process ifup: interface lo already configured done.


#18

le ‘networking stop’ est plus RedHat que debian.
Sous debian, tu peux te contenter de ‘ifdown -a’ et ‘ifup -a’


#19

Déjà, je vois qu’au /etc/init.d/networking restart, il n’active que l’interface lo. --> PAS normal
Je me plonge dans ton interface et je te tiens au courant…


#20

Est-ce normal que les gateway pour eth0 et eth1 soient differentes ?
A mon avis, cela devrait être 192.168.0.1 pour les 2 (adresse de ton routeur je suppose)