Problème réseau sur Debian et ESXi 6.7


#1

Bonjour, c’est la première fois que je vais sur un forum alors j’espère que je vais bien m’exprimer.

J’ai configuré un serveur Debian pour héberger une instance Nextcloud. Le serveur est fonctionnel mais de temps en temps, j’ai des difficultés à y accéder depuis l’Internet.
Je me suis rendu compte que le problème vient de la carte réseau qui doit perdre sa passerelle par défaut.

Je suis sous ESXi 6.7, j’étais avec le pilote E1000 et je suis passé au VMXNET3. le problème est le même avec les deux pilotes.

Avez vous une idée ou une piste à suivre ?


#2

Bonjour,

Est-ce que le ESXi 6.7 joint correctement (sans perte) le WAN (internet) ? Si oui, est-ce que ton vSwitch est correctement configuré ? Si oui, est-ce que la machine virtuelle joint correctement le LAN ?

Je pense que ça n’a rien à voir puisque de Debian s’en sort bien avec le VMXNET3, mais as-tu installé les vmtools ? Te prends pas le chou avec ceux de VMware, ceux dispo dans Debian fonctionnent parfaitement :

apt install open-vm-tools

Petite remarque : E1000 ou VMXNET3 ne sont pas des pilotes, mais des références de matériel émulé. En gros, c’est comme si tu avais une carte réseau Broadcom ou Realtek par exemple. Attention, je ne dit pas que Broadcom égal E1000 ni VMXNET3 égal Realtek, c’est une image par rapport au monde du physique.


#3

Merci pour ta réponse, j’ai bien installé les VMware tools de VMWARE ainsi que les open-vm-tools.
J’ai plusieurs VM d’installées et elles n’ont pas de soucis pour aller sur Internet.

Quand ma VM Debian n’est plus accessible d’Internet, elle fonctionne parfaitement de LAN.
Je ne sais pas de qui peut poser problème… :thinking:


#4

Installer les deux n’a aucun intérêt, d’où ma réponse.

Quelle est la configuration réseau de ta Debian? Est-ce que la passerelle par défaut répond toujours lorsque le problème survient?


#5

Que veux-tu savoir sur la configuration réseau ?
Je suis sur un réseau en 192.168.1.0/24 avec ma passerelle en 192.168.1.1 (Stormshield)
Ma passerelle répond bien mais pas d’accès à Internet comme si ma passerelle avait sautée. Ma VM Debian à bien marché pendant 6 mois avant que ce problème survienne, ce qui est étonnant je trouve.

Faut-il que j’en désinstalle un des deux ?


#6

En gros, la sortie de:

cat /etc/network/interfaces

Hum. Elle répond, mais saute? Les routes sont correctes?

En six mois, il peut s’en passer des choses dont notamment des mises à jour ou changement de configuration (pas forcément que sur l’OS d’ailleurs).

Comme ça, je dirais oui, mais un instantané de la VM avant de le faire peut être pas mal. En théorie, avoir les deux ne pose pas de soucis, mais comme je n’ai jamais tenté…

Concernant ton soucis de perte d’internet, tu n’as rien dans les journaux?
Lors d’une coupure, que donne la commande suivante:

traceroute www.qwant.fr

#7
# The loopback network interface
auto lo
iface lo inet loopback
auto ens160
iface ens160 inet static
	address 192.168.1.200
	netmask 255.255.255.0
	gateway 192.168.1.1

J’ai que la route par défaut

www.qwante.fr: Échec temporaire dans la résolution du nom
Cannot handle "host" cmdline arg 'www.qwante.fr' on position 1 (argc 1)

J’ai trop de mal a reprendre le réseau sur cette VM. Elle n’est de nouveau inaccessible.

Les DNS sautent dès qu’elle redémarre…


#8

J’ai supprimé network-manager qui me posait problème avec le fichier resolv.conf,
Les DNS semblent fonctionner à nouveau


#9

Donc deux lignes si tu fais la commande suivante?

ip route

C’est normal, y a pas de e à qwant…

Les DNS doivent être configurés dans /etc/resolv.conf. Moi j’ai ça:

nameserver 80.67.169.12
nameserver 80.67.169.40

#10

Avec Network-Manager, le fichier resolv.conf est un lien avec un autre fichier. En le désinstallant, j’ai retrouvé mon fichier resolv.conf.

Donne 2 lignes avec la passerelle et le LAN.


#11

Du coup, ça en est où?


#12

Salut,

Je galère toujours avec l’accès depuis l’extérieur, je n’arrive pas à savoir si c’est le port 443 qui pose problème ou si c’est mon serveur Debian. Faut que je test la redirection du port 22 par exemple pour voir si lui fonctionne.
Je m’arrache un peu les cheveux sur ce phénomène…


#13

C’est quoi cette histoire de port 443 ?


#14

C’est le port d’écoute de mon serveur Nextcloud


#15

Alors attends, je suis paumé.
Ta VM perd internet ou alors tu n’arrive plus a accéder à ton NextCloud?


#16

Oui c’est à peu prêt ça, mais là elle a retrouvée internet mais Nextcloud est toujours inaccessible