Problème résolution : Écran inconnu


#1

Salut à tous,

Alors voilà, je rencontre un souci au niveau de ma carte graphique et de ses pilotes, ce qui empêche je pense mon écran d’être détecté correctement. Ma carte graphique est une NVIDIA geForce 7500 LE.
Donc je sais pas si c’est au niveau des drivers ou de l’écran, je pencherai plus pour les drivers, mais mon écran n’est pas détecté.

Après avoir lu des pages de wiki, je vois pas quel solution adopté, j’en ai essayé pas mal, je viens donc voir si vous sauriez m’aider à la trouver. :slightly_smiling:

Version des pilotes actuelle : 195.36.31 (Non-free)
Méthode d’installation utilisée : Compilation (suivi le tutoriel suivant : http://wiki.debian.org/NvidiaGraphicsDrivers)

Caractéristiques de l’écran :
http://www.lcd-compare.com/moniteur-ASUVH242H-ASUS-VH242H.htm

Je joins mon fichier de Xorg.0.log,
Xorg.0.log (16 KB)
On peut noter, que je n’ai aucune erreur(EE) dedans.

J’ai essayer de configurer mon xorg.conf comme il faut à l’aide de http://wiki.debian.org/fr/Xorg mais sans succès.

Mon xorg.conf étant actuellement celui ci :

[code]
Section “Module”
Load “glx”
EndSection

Section “Device”
Identifier “Video Card”
Driver “nvidia”
EndSection[/code]

Il contient le strict minimum, j’ai essayé de le faire comme conseillé dans le tutoriel à cette partie : http://wiki.debian.org/NvidiaGraphicsDrivers#Create_an_xorg.confs

La dernière résolution a été ajouté manuellement, malgré que j’ai l’erreur, mais je ne peux pas la sélectionné.
Notons, qu’avec les pilotes Nouveau, je peux avoir une résolution de 1920x1080 avec la méthode xrandr qui est la résolution normalement maximum de mon écran et je n’obtiens pas l’erreur Failed to get size of gamma for output default.

Mais obligé de rerégler, avec le xrandr à chaque fois, la modification dans le xorg.conf n’est pas correctement prise en compte ou je l’ai mal faite.

Donc la je suis de retour avec les pilotes propriétaires NVIDIA et je crois que normalement tout y est : #dpkg --get-selections | grep nvidia libgl1-nvidia-alternatives install libgl1-nvidia-glx install libglx-nvidia-alternatives install nvidia-glx install nvidia-kernel-2.6.32-5-686 install nvidia-kernel-common install nvidia-kernel-source install nvidia-settings deinstall nvidia-vdpau-driver install

(nvidia-settings est marqué comme désinstallé mais je l’ai quand même :O)

Après pour les réglages “automatiques” si je puis dire avec le NVIDIA xserver settings , j’ai un panel de résolution de allant de 320x240 à 1360x768, alors qu’avec celui de Debian Système > Préférences > Ecrans : j’ai de 320x240 à 1024x768 (résolution actuelle ^^), quand je clique sur detecté Ecran que ce soit dans le Nvidia settings ou sur le panel de Debian, ca n’a aucun effet. Actuellement dans le Nvidia settings mon écran est marqué comme : CRT-0 (youhou!! :unamused: )

J’ai essayé d’être super complet pour vous informer le plus sur la situation, je viens pas la les mains vides hein’ :005 , j’ai fait des recherches toute la journée :013 malgré que c’est super instructif quand on y arrive pas au bout d’un moment, ca soule donc je viens à vous, en espérant que vous arriverez à m’aider. Merci d’avance :wink:

Infos supplémentaires :

Accélération matérielle : c’est ok. Et le glxgears fonctionne.


#2

Un petit up :slightly_smiling:


Suite MAJ driver nvidia erreur "Failed at step EXEC spawning /bin/plymouth : no such file or directory"
#3

salut.

quand j’installe mon pilote nvidia j’utilise invariablement la même méthode,je me logue en single user,je flingue le serveur X,et ensuite:

quand l’affaire est dans le sac j’envoie:

ensuite:

et je termine par:

jamais le moindre problème.

Si tu as essayé d’installer le .run avant toute chose tu fais:


Suite MAJ driver nvidia erreur "Failed at step EXEC spawning /bin/plymouth : no such file or directory"
#4

Salut marcastro,

Je vais retenter comme tu me dis malgré que cette méthode j’ai déjà essayé de l’utilisé et que le résultat n’avait pas été concluant.
Je vais tout de même réessayer… il n’y a que ça à faire. Pour ce qui est du .run, j’ai tout d’abord utiliser la méthode “propre” avec le module assistant avant d’essayer celle du .run, et j’ai bien fait le

#nvidia-installer --uninstall avant de recommencer mes manipulations.

J’édite ce message pour donner le résultat :

Rien de nouveau, toujours au même stade, mais j’ai noté ca à la sortie de nvidia-xconfig: (il y avait d’autres warning mais il parlait du clavier, etc…)

Mon xorg.conf actuel :

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (pbuilder@windlord)  Sun Jun 13 06:03:17 UTC 2010

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Device"
    Identifier     "Video Card"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Video Card"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

#5

C’est bon, j’ai réussi à résoudre mon problème.
Voici un mini tutoriel lorsque vous avez un problème de détection d’écran non reconnu par votre carte graphique NVIDIA :

  • Installer vos pilotes NVIDIA avec votre méthode préférée.
  • Après quelques modifications de votre fichier xorg.conf s’impose :

Tout d’abord vous aurez besoin des caractéristiques de votre écran, prenez par exemple un site comme http://www.lcd-compare.com/
qui fournit des caractéristiques détaillées sur beaucoup d’écrans.
Relevez les lignes suivantes dans les caractéristiques :

Résolution / Fréquence : <Résolution de votre écran>
(Fréquence de balayage vertical)
Synch. Vert. Analogique : Mini : <Frequence_mini_de_votre_ecran> Hz / Maxi : <Frequence_maxi_de_votre_ecran> Hz
(Fréquence de balayage horizontal)
Synch. Hor. Analogique : Mini : <Frequence_mini_de_votre_ecran> kHz / Maxi : <Frequence_maxime_de_votre_ecran> kHz

Vous possédez les marges de fréquences de rafraîchissement pour votre écran ainsi que sa résolution maximum, vous pouvez donc générer la résolution qui convient à votre écran :

Utiliser gtf qui calcule les modes GTF vesa.
Manuel de GTF : http://marionpatrick.free.fr/man_html/html/gtf_1.html

N.B : Plus la fréquence de rafraîchissement sera élevé, meilleur sera le confort visuel.

Vous devriez avoir en sortie, quelque chose de ce style :

Copiez ce résultat.

Passez en root et éditer le fichier /etc/X11/xorg.conf.
Avant toute modification, pensez à faire une copie de ce fichier, histoire qui si vous faites une mauvaise manipulation, vous puissiez récupérerez l’ancienne configuration, même si celle ci n’est pas optimale.

Tout d’abord, ajouter une section Monitor si elle n’existe pas déjà, sinon adapter la au modèle suivant :

Section "Monitor"
Identifier “<Votre nom d’écran>”
#Remplacer par les fréquences mini. et max. de balayage horizontale correspondant à celle de votre écran que vous avez normalement relevées
HorizSync 30.0 - 83.0
#Remplacer par les fréquences mini. et max. de balayage verticale correspondant à celle de votre écran que vous avez normalement relevées
VertRefresh 50.0 - 75.0
#Remplacer par le modeline que vous avez copié précédemment
Modeline “1920x1080_75.00” 220.64 1920 2056 2264 2608 1080 1081 1084 1128 -HSync +Vsync
#Remplacer par la partie entre guillemets dans votre modeline
Option “PreferredMode” "1920x1080_75.00"
EndSection

Ensuite, ajouter une section Screen si elle n’existe pas déjà, sinon adapter la au modèle suivant :

Section "Screen"
Monitor "<Votre nom d’écran>"
Identifier "Default Screen"
Device ""
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"
EndSubSection
EndSection

Redémarrez l’ordinateur (un restart du serveur X devrait peut-être suffire mais je préfère faire un reboot) , et normalement, c’est tout bon :slightly_smiling:
Si la résolution n’est pas réglé au démarrage, allez tout de même voir dans Système > Administration > NVIDIA X Server Settings.
Dans l’onglet X Server Display Configuration, vous pouvez choisir la résolution, vous devriez voir apparaître la résolution souhaité, choisissez là et appliquer les changements. Ça devrait être bon.

Si vous avez des remarques, des explications plus détaillés à fournir, des questions par rapport à ce mini tutoriel, n’hésitez pas à poster.
Je n’hésiterai pas à corriger et améliorer ces explications.

Voilà en espérant que ça fonctionnera pour vous aussi.

Liens relatifs :
http://wiki.debian.org/XStrikeForce/HowToRandR12


#6

[quote=“Skw33d”]C’est bon, j’ai réussi à résoudre mon problème.
Voici un mini tutoriel lorsque vous avez un problème de détection d’écran non reconnu par votre carte graphique NVIDIA :

  • Installer vos pilotes NVIDIA avec votre méthode préférée.
  • Après quelques modifications de votre fichier xorg.conf s’impose :

Tout d’abord vous aurez besoin des caractéristiques de votre écran, prenez par exemple un site comme http://www.lcd-compare.com/
qui fournit des caractéristiques détaillées sur beaucoup d’écrans.
Relevez les lignes suivantes dans les caractéristiques :

Résolution / Fréquence : <Résolution de votre écran>
(Fréquence de balayage vertical)
Synch. Vert. Analogique : Mini : <Frequence_mini_de_votre_ecran> Hz / Maxi : <Frequence_maxi_de_votre_ecran> Hz
(Fréquence de balayage horizontal)
Synch. Hor. Analogique : Mini : <Frequence_mini_de_votre_ecran> kHz / Maxi : <Frequence_maxime_de_votre_ecran> kHz

Vous possédez les marges de fréquences de rafraîchissement pour votre écran ainsi que sa résolution maximum, vous pouvez donc générer la résolution qui convient à votre écran :

Utiliser gtf qui calcule les modes GTF vesa.
Manuel de GTF : http://marionpatrick.free.fr/man_html/html/gtf_1.html

N.B : Plus la fréquence de rafraîchissement sera élevé, meilleur sera le confort visuel.

Vous devriez avoir en sortie, quelque chose de ce style :

Copiez ce résultat.

Passez en root et éditer le fichier /etc/X11/xorg.conf.
Avant toute modification, pensez à faire une copie de ce fichier, histoire qui si vous faites une mauvaise manipulation, vous puissiez récupérerez l’ancienne configuration, même si celle ci n’est pas optimale.

Tout d’abord, ajouter une section Monitor si elle n’existe pas déjà, sinon adapter la au modèle suivant :

Section "Monitor"
Identifier “<Votre nom d’écran>”
#Remplacer par les fréquences mini. et max. de balayage horizontale correspondant à celle de votre écran que vous avez normalement relevées
HorizSync 30.0 - 83.0
#Remplacer par les fréquences mini. et max. de balayage verticale correspondant à celle de votre écran que vous avez normalement relevées
VertRefresh 50.0 - 75.0
#Remplacer par le modeline que vous avez copié précédemment
Modeline “1920x1080_75.00” 220.64 1920 2056 2264 2608 1080 1081 1084 1128 -HSync +Vsync
#Remplacer par la partie entre guillemets dans votre modeline
Option “PreferredMode” "1920x1080_75.00"
EndSection

Ensuite, ajouter une section Screen si elle n’existe pas déjà, sinon adapter la au modèle suivant :

Section "Screen"
Monitor "<Votre nom d’écran>"
Identifier "Default Screen"
Device ""
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"
EndSubSection
EndSection

Redémarrez l’ordinateur (un restart du serveur X devrait peut-être suffire mais je préfère faire un reboot) , et normalement, c’est tout bon :slightly_smiling:
Si la résolution n’est pas réglé au démarrage, allez tout de même voir dans Système > Administration > NVIDIA X Server Settings.
Dans l’onglet X Server Display Configuration, vous pouvez choisir la résolution, vous devriez voir apparaître la résolution souhaité, choisissez là et appliquer les changements. Ça devrait être bon.

Si vous avez des remarques, des explications plus détaillés à fournir, des questions par rapport à ce mini tutoriel, n’hésitez pas à poster.
Je n’hésiterai pas à corriger et améliorer ces explications.

Voilà en espérant que ça fonctionnera pour vous aussi.

Liens relatifs :
http://wiki.debian.org/XStrikeForce/HowToRandR12[/quote]

T’as de la chance, ça fait quinze jours que je triture le xorg.conf pour obtenir une fréquence de 60 Hz.

J’ai bien 1680x1650 dans “Affichage” mais une fréquence de 50 Hz alors que la fréquence de mon moniteur par la commande xrandr (et gtf ausii) me donne une fréquence 60 Hz.
Impossible de modifier la fréquence, impossible également de modifier les parametres du serveur NVIDIA avec nvidia-settings.

J’ai modifié le xorg.conf dans tous les sens ( modeline, prefferrmode, etc…), rien n’y fait!

Le problème est probablement là::

Dans le xorg.0.log, on voit qu’il charge le mode “nvidia-auto-select” avec un module “ramdac”.

Mais nulle trace de l’un ou l’autre dans le systeme …


#7

quelle est ta carte nvidia?quelle version debian?


#8

nvidia Geforce 5200, Wheezy…


#9

pour installer ton pilote:

et dans une console user tu fais:

tu verras les drivers nvidia disponibles pour ta carte et les différentes options d’installation

ensuite:

tu renseignes le user et le passwd et ensuite tu passes root,et en root tu fais simplement:

sgfxi pour installer le driver par défaut ou alors tu fais:


#10

typo,faute de frappe,il faut lire:


#11

Merci pour ton aide, mais tout ça c’est fait.

En fait ma carte ayant des pb d’affichage avec le driver nouveau, j’ai installé le driver propriétaire (nvidia).

Je n’ai pas de pb spécifique sauf que dasn “affichage” j’ai 50 Hz alors que pour 1680x1650 mon écran est en 60 Hz.

Impossible de changer quoi que ce soit par le xorg.conf ( modeline, etc…) ou par “parametres du serveur nvidia”.

Il semblerait que Xorg charge un module ramdax et installe un mode par default.

Extrait du xorg.0.log:


#12

j’ai aussi une carte nvidia et il me semble que avant d’installer le pilote proprio j’avais viré le driver nouveau.
As tu installé nvidia-settings?


#13

[quote=“marcastro”]j’ai aussi une carte nvidia et il me semble que avant d’installer le pilote proprio j’avais viré le driver nouveau.
As tu installé nvidia-settings?[/quote]
J’ai enlevé le nouveau.

J’ai nvidia settings mais dans “Xserver Display configuration” j’ai:

[i]Unable to load X Server Display Configuration page:

The NVIDIA X driver on Wheezy:0.0 is not new
enough to support the nvidia-settings Display Configuration page.
[/i]


#14

quel pilote actuellement installé?
regarde cette page:

http://www.nvidia.fr/Download/Find.aspx?lang=fr

pour voir le pilote


#15

[quote=“marcastro”]quel pilote actuellement installé?
regarde cette page:

http://www.nvidia.fr/Download/Find.aspx?lang=fr

pour voir le pilote[/quote]
Je crois que tu n’as pas saisi mon pb. Je n’ai pas de pb avec le driver (j’ai bien le 173.14.35), mais je ne peux pas modifier les paramètres d’affichage de mon écran.

A priori le fichier xorg.conf n’est pas pris en compte, nvidia-settings ne permet pas de modifier les paramètres et dans affichage c’est gelé également…


#16

montre lspci


#17


#18

[quote]The NVIDIA X driver on Wheezy:0.0 is not new
enough to support the nvidia-settings Display Configuration page.[/quote]

et le driver en question est le plus récent,il doit y avoir un bug sur wheezy concernant l’installation du pilote.
essaye peut être avec un pilote plus ancien?


#19

[quote=“marcastro”]et le driver en question est le plus récent,il doit y avoir un bug sur wheezy concernant l’installation du pilote.
essaye peut être avec un pilote plus ancien?[/quote]

Le plus récent c’est “nouveau” ( xserver-xorg-video-nouveau 1:0.0.16+git20120322+ab7291d-1 ).

Moi j’ai le “nvidia” ( xserver-xorg-video-nvidia-legacy-173xx 173.14.35-2 ) …


#20

tu ouvres synaptic et tu vires tous les paquets qui contiennent nvidia ,si tu avais tenté d’installer un .run de chez nvidia tu le vires aussi avec la commande:

et ensuite tu relances l’installation avec le script sgfxi comme indiqué plus haut