Problème rsync sur serveur local

Tags: #<Tag:0x00007fd6e5fb7958>

Bonjour à tous,
J’ai sur mon réseau local :

  • Un serveur qui tourne sour Debian
  • Un Raspberry sur lequel j’ai monté un disque dur externe
  • Un mac pour administrer tout ça avec ssh

Je souhaite faire un rsync depuis le Debian vers le Raspberry, à des fins de sauvegarde.
A des fins de tests, j’essaye de transférer le dossier /var/cache du Debian vers le dossier /usb/media sur Raspberry, là où est monté mon disque dur.
Voici la commande que je lance (depuis OSX via terminal):

    sudo rsync -r -e ssh /var/cache pi@192.168.0.30/22:/usb/media/

Et voici l’erreur qu’il me retourne :

rsync: mkdir "/home/thibault/pi@192.168.0.30/22:/usb/media" failed: No such file or directory (2)
rsync error: error in file IO (code 11) at main.c(682) [Receiver=3.1.3]

le ‹ /home/thibault/pi@192.168.0.30/22 › me fait penser que le serveur ne comprend pas que je veux envoyer les fichiers vers un autre serveur, mais qu’il pense que je veux les placer en local dans le dossier /home/thibault/pi@192… qui bien sûr n’existe pas.

Quelqu’un a-t-il une idée pour résoudre ce problème ?

Merci d’avance :slight_smile: :slight_smile:
Thibault

Tu peux essayer avec ces options ?

rsync -avz /var/cache pi@192.168.0.30:/usb/media/

Tu n’as pas besoin de préciser le port 22 (en tout cas de cette manière, ni de préciser le protocle SSH de cette manière :wink:

Le a permet de grouper les principale options, pratique et souvent utilisé, v pour le mode verbose (il peut-être omis) et le z compresse pour gagner en bande passante.

CF : manuel de rsync :wink:

Merci pour ton retour rapide :slight_smile:
Enfait, je pensais que comme sur le client j’utilise un autre port que le 22, je devais spécifier que le serveur n’utilisait pas le même port que le client (?).
Voici la syntaxe que j’ai utilisé suite à ton message :
sudo rsync -avz /var/cache -e "ssh -p 22" pi@192.168.0.22:/media/usb

Cependant, maintenant il ne parvient pas à se connecter. Certainement que je dois configurer les histoires de clés ssh… Je vais explorer ça :wink:

Soit j’ai loupé un truc soit ton ip n’est pas correcte c’est en 0.22 ou en 0.30 ?

Je te le répète tu n’a pas besoin sur le client de préciser le port SSH.

Oups, c’était bien en .30 !
C’est bon, tout fonctionne. Merci pour ton aide :slight_smile: