Probleme sur eth0


#1

bonjour a tous,

je suis passé d’un serveur window NT a un serveur debian. Pour faire un serveur CVS c’est plus pratique mais la je commence a regretter mon NT car j’ai un probleme qui commence a m’enerver.

Voila ma configuration:

Debian Sarge sans interface graphique (dans un placard) qui me sert de serveur
un modem Fast 800
Un réseaux privé deriere .

Mon problème:

Quand je lance mon serveur tout ce passe bien, je me conecte en ssh dessus pour lancer internet et mon partage de connexion. Mon réseau fonctionne a merveille. Cependant au bout de quelque temps 5 ou 6 heures , mon interfaces eth0 tombe, je n’est plus acces a mon serveur par le réseau local.
J’ai mis en place un script bash:
#!/bin/bash
while [ true ]
ifconfig eth0 down
ifconfig eth0 up
sleep 1800
done

donc c’est un peu foireux et je pensais prevenir le probleme. Mais ca ne marche tjs pas.
Si vous avez des éléments de réponse je vous en serai tres reconnaissant

Merci d’avance…
bonne journée


#2

6 heures, ça ressemble à un bail DHCP non renouvellé. Quelle est la configuration exactement? Entre autres, y-a-t-il auto eth0 dans /etc/network/interfaces?


#3

Mon fichier interfaces pour eth0:

auto eth0
iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
mtu 1422

Mais j’ai entrée mes adresses a la main !! je n’ai jamais configuré le DHCP. A ton avis que puis-je faire??


#4

Bon donc ça n’est pas un pbm de DHCP. Que dit /var/log/syslog au moment où la carte se casse la figure? Le délai est-il touyjours exactement le même?


#5

bah en fait je ne peux pas savoir … car pas de carte graphique sur le pc et suis obliger du coup de rebooter …

Les log sont ils present apres un reboot??


#6

[quote=“gwen”]bah en fait je ne peux pas savoir … car pas de carte graphique sur le pc et suis obliger du coup de rebooter …

Les log sont ils present apres un reboot??[/quote]

Comment ça tu reboutes??? Fais manuellement

ifdown eth0;ifup eth0

ça suffira.

Par ailleurs, oui les logs sont dans /var/log/syslog


#7

bah sans ecran … c’est chaud!!! :confused:

Enfin j’ai redemarrer a 8 heure ce matin et il est pas tombé depuis… mais… cron efface les log a 6h25 tous les matins

donc vais attendre le prochain plantage de l’interface pour te transmettre les logs…
mais deja je connaissais pas l’exitence de ce fichier… je vais le surveiller

merci


#8

Non, cron bouge les logs, ils se retrouvent sous /var/log/syslog.0, 1,2,… .gz