Probleme telnet: Connection closed by foreign host

bonjour,

je suis entrain d’installer un serveur mail, et je dois faire le test d’envoi de mail avecla commande telnet, mais ça bug je ne sais pour quoi. voici la commande:

:~# telnet 127.0.0.1 25
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
Connection closed by foreign host.
root@mail:~# 

comment puis-je corriger ce brobleme?
Merci

Bonsoir,

Peux tu nous dire ce que contient ton fichier

merci pour la reponse,

voici le contenu de hosts.allow

# /etc/hosts.allow: list of hosts that are allowed to access the system.
#                   See the manual pages hosts_access(5) and hosts_options(5).
#
# Example:    ALL: LOCAL @some_netgroup
#             ALL: .foobar.edu EXCEPT terminalserver.foobar.edu
#
# If you're going to protect the portmapper use the name "portmap" for the
# daemon name. Remember that you can only use the keyword "ALL" and IP
# addresses (NOT host or domain names) for the portmapper, as well as for
# rpc.mountd (the NFS mount daemon). See portmap(8) and rpc.mountd(8)
# for further information.
#
que dois-je modifier ou rajouter pour que ça marche?
 merci d'avance

ajoute dans /etc/hosts.allow

Et vérifie bien que postfix est démarrer, et refait un test.

Un processus a bien ouvert le port 25 en écoute, sinon la réponse de telnet serait différente.
Avant de modifier hosts.allow, il faudrait vérifier si le refus de la connexion vient de hosts.deny. Dans le cas contraire, c’est le processus en écoute lui-même qui ferme la connexion aussitôt, il faut donc regarder du côté de sa configuration.

Il doit y avoir des messages dans le syslog, dans mail.info et dans daemon.log je pense.

Bonjour,

Merci pour vos reponses, j’ai toujours le meme probleme meme apres avoir ajouter la ligne
127.0.0.1 localhost dans le fichier hosts.allow.

pour le ficher hosts.deny, voici son contenu

# /etc/hosts.deny: list of hosts that are _not_ allowed to access the system.
#                  See the manual pages hosts_access(5) and hosts_options(5).
#
# Example:    ALL: some.host.name, .some.domain
#             ALL EXCEPT in.fingerd: other.host.name, .other.domain
#
# If you're going to protect the portmapper use the name "portmap" for the
# daemon name. Remember that you can only use the keyword "ALL" and IP
# addresses (NOT host or domain names) for the portmapper, as well as for
# rpc.mountd (the NFS mount daemon). See portmap(8) and rpc.mountd(8)
# for further information.
#
# The PARANOID wildcard matches any host whose name does not match its
# address.
#
# You may wish to enable this to ensure any programs that don't
# validate looked up hostnames still leave understandable logs. In past
# versions of Debian this has been the default.
# ALL: PARANOID

apres avoir rajouté la ligne 127.0.0.1 localhost dans le fichier hosts.allow, j’ai redemarré postfix, il a bien redemarré sans probleme, puis j’ai executé la commande
#telnet 127.0.01 25 et le resultat été encore:

# telnet 127.0.0.1 25
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
Connection closed by foreign host.

voici le contenu de mail.log apres cette commande

Jul  6 17:39:48 messagerie postfix/smtpd[10503]: connect from localhost.localdomain[127.0.0.1]
Jul  6 17:39:48 messagerie postfix/smtpd[10503]: fatal: non-null host address bits in "193.194.80.133/28", perhaps you should use "@public/30" instead
Jul  6 17:39:49 messagerie postfix/master[10390]: warning: process /usr/lib/postfix/smtpd pid 10503 exit status 1
Jul  6 17:39:49 messagerie postfix/master[10390]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

quel est le probleme, et comment puis je le regler?

MERCI

Je dirais que c’est une erreur de configuration de postfix. Quelque part dans un de ses fichiers de configuration tu as spécifié le préfixe 193.194.80.133/28, dont certains bit de la partie hôte ne sont pas à 0 contrairement à ce que postfix semble attendre. Pour information :

$ ipcalc 193.194.80.133/28 Address: 193.194.80.133 11000001.11000010.01010000.1000 0101 Netmask: 255.255.255.240 = 28 11111111.11111111.11111111.1111 0000 Wildcard: 0.0.0.15 00000000.00000000.00000000.0000 1111 => Network: 193.194.80.128/28 11000001.11000010.01010000.1000 0000

Merci PascalHambourg pour votre reponse,

ça m’a permis de revérifier mon main.cf, et j’ai découvert une erreur de frappe dans mynetworks
au lieu de mettre adresse reseau j’ai mis sans faire attention l’adresse de la machine.

j’ai repris et ça a marché.

Merci

1 J'aime