Probléme webmin + apache2 + autres question. Merci


#1

Bonjour à vous tous,

Comencant à m’énerver contre vindo, je me suis dis qu’il fallait que je me lance dans linux (en fait cela fait bientôt 6 mois que j’ai commencé à trifouiller). J’ai donc était récupérer une distrib debian. L’installation, et les premier pas ce sont trés bien passer. J’ai donc ensuite eu comme objectif d’installer un équivalent de Exchange pour mon entreprise. Je suis tombé sur egroupware, et je me suis mis en tête de l’essayer. Mais je voulais comprendre chaque partie de l’installe (donc pas de apt-get install egroupware). J’ai donc installer une distrib vierge sur un PC. J’ai ensuite installer apache2 puis pour pouvoir administrer le serveur je me suis mis a vouloir installer webmin, et là commence les questions.

Tout d’abord l’install de webmin ce passe trés bien, mais lorsque je veux accéder à distance sur webmin, il me dit que je ne suis pas autorisé. Aprés divers recherche tout les infos m’oriente sur la configuration du fichiers httpd2.conf ou httpd.conf. Mais je n’est pas de httpdé.conf, et dans httpd.conf, je n’est que 3 lignes. Cela et il normal ? Que dois je faire ?

Hors mit cette question, je me permet de ous poser quelque questions auqu’elle je n’est pas encore trouvé de réponse.

Y a t’il une commande pour connaitre la version que l’on posséde ?
Comme je vais devoir installer un serveur de messagerie, vaut’il mieux que j’utilise exim4 ou courier-imap ?
Comment fait vous pour récupérer des fichiers sur le net depuis votre serveur et en mode console et quand les fichiers ce télécharge en http et non pas en ftp ?

Bon je vais arrêter là. Je vous remercie d’avance pour tout l’aide que vous pourrez m’apporter.

Bon week end

Ludo


#2

slt,

As tu un firewall ? Ou as tu bien configuré l’accés a distance dans “webmin -> configuration de webmin-> Contrôle d’accès par adresse IP> Là tu peut définir, les adresses autorisées à lancer webmin” aussi “Ajouter des utilisateurs à webmin : webmin -> Utilisateurs Webmin”

[quote]
Mais je n’est pas de httpdé.conf, et dans httpd.conf, je n’est que 3 lignes. Cela et il normal ? Que dois je faire ? [/quote]

A mon avis non ce n’est pas normale d’avoirs 3 lignes dans ton httpd.conf, essaie de choper les sources d’apache sur (apache.org) puis de récupéré un fichier d"exemple.

La version de quoi ?

Pour ma part dans notre boite on utlise postfix, simple a configurer, rapide, réputé, et pas de faille de sécu.

Plusieurs astuces :slightly_smiling:

#wget -O /ou/tu/veut/mettre/ton/file http://host.com/file.*
#lynx -dump  http://host.com/file.* > /ou/tu/veut/mettre/ton/file 
#curl -o  /ou/tu/veut/mettre/ton/file http://host.com/file.*
#w3m -dump http://host.com/file.* > /ou/tu/veut/mettre/ton/file 

La suite depend de ton install

#GET http://host.com/file.* > /ou/tu/veut/mettre/ton/file 

Depend si il y a le module perl LWP.

#lwp-download http://host.com/file.* > /ou/tu/veut/mettre/ton/file 
#perl -MLWP::Simple -e "getstore('http://host.com/file','/ou/tu/veut/mettre/ton/file ');"

mdr r R R qu’est ce que c’est c00l gnu…


#3

pour apache2 3 lignes dans le httpd.conf c’est normal les sites sont gérés autrement

voir les fichiers dans sites-available et sites-enabled
Répertoire /etc/apache2/sites-enabled
Lien vers la configuration du site afin qu’il soit accessible

Répertoire /etc/apache2/sites-available
Configuration du site un nom de fichier par site pas d’extension.

Pour la version c’est en général la commande suivis de l’option -v ou --v ou --version enfin tu test si c’est pour linux


#4

Merci beaucoup pour votre aide,

Néanmoins (si il n’y avais pas ce mot il faudrais l’inventer :laughing: ) pour mon webmin je n’y arrive pas même en le mettant dans site-enable. Cela doit trés certainement du a une gestion particuliére de droit. Sinon pour stonfi, en fait ce que j’appelle à distance c’est sur le même réseau. Mon serveur n’ayant pas d’interface graphique (et oui j’ai voulue me la joué), je ne peut pas lancé webmin, donc je ne peut pas configurer les adresses ip. Que faire ??

Encore mille merci à vous.

Ludo

PS : C’est claire que Linux c’est bien, rien que pour le plaisirs de pouvoir trouvé de l’aide et en plus par des personnes sympa


#5

Je viens d’essayer, même aveclynx (donc en local), il me dit accés refuser


#6

slt,

Il te faut retrouver le fichier de conf de webmin, en general dans /etc ou /etc/webmin l’editer et ajouter l’option suivante.

allow=ton ip

Encore heureux mdr qu’il ni est pas de X sur les servers. :slightly_smiling:

Ps: N’oublie pas de redemarrer webmin.


#7

Super non seulement ca marche mais j’ai aussi compris. En fait webmin à son propre serveur web. Et dire que je me suis cassé la tête depuis 2 jour dans les fichiers de config d’apache.

Encore merci, je vais pouvoir continuer mais installe pour pouvoir faire fonctionner egroupware.

Je vous dis donc peut être à une autre fois :wink:

Ludo