Problème XRDP

Tags: #<Tag:0x00007f1ee27f1c70>

Bonjour à tous,

J’aimerai réalisé la mise en place d’un bureau à distance sous XRDP avec l’environnement graphique Cinnamon.

XRDP se bloque sur l’écran bleu mais depuis root sa marche.

Je suppose qu’il y a un soucis sur le chargement de l’environnement . (Commande de chargement, droit, groupe …)

SSH:

Bloquer l’authentification par mot de passe:

  • PermitRootLogin no
  • PasswordAuthentication no

Autoriser l’authentification par clé

  • PubkeyAuthentication yes

cat /var/log/xrdp-sesman.log

[20200914-15:09:35] [INFO ] A connection received from ::1 port 54750
[20200914-15:09:36] [INFO ] ++ created session (access granted): username marc, ip 0.0.0.0:53158 - socket: 12
[20200914-15:09:36] [INFO ] starting Xorg session…
[20200914-15:09:36] [DEBUG] Closed socket 9 (AF_INET6 :: port 5910)
[20200914-15:09:36] [DEBUG] Closed socket 9 (AF_INET6 :: port 6010)
[20200914-15:09:36] [DEBUG] Closed socket 9 (AF_INET6 :: port 6210)
[20200914-15:09:36] [DEBUG] Closed socket 8 (AF_INET6 ::1 port 3350)
[20200914-15:09:36] [DEBUG] Closed socket 7 (AF_INET6 ::1 port 3350)
[20200914-15:09:36] [INFO ] Xorg :10 -auth .Xauthority -config xrdp/xorg.conf -noreset -nolisten tcp
[20200914-15:09:46] [ERROR] X server for display 10 startup timeout
[20200914-15:09:46] [INFO ] starting xrdp-sessvc - xpid=943 - wmpid=942
[20200914-15:09:46] [ERROR] X server for display 10 startup timeout
[20200914-15:09:46] [ERROR] another Xserver might already be active on display 10 - see log
[20200914-15:09:46] [DEBUG] aborting connection…
[20200914-15:09:46] [INFO ] ++ terminated session: username marc, display :10.0, session_pid 941, ip 0.0.0.0:53158 - socket: 12
[20200914-15:09:58] [INFO ] A connection received from ::1 port 54752
[20200914-15:09:59] [INFO ] ++ created session (access granted): username marc, ip 0.0.0.0:53179 - socket: 12
[20200914-15:09:59] [INFO ] starting Xorg session…
[20200914-15:09:59] [DEBUG] Closed socket 9 (AF_INET6 :: port 5910)
[20200914-15:09:59] [DEBUG] Closed socket 9 (AF_INET6 :: port 6010)
[20200914-15:09:59] [DEBUG] Closed socket 9 (AF_INET6 :: port 6210)
[20200914-15:09:59] [DEBUG] Closed socket 8 (AF_INET6 ::1 port 3350)
[20200914-15:09:59] [DEBUG] Closed socket 7 (AF_INET6 ::1 port 3350)
[20200914-15:09:59] [INFO ] Xorg :10 -auth .Xauthority -config xrdp/xorg.conf -noreset -nolisten tcp

Petite question bête, tu as essayé de te connecter directement, sans passer par un tunnel SSH ?

Pour l’heure j’essaie sans Tunnel, directement . Mais sa marche pas

Pardon, j’ai un peu baroudé sur xrdp ces dernières années, tu utilises quel version exactement ? Pour le moment, celle que j’ai réussi à mettre en œuvre sont celle du backport de Debian 8, celle du backport de Debian 9 et celle de Debian 10. Si ton système est sous Debian 8 et Debian 9, je te conseille, déjà, de passer au backport pour avoir une version plus fonctionnelle. De mémoire, au vu de tes journaux, ce n’est pas celle de Debian 8.