Problèmes Expressvpn et DynDNS

Tags: #<Tag:0x00007f32d3687240> #<Tag:0x00007f32d3686d68> #<Tag:0x00007f32d3686c78>

Bonjour !

Développeur de métier c’est très rarement que je prend le temps de poster un sujet pour demander de l’aide, en général de bonnes recherches règle mon problème mais si je suis ici aujourd’hui c’est que je coule…

Je suis totalement nouveau sur debian, je me suis installer un petit serveur qui me renvoies des pages web sur différents ports et j’y ai installer un vpn comme sur le reste de mon réseau.

Quand je me connecte au réseau local, j’accède sans aucun problème à ces pages, mais que je met en place mon DynDNS noip et que j’essaye d’y accéder par internet c’est la catastrophe (L’adresse ip publique brute ne fonctionne pas non plus)… Il refuse catégoriquement de me renvoyer mes pages et comme cela ne se produit que lorsque le VPN est connecté j’en conclu qu’il est en faute (quand le vpn est déconnecté j’arrive sans problème à accéder à mes pages depuis internet).

J’ai essayer de modifier “iptables”, les interfaces network et j’en passe, je me perd littéralement dans le flux d’information et je ne suis plus de ce que je dois faire.

Pour ma machine, je suis un debian AMD64, avec ma carte réseau internet principale (celle connectée à ma box pour accéder à internet, 255.255.255.0), une deuxième carte réseau secondaire pour un sous réseau interne (Actuellement non branché car je règlerait ces problèmes ultérieurement , 255.255.0.0) et dans “ifconfig” je me retrouve avec “tun0” correspondant à mon vpn (255.255.255.255)

Je reste à votre disposition pour plus d’informations et merci à ceux qui prendront le temps de me répondre :slight_smile: