Problèmes installation périphériques avec Debian


#1

Bonjour
Je me suis lancé sur Debian. Pour le moment je suis avec la mandrake 10.1, en attendant de pouvoir régler les problèmes de config sur Debian.
noyau : 2.6.8-1-386
j’ ai fait l’installation avec le net, donc sans Cd
J’avais essayer avec des CD Ikarios mais les pb sont les mêmes.
Les voici :
aprés l’instal mon lecteur cd (graveur cd dvd) n’est plus reconnu
voici le message d’erreur que j’obtiens :
mount: mount point /media/cdrom0 does not exist
de plus j’ai un disque dur externe en usb auquel je ne peux accéder (alors qu’il fontionne bien avec mandrake), message d’erreur :
mount: I could not determine the filesystem type, and none was specified
et aussi j’ai un lecteur Zip Iomega qui me pose le même problème je pense :
si j’utilise une disquette Zip qui fonctionne avec la mdk 10.1 j’ai le message :
mount: I could not determine the filesystem type, and none was specified
mais si je formate une disquette Zip avec la Debian je ne peux pas l’utiliser sur la mandrake !!!
Si quelqu’un peut me sortir de ces problèmes, je pourrai avancer dans l’instal de Debian et donc exposer mes futurs pb
Merci
Je suis un utilisateur primaire de Linux, mais je ne suis plus du tout sous microsoft …
Michel


#2

c’est surement pas grand chose:
quel est le contenu de /etc/fstab ?
ou est branché ton graveur: en ide, en scsi ?
si ide, sais tu si c’est le 1er ide ou le 2eme, et s’il est en primaire ou secondaire sur sa nappe ?
tu dis que tu ne peux pas utiliser ton zip, mais comment as tu fait alors pour formatter ?
ensuite, est ce qu’un zip formatté sous debian fonctionne sous debian ?


#3

[quote=“MattOTop”]c’est surement pas grand chose:
quel est le contenu de /etc/fstab ?
ou est branché ton graveur: en ide, en scsi ?
si ide, sais tu si c’est le 1er ide ou le 2eme, et s’il est en primaire ou secondaire sur sa nappe ?
tu dis que tu ne peux pas utiliser ton zip, mais comment as tu fait alors pour formatter ?
ensuite, est ce qu’un zip formatté sous debian fonctionne sous debian ?[/quote]

Bonjour
Voici le fichier : /etc/fstab

proc /proc proc defaults 0 0
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
/dev/hda8 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/sda /media/usb0 auto rw,user,noauto 0 0
/dev/sdb /media/usb1 auto rw,user,noauto 0 0

Le graveur me paraît branché en IDE 1 (esclave) d’après ce que j’ai vu avec la mandrake.
Comment être plus précis ? j’ai fait la commande dmesg mais je n’y comprends pas grand chose,
voici la partie qui parle du graveur :
/dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 p8 > p3
hdc: _NEC DVD_RW ND-3500AG, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Adding 265032k swap on /dev/hda8. Priority:-1 extents:1
EXT3 FS on hda3, internal journal
Generic RTC Driver v1.07
hdc: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
SCSI subsystem initialized
Capability LSM initialized
ACPI: PCI interrupt 0000:00:09.0[A] -> GSI 11 (level, low) -> IRQ 11

J’ai vu que dans /media il n’y a pas /media/cdrom0

Pour ce qui est du Zip je n’ai pas été très clair : je ne peux pas récupérer les données que j’avais stockées en utilisant la mdk, je ne peux pas accéder avec Debian aux disquettes formatées avec mandrake et inversement, mais je peux utliser les diques “mandrake” avec mdk et les disques “debian” avec debian.
Est- ce que cela permet d’avancer
Merci
Michel


#4

Bonjour.

[quote=“calas”]Voici le fichier : /etc/fstab

Le graveur me paraît branché en IDE 1 (esclave) d’après ce que j’ai vu avec la mandrake.[/quote]
enfait, non, il est en IDE 1 maitre (hdc) sinon, il serait en hdd

[quote=“calas”]Comment être plus précis ? j’ai fait la commande dmesg mais je n’y comprends pas grand chose,
…[/quote]
bonne idée, le dmesg, ca confirme juste que le lecteur cdrom est sur /dev/hdc .

Est ce que tu utilises un autofs qui monterait les périphériques à la volée sur /media ?
Essayes de créer le répertoire /media/cdrom0.

Lorsque tu montes une disquette zip debian sous debian, que donnes ‘mount’ concernant le format de ta disquette zip ?
pareil pour mdk si tu l’as encore.

Sinon, à tester:
mettons que tu saches que ton lecteur zip est en sda
rajoutes une ligne
/dev/sda /mnt/sdafat32 vfat rw,user,noauto 0 0
dans ton fstab
puis tu crées le répertoire /mnt/sdafat32 . puis finalement ‘mount /mnt/sdafat32’ pour monter une disquette mandrake sur /mnt/sdafat32, en forcant le format fat32.

[quote=“calas”]Est- ce que cela permet d’avancer
Merci
Michel[/quote]
C’est toi qui juges.


#5

Bonjour.

[quote=“calas”]Voici le fichier : /etc/fstab

Le graveur me paraît branché en IDE 1 (esclave) d’après ce que j’ai vu avec la mandrake.[/quote]
enfait, non, il est en IDE 1 maitre (hdc) sinon, il serait en hdd

[quote=“calas”]Comment être plus précis ? j’ai fait la commande dmesg mais je n’y comprends pas grand chose,
…[/quote]
bonne idée, le dmesg, ca confirme juste que le lecteur cdrom est sur /dev/hdc .

Est ce que tu utilises un autofs qui monterait les périphériques à la volée sur /media ?
Essayes de créer le répertoire /media/cdrom0.

Lorsque tu montes une disquette zip debian sous debian, que donnes ‘mount’ concernant le format de ta disquette zip ?
pareil pour mdk si tu l’as encore.

Sinon, à tester:
mettons que tu saches que ton lecteur zip est en sda
rajoutes une ligne
/dev/sda /mnt/sdafat32 vfat rw,user,noauto 0 0
dans ton fstab
puis tu crées le répertoire /mnt/sdafat32 . puis finalement ‘mount /mnt/sdafat32’ pour monter une disquette mandrake sur /mnt/sdafat32, en forcant le format fat32.

[quote=“calas”]Est- ce que cela permet d’avancer
Merci
Michel[/quote]
C’est toi qui juges.[/quote]

Bonjour
J’ai toujours en effet mdk 10.1 : j’en ai besoin pour mon boulot.
Mai je souhaite n’utliser que debian : je ne sais pas si j’ai un autofs ( comment faire pour savoir) par contre j’ai créé le répertoire /media/cdrom0 et cela marche : j’ai pu ouvrir un cdrom (tout simplement !!!).
Mais si je reboot, je dois de nouveau créer le répertoire /media/cdrom0.(Cela correspond-il à autofs.)

Lecteur Zip est en sda : commande mount avec disquette zip formatée avec debian
debianfixe:/home/micniq# mount /dev/sda
mount: /dev/sda already mounted or /media/usb0 busy
mount: according to mtab, /dev/sda is already mounted on /media/usb0

si j’uttlise une disquette zip formatée avec mdk
debianfixe:/home/micniq# mount /mnt/sdafat32
mount: wrong fs type, bad option, bad superblock on /dev/sda,
or too many mounted file systems

J’ai essayé la commande fsck : Zip formaté avec Debian sur Debian
fsck /dev/sda
fsck 1.35 (28-Feb-2004)
e2fsck 1.35 (28-Feb-2004)
/dev/sda: propre, 12/24576 fichiers, 3128/98304 blocs

Disquette formatée mdk sur debian
fsck /dev/sda
fsck 1.35 (28-Feb-2004)
e2fsck 1.35 (28-Feb-2004)
Ne peut repérer le superbloc ext2, tente d’archiver les blocs…
fsck.ext2: Bad magic number in super-block lors de la tentative d’ouverture de /dev/sda

Le super devrait être lu ou ne contient pas une extension correcte de type ext2
système de fichiers. Si le périphérique est valide et qu’il contient réellement une extension de type ext2
système de fichiers (qui n’est pas de type swap ou autre), alors le super
est corrompu, et vous devrierz tenter d’exécuter e2fsck avec un super alternatif:
e2fsck -b 8193 <périphérique>

si je fais e2fsck -b 8193 /dev/sda j’ai le même type de message avec
e2fsck -b 8193 /dev/sda
e2fsck 1.35 (28-Feb-2004)
e2fsck: Bad magic number in super-block lors de la tentative d’ouverture de /dev/sda
Le super devrait être lu ou ne contient pas une extension correcte de type ext2
système de fichiers. Si le périphérique est valide et qu’il contient réellement une extension de type ext2
système de fichiers (qui n’est pas de type swap ou autre), alors le super
est corrompu, et vous devrierz tenter d’exécuter e2fsck avec un super alternatif:
e2fsck -b 8193 <périphérique>

Zip mandrake sur mdk
fsck /dev/sda4
fsck 1.35 (28-Feb-2004)
e2fsck 1.35 (28-Feb-2004)
/dev/sda4 is mounted.

WARNING!!! Running e2fsck on a mounted filesystem may cause
SEVERE filesystem damage.

Do you really want to continue (y/n)? no

Zip debian avec mdk
fsck /dev/sda4
fsck 1.35 (28-Feb-2004)
e2fsck 1.35 (28-Feb-2004)
fsck.ext2: No such file or directory while trying to open /dev/sda4

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193
Est-ce que Debian et mdk utliseraient des méthodes de formatages différentes ?
Merci
Michel


#6

bon, en fait /media m’a bien l’air d’être gèré automatiquement. Si c’est pas autofs, c’est une nouveauté liée à udev.
Bon, alors laisses ce qu’il y avait à l’origine dans /etc/fstab, et crées les mountpoints suivants: #variation de celle que je t'ai fait rajouter déjà: /dev/sda /mnt/fat32/sda vfat rw,user,noauto 0 0 /dev/sda4 /mnt/fat32/sda4 vfat rw,user,noauto 0 0 #des nouvelles pour tester en auto /dev/sda /mnt/auto/sda auto rw,user,noauto 0 0 /dev/sda4 /mnt/auto/sda4 auto rw,user,noauto 0 0 #et les mounts dont tu es sur /dev/hdc /mnt/cd iso9660 ro,user,noauto 0 0
en oubliant pas de créer à chaque fois /mnt/fat32/sda, /mnt/fat32/sda4, etc…
Bon, enfin, tu te fais ton arborescence /mnt comme tu veux, mais contrairement à /media, c’est toi qui le controle. Aprés, tu pourras toujours essayer de voir à quoi correspond ce /media, mais en attendant, tu le laisse tranquille.

Aprés, tu essayes de voir avec, un mount /mnt/auto/sda4 si ca te permet d’accèder à tes disquettes mandrake (dans l’autre sens, pas d’idée pour l’instant).


#7

[quote=“MattOTop”]bon, en fait /media m’a bien l’air d’être gèré automatiquement. Si c’est pas autofs, c’est une nouveauté liée à udev.
Bon, alors laisses ce qu’il y avait à l’origine dans /etc/fstab, et crées les mountpoints suivants: #variation de celle que je t'ai fait rajouter déjà: /dev/sda /mnt/fat32/sda vfat rw,user,noauto 0 0 /dev/sda4 /mnt/fat32/sda4 vfat rw,user,noauto 0 0 #des nouvelles pour tester en auto /dev/sda /mnt/auto/sda auto rw,user,noauto 0 0 /dev/sda4 /mnt/auto/sda4 auto rw,user,noauto 0 0 #et les mounts dont tu es sur /dev/hdc /mnt/cd iso9660 ro,user,noauto 0 0
en oubliant pas de créer à chaque fois /mnt/fat32/sda, /mnt/fat32/sda4, etc…
Bon, enfin, tu te fais ton arborescence /mnt comme tu veux, mais contrairement à /media, c’est toi qui le controle. Aprés, tu pourras toujours essayer de voir à quoi correspond ce /media, mais en attendant, tu le laisse tranquille.

Aprés, tu essayes de voir avec, un mount /mnt/auto/sda4 si ca te permet d’accèder à tes disquettes mandrake (dans l’autre sens, pas d’idée pour l’instant).[/quote]

Bonjour
Et bien voilà :
évidement pour le cd avec /dev/hdc et /mnt/cd cela marche.
Pour le Zip cela fonctionne avec /dev/sda4 et /mnt/auto/sda4 auto rw,user,noauto 0 0
je peux donc lire les Zip mdk , écrire dessus sous debian et réciproquement ça colle .
Au passage je ne peux plus lire le ZIP formaté sous debian ( je le lisais avec /dev/sda monté sur /media/usb0).
J’ai essayé de trafiquer les points de montage pour le disque externe en usb
en utilisant /mnt/usb sur /dev/sdb mais toujours le message d’erreur :
mount: I could not determine the filesystem type, and none was specified.

A prropos quand je sors de vi /etc/fstab/ j’ai le message suivant :
debianfixe:/home/micniq# vi /etc/fstab
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

debianfixe:/home/micniq#
Je ne sais pas si cela indique quelque chose d’important.
Et bien cela avance : merci
Michel


#8

pour le zip, vérifies que les /dev/sda* soient unmounted sur /mnt si tu veux mounter /dev/sda sur /media.
Pour vi, ca doit être parceque l’utilisateur de l’interface X windows que tu utilises n’a pas donné les droits à root d’accèder au serveur X.
On m’a conseillé pour ca d’installer le paquet “sux” (sans rire, il s’appelle comme ça). Ensuite, tu fais 'sux ’ pour executer, depuis un shell utilisateur, une commande en tant que superuser, avec les droits qu’il faut sur le serveur X. Ca donnerait:sux vi /etc/fstabJe l’ai installé, mais je préfère le bête xhost + dans un shell utilisateur qui déverrouille complètement l’accés à mes dispositifs X. De toutes les manières, l’accés au serveur X est limité au localhost en dur dans la config debian, alors…


#9

[quote=“MattOTop”]pour le zip, vérifies que les /dev/sda* soient unmounted sur /mnt si tu veux mounter /dev/sda sur /media.
Pour vi, ca doit être parceque l’utilisateur de l’interface X windows que tu utilises n’a pas donné les droits à root d’accèder au serveur X.
On m’a conseillé pour ca d’installer le paquet “sux” (sans rire, il s’appelle comme ça). Ensuite, tu fais 'sux ’ pour executer, depuis un shell utilisateur, une commande en tant que superuser, avec les droits qu’il faut sur le serveur X. Ca donnerait:sux vi /etc/fstabJe l’ai installé, mais je préfère le bête xhost + dans un shell utilisateur qui déverrouille complètement l’accés à mes dispositifs X. De toutes les manières, l’accés au serveur X est limité au localhost en dur dans la config debian, alors…[/quote]

Bonjour
j’ai réglé le pb xhost +local
Je continue à chercher pour mon disque externe en USB
Merci encore.
Michel


#10

Pour l’externe USB, essayes la même manip de création de mountpoint, et regarde ce qu’il y a dans sdb1 (oublies sdb).


#11

Bonjour
j’ai monté le disque externe usb sous /mnt/auto/sdb1
et cela marche
Et voilà une bonne chose de faite
Merci pout
A bientôt peut-être
Michel


#12

tiens, j’étais en train de regarder les nouveautés du jour, et je suis tombé sur un paquet “usbmount” dont voici le pitch:[quote=“usbmount”]
usbmount - automatically mount and unmount USB mass storage devices

This package automatically mounts USB mass storage devices (typically USB pens) when they are plugged in, and unmounts them when they are
removed. The mountpoints (/media/usb[0-7] by default), filesystem types to consider, and mount options are configurable. When multiple
devices are plugged in, the first available mountpoint is automatically selected. If the device provides a model name, a symbolic link
/var/run/usbmount/MODELNAME pointing to the mountpoint is automatically created.

The script that does the (un)mounting is called by the udev daemon. Therefore, USBmount requires a 2.6 (or newer) kernel.

USBmount is intended as a lightweight solution which is independent of a desktop environment. Users which would like an icon to appear
when an USB device is plugged in should use the pmount and hal packages instead.

Homepage: usbmount.alioth.debian.org/
[/quote]
Tu n’aurais pas ce paquet là d’installé par hasard ?