problèmes relous ( X, points de montage, hotplug )


#1

Salut,

je suis “debutant” sous Linux , cela fait en effet 2 semaines que je suis sous Sarge ( après 3 semaines sous Mandrake, et après qques sueurs en ce qui concerne la configuration ( Speedtouch 330, réseau, X, partitionnage ), jai enfin un KDE qui fonctionne au poil.

il reste cependant des problèmes qui persistent, et qui mempêchent de profiter à fond de cette exellente distrib :

1 / Le plus énorme est certainement le fait que je ne peux pas accéder aux partitions NTFS et FAT32 excepté si je suis loggé comme root. Jai pourtant ajouté les entrées nécessaires dans /etc/fstab :

[code]localhost:/$ cat /etc/fstab

/etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/hda5 / ext3 defaults,errors=remount-ro 0 1
/dev/hdb2 /home xfs defaults 0 2
/dev/hda8 /opt xfs defaults 0 2
/dev/hda7 /usr xfs defaults 0 2
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/sda /media/usb0 auto rw,user,noauto 0 0

/dev/hda1 /mnt/win_c ntfs ro,auto,user 0 4
/dev/hda2 /mnt/win_g ntfs ro,auto,user 0 5
/dev/hda3 /mnt/win_shared vfat rw,auto,user 0 3
/dev/hdb1 /mnt/win_arch vfat rw,auto,user 0 5[/code]

et les partitions sont bien montées au démarrage.
Par contre, chaque reboot écrase les permissions que jai donné durant la session précédente, les ntfs ne sont accessibles en lecture que par root, et les vfat se rettrouves en lecture seule pour les utilisateurs normaux. Mais le plus zarb vient du fait que je ne peux même pas accéder aux points de montage vfat alors que jen ai les permissions. Voilà le “l /mnt” et le “mount” si ça peut vous éclairer :

localhost:/$ l /mnt total 44 drwxr--r-- 9 root root 32768 1970-01-01 04:00 win_arch dr-x------ 1 root root 4096 2004-11-19 17:34 win_c dr-x------ 1 root root 4096 2004-11-14 17:05 win_g drwxr--r-- 3 root root 4096 1970-01-01 04:00 win_shared localhost:/$ mount /dev/hda5 on / type ext3 (rw,errors=remount-ro) proc on /proc type proc (rw) sysfs on /sys type sysfs (rw) devpts on /dev/pts type devpts (rw,gid=5,mode=620) tmpfs on /dev/shm type tmpfs (rw) /dev/hdb2 on /home type xfs (rw) /dev/hda8 on /opt type xfs (rw) /dev/hda7 on /usr type xfs (rw) /dev/hda1 on /mnt/win_c type ntfs (ro,noexec,nosuid,nodev) /dev/hda2 on /mnt/win_g type ntfs (ro,noexec,nosuid,nodev) /dev/hda3 on /mnt/win_shared type vfat (rw,noexec,nosuid,nodev) /dev/hdb1 on /mnt/win_arch type vfat (rw,noexec,nosuid,nodev) usbfs on /proc/bus/usb type usbfs (rw)

2 / Un autre blem qui commence à me chauffer, c que je ne puisse pas lancer dapplis X une fois identifié comme un autre utilisateur. Je me retrouve à tousl es coups avec ce message d’erreur :

[code]localhost:~$ su
Password:
localhost:/home/superdindon# emacs
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

emacs: Cannot connect to X server :0.0.
Check the DISPLAY environment variable or use -d'. Also use thexhost’ program to verify that it is set to permit
connections from your machine.[/code]

c particulièrement difficile à digérer pour la compilation dun noyau, pour lequel je suis forcé dutiliser menuconfig

à noter que jai bien la valeur :0.0 pour DISPLAY même sans avoir lancé de su

3 / Le moment geek : hotplug me fait perdre 5-10 secs au démarrage parce quil lance 5 fois de suite le script dinitialisation de mon Speedtouch, ce qui ralentit inutilement le démarrage. Est-il possible de régler le problème? ( je nai trouvé aucun fichier d’option , quasiment que des scripts shells pas bien précis et qui ne mont pas beaucoup aidés )

Voilà, si vous avez une réponse ou un tronçon de réponse, ça maiderait beaucoup.

merci d’avance


#2

1/c’est users avec un ‘s’, et un umask à 0, qu’il faut mettre dans ton fstab
mes options a moi, aprés tatonnement:
defaults,users,umask=0
2/dans un shell qui possede le display X, tu fais un xhost + pour ouvrir le display sur le localhost (le serveur n’ecoute pas sur les interfaces externes, c’est un autre probleme et je n’ai pas encore trouvé une solution simple)
3/???, déconnectes le hotplug au boote, et force les modules necessaires dans /etc/modules ? peut etre cette derniere option peut elle d’ailleurs resoudre aussi ton probleme.


#3

1/Ce nest pas dangeureux dutiliser “users”? En fait voilà le scénar qui me fait peur : un pirate arrive à lancer une session RSH ou SSH ( et il a pa s besoin dun compte utilisateur, puisque les nobody peuvent aussi monter les partitions avec users ), il démonte une partition NTFS, il la remonte en rw, puis il me nicke la partition avec un echo “Souvenir!!” w masignature.txt.

En attendant ta réponse je vais essayer avec le umask

2/Ok ça marche nickel

3/Non je pense que jai mal expliqué le problème. En fait il ne sagit pas uniquement de modules à charger, mais aussi de lancer une c onnection, et cette deuxième phase prend un certain temps ( à cause de modem_run qui doit charger le firmware dans le modem ), ce qui fait qu’Hotplug relance intuliement de nouveau le script toutes les 4-5 secondes, et à 5 reprises. Jai lancé un grep -R sleep * dans /etc/hotplug, il a bien trouvé des occurences, mais aucune qui me paraisse en rapport avec le prob, je suis donc un peu paumé


#4

1/effectivement, tu as sans doute raison, mais d’abord, pas de rsh sur ma machine, comme ca pas de faille, et d’ici à ce qu’il ait une connection ssh. En fait, j’ai mis en users, parceque j’evite de les monter au boot (je n’ai pas mis ca dans mon post précèdent parceque ca ne te concernait pas, mais je suis en noauto). sinon, pour que le pirate remonte ta partoche en NTFS, il faudrait déja que tu aies le module RW dans le noyau. Or quoi que sûr à présent, je ne l’ajoute pas parcequ’il ne sait que modifier les octets dans un fichier existant, et sans changer sa taille, ce qui est, tu en conviendra, bien loin d’un VRAI accés en RW…
3/as tu recherché autre chose que le sleep, par exemple ton modem_run dans les scripts hotplug ? sinon, tu peux peut etre modifier le modem_run pour qu’il verrouille la premiere fois qu’il se lance, et qu’il ne fasse rien les fois suivantes. reste a gerer le nettoyage du verrou. tu peux aussi te débrouiller pour qu’il démarre en bg. sinon, tu peux encore démarrer modem éteint, et le brancher aprés :slightly_smiling:
dsl, pas mieux…


#5

1/Yep ça y est, umask a réglé le problème, sans avoir recours à users
3/En fait le modem_run est lancé dans un script à part, mais quest-ce que tu veux dire par verrouiller?

Sinon jai essayé de lancer le script d’initalisation en tache de fond, il y a moins dattente, mais bizarrement lerreur est tjrs là :

Nov 21 08:15:41 localhost kernel: usbcore: registered new driver speedtch
Nov 21 08:15:41 localhost kernel: usbcore: deregistering driver speedtch
Nov 21 08:15:41 localhost kernel: usbcore: registered new driver speedtch
Nov 21 08:15:41 localhost kernel: usbcore: deregistering driver speedtch
Nov 21 08:15:41 localhost kernel: usbcore: registered new driver speedtch
Nov 21 08:15:41 localhost kernel: cpci_hotplug: CompactPCI Hot Plug Core version: 0.2
Nov 21 08:15:41 localhost kernel: pci_hotplug: PCI Hot Plug PCI Core version: 0.5
Nov 21 08:15:41 localhost kernel: pciehp: PCI Express Hot Plug Controller Driver version: 0.4
Nov 21 08:15:41 localhost kernel: usb 3-2: usbfs: interface 1 claimed while ‘modem_run’ sets config #1
Nov 21 08:15:41 localhost kernel: usb 3-2: usbfs: interface 2 claimed while ‘mod
em_run’ sets config #1
Nov 21 08:15:41 localhost kernel: shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
Nov 21 08:15:41 localhost kernel: usb 3-2: bulk timeout on ep5in
Nov 21 08:15:41 localhost kernel: usb 3-2: usbfs: USBDEVFS_BULK failed ep 0x85 len 512 ret -110
Nov 21 08:15:41 localhost kernel: usb 3-2: usbfs: interface 0 claimed while ‘modem_run’ sets config #1
Nov 21 08:15:41 localhost kernel: usb 3-2: usbfs: interface 1 claimed while ‘modem_run’ sets config #1
Nov 21 08:15:41 localhost kernel: usb 3-2: usbfs: interface 2 claimed while ‘modem_run’ sets config #1
Nov 21 08:15:41 localhost kernel: usbcore: deregistering driver speedtch
Nov 21 08:15:41 localhost kernel: usbcore: registered new driver speedtch
Nov 21 08:15:41 localhost kernel: usbcore: deregistering driver speedtch
Nov 21 08:15:41 localhost kernel: usbcore: registered new driver speedtch

( et en tapant un ps U root rapidement après la demande de login, je me retrouve avec plusieurs modem_run lancés )

menfin jai pu qd même gagner 5 bonnes secondes, ma cupidité a été satisfaite

Bonus/C quoi ce patch cramfs qu’il faut appliquer pour pouvoir compiler un noyau avec initrd? Est-ce qu’il est nécessaire pour noyau 2.6.8?
Jai déjà essayé de compiler un noyau avecf make-kpkg sans --initrd, et ça ma affiché un Kernel Panic pas très sexy au reboot suivant, sans Knoppix, jétais foutu


#6

Un verrou:
au début du script, tu verifies s’il exist un petit fichier de verrou, s’il existe, tu sort, sinon, tu le crées et tu executes la suite du script, soit au début du script:

[-f /var/run/modem_run.lck] && exit 0
touch /var/run/modem_run.lck

reste à choisir le moment ou tu l’enleve. à la fin de modem_run, c’est peut etre trop tot, il faudrait le supprimmer au moment d’un modem_down (tuvoisskejveudire)


#7

[quote=“SuperDindon”]
2 / Un autre blem qui commence à me chauffer, c que je ne puisse pas lancer dapplis X une fois identifié comme un autre utilisateur. Je me retrouve à tousl es coups avec ce message d’erreur :

[code]localhost:~$ su
Password:
localhost:/home/superdindon# emacs
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

emacs: Cannot connect to X server :0.0.
Check the DISPLAY environment variable or use -d'. Also use thexhost’ program to verify that it is set to permit
connections from your machine.[/code][/quote]
J’ai installé le paquet sux (apt-get install sux) et maintenant, je peux lancer des appli X depuis la console pour n’importe quel user.


#8

sucks ? joli nom :slightly_smiling: . mais tu casses toute la poesie d’X windows avec tes solutions simples…
Que deviennent les xauth, xhost, et les extensions xdcmp ?
Pourquoi faire simple, quand on peut faire compliqué ?
:cry: