Problèmes squid / Ident


#1

Bonjour,

J’ai un problème avec Squid.

En effet, mon proxy Squid fonctionne bien mais je rencontre un problème au niveau de l’identification des utilisateurs.

En effet, sur les machines clientes (Windows), il y a le service Ident qui tourne. Dans squid.conf, j’ai défini une ACL : acl utilAutorises ident remy02. Ensuite, j’ai défini une autre ACL pour permettre l’authentification : acl auth proxy_auth REQUIRED.

Donc normalement, si je veux aller sur Internet, avec mon compte remy02, je dois pouvoir me connecter sans authentification. Or ce n’est pas le cas, il me demande de m’authentifier.

Est-ce que quelqu’un aurait une petite idée ?

Merci beaucoup


#2

tu as défini des acl en ident, ce qui provoque bien le “lookup”, mais as tu bien pensé ensuite à dire si tu autorisais ou non à passer:
http_access allow utilAutorises
(question que je me pose en relisant squid-cache.org/Doc/FAQ/FAQ-10.html#ss10.7 )


#3

Oui oui j’ai fait ca.

http_access allow UtilAutorises


#4

essayes de rajouter une acl basée sur l’ip, et de changer ton acl ident:acl lan src 192.168.X.0/255.255.255.0 ... acl utilAutorises ident lan remy02
c’est comme ça qu’ils font dans l’exemple que je t’ai signalé, et ça paye pas de mine de restreindre les adresses autorisées…

mais en réfléchissant, je ne suis pas trop sur d’ou ça peut venir, désolé.

et tu as regardé si ca ne venait pas de la configuration de l’accés au plugin proxy_auth ou ident(je ne me souviens plus comment c’est fait dans la config), car si je me souviens bien, ça fait appel à un .so (une lib) externe, et si elle n’est pas à l’endroit attendu, si je me souviens bien, plutot que de planter, squid considère que c’est un refus d’authentification.
A tous hasards…


#5

et tu ne sais pas comment elle s’appelle cette lib externe et ou elle se trouve ?

g essayé un : find / | grep ide*.so. Il n’y a rien


#6

Franchement MERCI MattOTop !!!

C’est bon ca marche en fait. Cqe tu ma dis de faire marche.

Voila ce que j’ai fait :

ACL lan src 192.168.10.0/255.255.255.0
ACL ServiceInfo ident remy02
ACL UtilsAutorises ident bidon01…

http_access lan Informatique UtilisateursAutorises

ET CA MARCHE !!!

NAN en fait ca ne marche pas, c’est pas ce que je voulais.

Avec ce que tu m’as dit d’ajouter dans squid.conf, cela autorise toutes les machines de mon réseau à aller sur le net sans authentification. Or moi ce que je veux, c’est que seules les utilisateurs compris dans l’ACL utilsautorisés puissent se connecter directement à Internet.

Pour tester, j’ai désactivé le service Ident de mon PC. Donc si Ident ne marche pas, je devrais m’authentifier or ce n’est pas le cas.


#7

Un petit résolu dans le titre :slightly_smiling:


#8

NAN en fait ca ne marche pas, c’est pas ce que je veux.

Avec ce que tu m’as dit d’ajouter dans squid.conf, cela autorise toutes les machines de mon réseau à aller sur le net sans authentification. Or moi ce que je veux, c’est que seules les utilisateurs compris dans l’ACL utilsautorisés puissent se connecter directement à Internet.

Pour tester, j’ai désactivé le service Ident de mon PC. Donc si Ident ne marche pas, je devrais m’authentifier or ce n’est pas le cas.