Programmation avec Ubuntu


#1

Bonjour,

je viens tout juste de m’installer Ubuntu Breezy.

Dans mon sources.list,qu’est ce que je dois faire car il me semble que rien n’est installé.
Je ne peux pas faire de C,C++,Java,Perl,SQL,…

Je voudrais savoir comment faire pour installer ces langages et d’autres selon mes besoins.

Voici mon sources.list

[quote]deb cdrom : [Ubuntu 5.10 Breezy Badger_ -Realese i386 (20051012)]/ breezy main restricted

Uncomment the following two lines to fetch updated software from the network

deb fr.archive.ubuntu.com/ubuntu breezy main restricted

deb-src fr.archive.ubuntu.com/ubuntu breezy main restricted

Uncomment the following two lines to fetch major bug fix updates produced

after the final release of the distribution

deb fr.archive.ubuntu.com/ubuntu breezy-updates main restricted

deb-src fr.archive.ubuntu.com/ubuntu breezy-updates main restricted

Uncomment the following two lines to add software from the ‘universe’

repository

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team, and may not be under a free licence. Please satisfy yourself as to

your rights to use the software. Also,please note that software in

universe WILL NOT receive any review or updates from the Ubuntu security

team

deb fr.archive.ubuntu.com/ubuntu breezy universe

deb-src fr.archive.ubuntu.com/ubuntu breezy universe

Uncomment the following two lines to add software from the ‘backports’

repository

N.B. software from this repository may not have been tested as

extensively as that contained in the main release, although it includes

newer versions of some applications which may provide useful features.

Also,please note that software in backports WILL NOT receive any review

or updates from the Ubuntu security team.

deb fr.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse

deb-src fr.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse

deb security.ubuntu.com/ubuntu breezy-security main restricted

deb-src security.ubuntu.com/ubuntu breezy-security main restricted

deb security.ubuntu.com/ubuntu breezy-security universe

deb-src security.ubuntu.com/ubuntu breezy-security universe[/quote]

Merci d’avance


#2

Tout est commenté tu ne peux donc rien allez chercher décommente les sources et ensuite install les paquets qui te sont necessaires pour le developpement.

Pour java, c, c++, tu as eclipse qui fonctionne bien
pour java seul tu as netbeans aussi

Normalement tu peux déjà faire de la programmation C et Perl car c’est déjà implémenté

Pour le SQL regarde du coté de PostgreSQL

[code]deb cdrom : [Ubuntu 5.10 Breezy Badger_ -Realese i386 (20051012)]/ breezy main restricted

Uncomment the following two lines to fetch updated software from the network

deb http://fr.archive.ubuntu.com/ubuntu breezy main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu breezy main restricted

Uncomment the following two lines to fetch major bug fix updates produced

after the final release of the distribution

deb http://fr.archive.ubuntu.com/ubuntu breezy-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu breezy-updates main restricted

Uncomment the following two lines to add software from the ‘universe’

repository

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team, and may not be under a free licence. Please satisfy yourself as to

your rights to use the software. Also,please note that software in

universe WILL NOT receive any review or updates from the Ubuntu security

team

deb http://fr.archive.ubuntu.com/ubuntu breezy universe
deb-src http://fr.archive.ubuntu.com/ubuntu breezy universe

Uncomment the following two lines to add software from the ‘backports’

repository

N.B. software from this repository may not have been tested as

extensively as that contained in the main release, although it includes

newer versions of some applications which may provide useful features.

Also,please note that software in backports WILL NOT receive any review

or updates from the Ubuntu security team.

deb http://fr.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu breezy-security main restricted
deb-src http://security.ubuntu.com/ubuntu breezy-security main restricted

deb http://security.ubuntu.com/ubuntu breezy-security universe
deb-src http://security.ubuntu.com/ubuntu breezy-security universe[/code]
pour l’installation c’est apt-get install paquet
et si tu veux savoir exactement quel paquet prendre apt-cache search paquet ou paquet correspond au paquet que tu veux installer comme eclipse par exemple


#3

Et pour info, ce qu’ash n’a pas dit, c’est que “décommenter” veut dire “enlever le # en début de ligne” :wink:
PS: et synaptic a une zoulie interface pour gèrer les sources, et les activer/desactiver à volonté.


#4

Salut,

merci pour toutes ces précisions.
Comme je suis débutants,je préfère utiliser un éditeur de texte simple .
Je crois que Eclipse n’est pas à conseiller au débutant.

Sinon,est ce qu’il y a des éditeurs de textes (simples et qui font l’indentation) de pré-installer sur Ubuntu .
Si c’est le cas,est ce qu’ils sont bons?

Sinon,que me recommandes-tu ?


#5

rien de tel qu’un bon petit kate ( kate.kde.org/ ) pour ça :smiley:

cependant cela necessite un minimum de librairies KDE …

kubuntu.org/announcements/kde-351.php

wget http://people.ubuntu.com/~jriddell/kubuntu-packages-jriddell-key.gpg sudo apt-key add kubuntu-packages-jriddell-key.gpg

pour le sources.list sous ubuntu:

ubuntulinux.nl/source-o-matic
ubuntuforums.org/showthread.php?t=92672
forum.ubuntu-fr.org/index.php


#6

Sans etre obligé d’installer les paquets de base de kde j’utilise scite comme editeur de texte graphique avec coloration syntaxique et indentation automatique.

Sinon tu peux aussi t’amuser avec emacs ou vi (Meme si on sait que vi est mieux qu’emacs</mode troll expres pour Matt>)

Sinon pour eclipse il est vrai que ce n’est pas recommandé pour les débutants mais il faut bien commencé un jour :stuck_out_tongue:


#7

[quote=“Ashgenesis”]
pour l’installation c’est apt-get install paquet
et si tu veux savoir exactement quel paquet prendre apt-cache search paquet ou paquet correspond au paquet que tu veux installer comme eclipse par exemple[/quote]

Pour la recherche de langage de programmation pour installation ,il suffit juste de faire pour python par exemple :

pour C++

etc…

PS: est-ce que faire les commandes pour l’installation impliquent que l’on doit avoir le net d’allumer sur le PC


#8

par dédaut, ed et vi sont installés, mais pas trés conviviaux. vim, la version X de vi, est déjà plus “classique” dans son usage.
Un éditeur minimaliste, mais je ne sais pas s’il est installé en standard, c’est nano.
Et sinon, il y a tous les éditeurs des difèrents wm (KDE et Gnome), ainsi, qu’emacs/xemacs (mais je ne dirait pas que c’est le plus bô parceque les “vi” istes vont me tomber sur le dos).
sinon, aptitude search text editor | grep “^.?i” devrait te donner une piste de ce que tu as d’installé.