Pxelinux debian live keymap


#1

Bonjour,

J’ai posé les fichiers filesystem.squashfs initrd et vmlinuz sur une serveur pxe.
J’ai créé le fichier de boot suivant

[quote]DEFAULT system

label system
KERNEL system/vmlinuz
APPEND initrd=system/initrd.img boot=live config quiet splash lang=fr_FR.UTF-8 locales=fr_FR.UTF-8 keyboard-model=pc105 keyboard-layouts=fr keyboard-variant=latin9 timezone=Europe/Paris utc=yes fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs[/quote]

Ca boot, mais le keymap est en qwerty quand même après le boot, sur le tty1, au moment du login.
Comment passer en azerty s’il vous plait ?

Bonne soirée.


#2

Alors ce que j’ai testé :

APPEND initrd=system/initrd.img boot=live config setkmap=fr fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config keyboard-layouts=fr fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config keyboard-model=pc105 fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config keyboard-variant=latin9 fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config keyboard-configuration/xkb-keymap=fr(latin9) fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config kbd-chooser/method=fr fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config locale=fr_FR fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config console-setup/layoutcode=fr fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config console-setup/modelcode=pc105 fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config live-config.locales=fr fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config languagechooser/language-name=French fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config countrychooser/shortlist=fr_FR fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs
APPEND initrd=system/initrd.img boot=live config console-keymaps-at/keymaps=fr-latin9 fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs

Et même un combo de tout ca, avec toutes les options :
APPEND initrd=system/initrd.img boot=live config languagechooser/language-name=French countrychooser/shortlist=fr_FR console-keymaps-at/keymaps=fr-latin9 setkmap=fr keyboard-layouts=fr keyboard-model=pc105 keyboard-variant=latin9 keyboard-configuration/xkb-keymap=fr(latin9) kbd-chooser/method=fr locale=fr_FR console-setup/layoutcode=fr console-setup/modelcode=pc105 live-config.locales=fr fetch=tftp://xxx.xxx.xxx.xxx/system/filesystem.squashfs

Rien n’y fait…