Qemu/ droits pour le réseau


#1

Bonjour,

J’ai installé qemu et je ne parviens pas à lancer une machine virtuelle avec les droits pour le réseau en utilisateur.

Je me suis attribué les droits sur /dev/net/tun et rendu le script suivant executable :
#!/bin/sh
/sbin/ifconfig $1 192.168.0.1 netmask 255.255.255.0

Lorsque je lance qemu -hda freebsd.img -boot c -n ifup.sh

J’obtiens :

onnected to host network interface: tun0
SIOCSIFADDR: Permission non accordée
SIOCSIFFLAGS: Permission non accordée
SIOCSIFNETMASK: Permission non accordée
ifup.sh: could not launch network script

Et là, franchement je suis dépassé, je ne sais même plus où chercher!

Si un gourou pouvait parfaire mon education, d’avance merci,

:slightly_smiling:


#2

est ce que le logiciel que tu utilise a les droits d’acces au reseau car si ce n’est pas le cas il risque d’y avoir une erreur cependant je ne suis pas expert mais je te propose une reponse


#3

Merci,

Oui normalement qemu permet de lancer un pc virtuel avec connection, j’ai trouvé des info pour l’installe à cette adresse : gcu-squad.org/viewtip/176-FreeBS … oxage.html

Le problème c’est que je ne peux même pas tenter en root, j’ai le message d’erreur suivant : Xlib: connection to “:0.0” refused by server

Bon moi aussi je suis trés loin d’être un expert, mais jusqu’ici je savais par où chercher, là je suis vraiment paumé.


#4

As tu essayer de creer un nouveau groupe et de lui autoriser l’acces au reseau et de rajouter qemu au groupe afin qu’il est les droits d’acces ou alors il y a peut etre un processus qui utilise deja la connection reseau et il n’accepte pas une connection en plus

Est ce que tu arrive a le lancer sans le reseau ?


#5

Oui, sans problème pour le lancer sans le réseau, même avec l’appli s’ouvre mais la machine virtuel n’est pas connecté.

Je ne crois pas qu’un autre processus utilise quoi que ce soit, en fait l’interface réseau est simulée et non physique, elle sert à la communication de la machine virtuel et de la machine hôte, si j’ai bien compris.

Je pense que je c’est bien un problème de droit, j’explorerai ton idée ce week end, je vais manquer de temps avant.

Pour tout te dire si je suis ci perdu c’est que mon idée première était d’en apprendre un peu plus sur les réseaux grace à ce soft (je ne dispose que d’un pc à domicile) car je n’y connais rien. L’ennui c’est que sa configuration semble nécessiter des connaissances liées au réseau !

A plus, ce soir je lache mon pc pour cause de rituel social (anniversaire de belle-mère :cry: ).


#6

[quote=“KARL”]Pour tout te dire si je suis ci perdu c’est que mon idée première était d’en apprendre un peu plus sur les réseaux grace à ce soft (je ne dispose que d’un pc à domicile) car je n’y connais rien. L’ennui c’est que sa configuration semble nécessiter des connaissances liées au réseau !
[/quote]Si tu as besoin d’aide niveau reseau n’hesite pas pose tes questions meme si tu a l’impression qu’elles sont betes on est tous deja passé par la :smiley:[quote=“KARL”]
A plus, ce soir je lache mon pc pour cause de rituel social (anniversaire de belle-mère :cry: ).[/quote]Je te plains j’ai la chance de ne pas encore avoir de belle mere :smiley::smiley:
Courage :stuck_out_tongue:


#7
Pour ce problème là c'est probablement parce que ton interface graphique est lancée par une session utilisateur standard. Ensuite, tu ouvres un terminal en root et tu lances ta commande et le serveur X gueule parce que tu n'as pas donné les droits nécessaires à root pour afficher dans la session X courante.

Essayes de taper xhost +

Chez moi:
[root@aspirateur linux]# xhost +
access control disabled, clients can connect from any host
[root@aspirateur linux]#

En gros: Xwindows étant un logiciel client-serveur, ton affichage, tu peux l'envoyer sur une machine à l'autre bout du monde, si tu veux... Pour autant que la machine distante aie des droits suffisants pour afficher ton bureau graphique.

Etant donné que tu as une adresse IP différente pour ta machine virtuelle, je suppose que le problème est le même ( mais j'y connais rien à Qemu ... )

xhost te permet de gérer les droits à ce niveau là ...

Le début de la man page de xhost:

[quote]
XHOST(1)                                                             XHOST(1)
 
NAME
       xhost - server access control program for X
 
SYNOPSIS
       xhost [[+-]name ...]
 
DESCRIPTION
       The  xhost  program is used to add and delete host names or user names
       to the list allowed to make connections to the X server.  In the  case
       of  hosts,  this  provides  a  rudimentary form of privacy control and
       security.  It is only sufficient for a workstation (single user) envi-
       ronment,  although it does limit the worst abuses.  Environments which
       require more sophisticated measures should  implement  the  user-based
       mechanism or use the hooks in the protocol for passing other authenti-
       cation data to the server.
[/quote]

Pour ce problème là c’est probablement parce que ton interface graphique est lancée par une session utilisateur standard. Ensuite, tu ouvres un terminal en root et tu lances ta commande et le serveur X gueule parce que tu n’as pas donné les droits nécessaires à root pour afficher dans la session X courante.

Essayes de taper xhost +

Chez moi:
[root@aspirateur linux]# xhost +
access control disabled, clients can connect from any host
[root@aspirateur linux]#

En gros: Xwindows étant un logiciel client-serveur, ton affichage, tu peux l’envoyer sur une machine à l’autre bout du monde, si tu veux… Pour autant que la machine distante aie des droits suffisants pour afficher ton bureau graphique.

Etant donné que tu as une adresse IP différente pour ta machine virtuelle, je suppose que le problème est le même ( mais j’y connais rien à Qemu … )

xhost te permet de gérer les droits à ce niveau là …

Le début de la man page de xhost: