Que veut dire ce msg ?


#1

[quote]ricardo2@debian-etch:~$ sudo kedit /etc/apt/sources.list
Password:
Error: “/tmp/kde-ricardo2” is owned by uid 1000 instead of uid 0.
Link points to “/tmp/kde-root”

[/quote]
malgré ça, il m’ouvre quand m^ kedit.


#2

c’est ce que je t’ai déja dit:
même si tes users ont le même nom sur les deux installs (et même si ce n’est pas le cas), pour être identifiés comme un même utilisateur et avoir les mêmes droits, tes deux users doivent avoir le même uid (si c’est 1000 d’un coté, ca doit etre 1000 de l’autre)…
je penses que pour corriger ca, il suffit d’homogeneiser les uid dans /etc/password. (peut être un peu de chown aprés pour mettre au carré)…


#3

C’est un peu ça mais j’ai la réponse qui me semble logique, dis-moi ce que tu en penses :
Ds l’exemple ci-dessus, je passe par sudo et donc par mon user (unique sur cette install = ricardo2) qui a pour iud ‘1000’ mais le msg demande un iud de ‘0’ et ‘0’ c’est root.
J’ai donc fait le m^ appel de kedit (ou autre TT) mais cette fois en tant que ‘root’ avec ‘su’ et là, je n’ai plus ce msg.
Peut-on règler ça au niveau de sudo ?
De ttes façons, ce n’est pas gênant puisque ça ouvre quand m^le TT.
Voilà ce que donne /etc/passwd :

root:x:0:0:root:/root:/bin/bash daemon:x:1:1:daemon:/usr/sbin:/bin/sh bin:x:2:2:bin:/bin:/bin/sh sys:x:3:3:sys:/dev:/bin/sh sync:x:4:65534:sync:/bin:/bin/sync games:x:5:60:games:/usr/games:/bin/sh man:x:6:12:man:/var/cache/man:/bin/sh lp:x:7:7:lp:/var/spool/lpd:/bin/sh mail:x:8:8:mail:/var/mail:/bin/sh news:x:9:9:news:/var/spool/news:/bin/sh uucp:x:10:10:uucp:/var/spool/uucp:/bin/sh proxy:x:13:13:proxy:/bin:/bin/sh www-data:x:33:33:www-data:/var/www:/bin/sh backup:x:34:34:backup:/var/backups:/bin/sh list:x:38:38:Mailing List Manager:/var/list:/bin/sh irc:x:39:39:ircd:/var/run/ircd:/bin/sh gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh nobody:x:65534:65534:nobody:/nonexistent:/bin/sh Debian-exim:x:102:102::/var/spool/exim4:/bin/false ricardo2:x:1000:1000:ricardo2,,,:/home/ricardo2:/bin/bash identd:x:100:65534::/var/run/identd:/bin/false sshd:x:101:65534::/var/run/sshd:/bin/false saned:x:107:107::/home/saned:/bin/false messagebus:x:103:108::/var/run/dbus:/bin/false


#4

Dans ce cas:
Dis moi , est ce que par hasard tu n’aurais pas déja un kedit d’ouvert, mais en ricardo2, au moment ou tu lances un deuxiême avec sudo ?
Parceque je verrais bien un truc du genre le kedit ricardo2 cree /tmp/KDE-ricardo2 appartenant à ricardo2, et le sudo kedit, qui n’est pas vraiment une execution en su, cafouille en voulant utiliser /tmp/KDE-ricardo2, alors que quand tu le lances en su, il tente bien d’utiliser /tmp/KDE-root, ce qui ne lui pose pas de pb…
Ca serait bien un bug mineur à signaler aux packagers debian KDE (je dis mineur, mais il y a peut être une exploit là dessous)…


#5

Voilà ce que ça donne sous ma Debian fonctionnelle en ‘sid’

ricardo3@ricardo:~$ sudo kedit /boot/grub/menu.lst Password: Error: "/tmp/kde-ricardo3" is owned by uid 501 instead of uid 0. Link points to "/tmp/kde-root"
et en tant que root :

ricardo3@ricardo:~$ su access control disabled, clients can connect from any host Password: ricardo:/home/ricardo3# kedit /boot/grub/menu.lst Link points to "/tmp/ksocket-root" kbuildsycoca running... KWrited - Écoute le périphérique « /dev/pts/2 » libhal.c 767 : org.freedesktop.DBus.Error.ServiceDoesNotExist raised "Service "org.freedesktop.Hal" does not exist" ricardo:/home/ricardo3#

J’ai bien fait attention, il n’y a rien d’autre de chargé.


#6

tu n’as pas lu/compris mon post precedent. Ricardo, manges tes vitamines, tu fonctionnes sur un mode diesel ce soir…


#7

Bon, j’ai essayé avec de l’essence mais je ne comprends pas mieux :blush:
Je recharge ma bécane,
Je vais ds /tmp et je n’ai que deux dossiers du genre :
kde-ricardo3 et kde-root

  • des soket, orbite et autres insultes
    Je suis seul sur ma machine et avec une seule machine, pas d’autres user en service.
    J’accepte que tu me dises cette fois que je fonctionne au pétrole mais dis-moi clairement ce que je dois faire pour trouver une pompe qui distribue du super sans plomb 99,9 :laughing:

#8

pas le tps pr l’instant.
Réponds déjà à ma question, ca voudra dire que tu as compris.


#9

[quote]Dis moi , est ce que par hasard tu n’aurais pas déja un kedit d’ouvert, mais en ricardo2, au moment ou tu lances un deuxiême avec sudo ? [/quote] NON !


#10

bon, oublies mes dernières remarques. J’ai verifié ce que je supposais, et c’est faux, donc en plus d’avoir l’air c#@, je me suis énervé pour rien.
Mais pour ma défense, je découvre la vitesse de déplacement d’un bébé à quatre pattes, et sa propension à ne faire QUE ce que tu lui interdit (jouer avec les fils éléctriques, passer sous des tablettes chargées de pots de fleurs, appuyer sur tous les bourtons de la chaine)…
J’ai perdu quinze kilo de transpiration depuis ce midi à me relever toutes les trois secondes (en moyenne: des fois, c’est 1/2) pour le ramener en zone sûre.
Avec ca, j’ai mon chien qui prend tous mes “NON !” pour lui, et qui m’a fait casser la gueule deux fois aujourd’hui en se foutant dans mes pattes…
RAAAAAAAAAAAAAAAAAHHHHHHHHHHH ! not lovely…

OUUUAAAAAAAH il est debout dans son parc ! zut, je croyais être tranquille, mais ca c’est nouveau. Même la je ne suis pas au calme. Je vais le féliciter… à plus tard.


#11

J’accepte tes excuses :laughing: et je compatis : j’ai donné, il y a 35 et 40 ans. A l’époque, je ne tapais pas encore sur un clavier d’ordi mais je bricolais déjà avec des outils dangereux :bulb:
Bon, j’ai installé ma derniere Debian, encore en Sarge mais destinée à être “mutée” en Sid.
Elle est donc tte neuve et j’ai installé Sudo (avec echo …) vérification faite ensuite ds /etc/sudoers, bizarre, je ne vois que ce que j’y ai apporté.

Il me semblait (sur les autres Debian) que root était installé automatiquement ?
Msg :

[code]ricardo3@debian-sid:~$ sudo kedit /boot/grub/menu.lst

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

Password:
Error: “/tmp/kde-ricardo3” is owned by uid 1000 instead of uid 0.
Creating link /root/.kde/tmp-debian-sid.
Created link from “/root/.kde/tmp-debian-sid” to "/tmp/kde-root"
ricardo3@debian-sid:~$

[/code][/quote]


#12

:open_mouth:
dsl, je ne vois pas…