Quelques pb après l'instal


#1

Bonjour

Je viens d’installer Debian 3.0-1 (avec le noyau 2.4.18-bf2.4) et ce n’est pas parfait (je plaide coupable : je ne suis pas très doué). Voici mes problèmes :

  1. La carte son n’est pas reconnue : j’ai vraissemblablement raté une marche lors de l’instal. Il s’agit d’une 5880 AudioPci 1371.
  2. L’imprimante non plus (HP deskjet 840 C)
  3. La molette de la souris (Logitech)

D’autre part, je ne comprend pas pourquoi apt-get ne me propose pas d’upgrader certains softs. Par exemple mozilla : la version installée est la 1.0. et “apt-get update” suivi de “apt-get upgrade” ne me propse rien de plus récent.

Merci de votre aide.


#2

Salut

hmm, avant toute chose, Debian n’est pas RedHat ni Mandrake, et il n’y a pas d’autodetection de ton matériel. L’ideal est d’installer un systeme de base. Si tu l’installes via le(s) CD, je te conseille en effet de faire un apt-get upgrade dès le départ, tu auras ainsi un systeme a jour, que ce soit en stable ou unstable.

Pour ce qui est de ta carte son, regardes si le module est deja fourni par Debian avec l’outil modconf. Un " lspci " peut aussi etre utile pour connaitre le chipset de ta carte. Pour l’imprimante, CUPS peut t’aider :smiley: voir : linuxprinting.org/cups-doc.html

Et enfin pour la molette sous X, un petit coup de google t’aurais donner la réponse a mon avis. Voila la conf a mettre en place dans ton fichier /etc/X11/XF86Config-4 :

Ceci est un exemple !! a adapter a ta config…

Section "InputDevice"
Identifier "Souris USB"
Driver "mouse"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

C’est cette partie qui te permettras d’utiliser la molette …

    Option          "Protocol"              "ImPS/2"
    Option          "Emulate3Buttons"       "true"
    Option          "ZAxisMapping"          "4 5"

bon courage

Sylvain


#3

Merci sylvain.

Quelques améliorations :

  1. La carte son est reconnue mais ne semble utilisable que par le superutilisateur. Si j’essaye de lancé xmms en mode utilisateur standard, j’obtient :

hyppolite:/home/fal# su fal
fal@hyppolite:~$ xmms &
[1] 627
fal@hyppolite:~$
Gdk-WARNING **: locale not supported by C library
libmikmod.so.2: cannot open shared object file: No such file or directory

  1. La molette de la souris fonctionne lorsque l’on se sert pour cliquer (par exemple pour un copier-coller) mais pas pour faire défiller un document. Voici l’extrait de /etc/X11/XF86Config-4 :

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/psaux"
Option “Protocol” "PS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option “SendCoreEvents” "true"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection


#4

j’oublie la ligne la plus importante :

fal@hyppolite:~$ xmms &
[1] 627
fal@hyppolite:~$
Gdk-WARNING **: locale not supported by C library
libmikmod.so.2: cannot open shared object file: No such file or directory

fal@hyppolite:~$
** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): Permission denied

fal@hyppolite:~$

Permission denied ? Il y a des permissions sur les périphériques ?


#5

J’ai changé les droits sur /dev/dsp et maintenant j’ai du son !!


#6

Changer les droits des /dev/* me parait qd meme être une solution pas très propre … alors qu’ils suffit de se rajouter dans le groupe audio pour avoir du son.


#7

voila qui est arrangé.
il me reste ce problème de souris.


#8

[quote=“Fal”]Merci sylvain.

Quelques améliorations :

  1. La carte son est reconnue mais ne semble utilisable que par le superutilisateur. Si j’essaye de lancé xmms en mode utilisateur standard, j’obtient :

hyppolite:/home/fal# su fal
fal@hyppolite:~$ xmms &
[1] 627
fal@hyppolite:~$
Gdk-WARNING **: locale not supported by C library
libmikmod.so.2: cannot open shared object file: No such file or directory

  1. La molette de la souris fonctionne lorsque l’on se sert pour cliquer (par exemple pour un copier-coller) mais pas pour faire défiller un document. Voici l’extrait de /etc/X11/XF86Config-4 :

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/psaux"
Option “Protocol” "PS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option “SendCoreEvents” "true"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection[/quote]

ok, assure toi d’avoir a la fin de ton fichier XF86Config-4, ca :

    InputDevice     "Generic Mouse" "CorePointer"
    InputDevice     "Configured Mouse" "SendCoreEvents

le support de la molette est assuré, entre autre, par le protocol “ImPS/2”

Sinon, pour le droit sur /dev/dsp, l’ideal comme l’a dit Dracus, c’est de s’ajouter au groupe audio via : adduser audio

a+


#9

J’ai modifié /etc/X11/XF86Config-4 comme tu me le conseilles :

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice “Configured Mouse” "SendCoreEvents
InputDevice “Generic Mouse” "CorePointer"
EndSection

Mais rien y fait…


#10

intervertis ces 2 lignes :

InputDevice “Configured Mouse” "SendCoreEvents
InputDevice “Generic Mouse” “CorePointer”

Vu que le protocole ImPS/2 est declaré dans Generic Mouse, il faut que la ligne qui y fait reference soit traitée en premier.

Cependant, si tu n’as qu’une seule souris, commente le bloc

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/psaux"
Option “Protocol” "PS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

et supprime la ligne InputDevice “Configured Mouse” "SendCoreEvents et passe InputDevice “Generic Mouse” “CorePointer” en InputDevice “Generic Mouse” “SendCoreEvents”

a+