Question académique: installation debootstrap avec 48Mo


#1

Voila, hier matin, avant de partir du boulot, j’ai lancé une knoppix, sur une vieille machine 95/PII 75 que je veux reconfigurer en routeur, dans le but de faire de chez moi une install en debootstrap (je ne suis pas censé retourner sur place avant vendredi, mais j’ai mes acces à distance, alors je souhaitais m’avancer).
Au démarrage, j’ai oublié de préciser que je ne voulais pas de gui, et comme je n’ai que 48Mo sur la machine, il m’a créé un swap en loopback sur hda1.
Dès que j’ai eu la main et avant que l’interface X se lance, je suis passé en runlevel 3 (parfait, je suis bien en mode console). Le serveur ssh s’est lancé sans pb…
De retour chez moi, je me connecte nickel, je fais un ‘swapoff -a’ et un ‘umount /dev/hda1’ (la partition unique 95 sur lequel était monté le swap). Et je commence à partitionner.
Et là problème: je lance fdisk, mais aucun echo…
Je me logue une deuxieme fois en ssh, un kill -9 et rien… Mon fdisk reste en mêmoire, même quand je me déconnecte.
Même chose quand je tente de remonter mon hda1 pour reactiver le swap, la commande ne se termine pas.
La commande ‘free’ me donne le resultat suivant:

             total       used       free     shared    buffers     cached
Mem:         43756      40844       2912          0       1980      18488
-/+ buffers/cache:      20376      23380
Swap:            0          0          0

Vola ma question: j’imagine que l’ecran de la console doit etre rempli de message “memoire insuffisante”, mais j’aimerais tt de même insister et formatter mon disque, et créer le swap qui me permettra de continuer mon install. Le tout à distance bien sur…
Si quelqu’un a une idée :wink:


#2

ça ne te donnera certainement pas d’explications mais quand je tape fdisk -l, rien ne se passe

[quote]debian:/home/ricardod# fdisk -l
debian:/home/ricardod#
[/quote]
alors qu’avec les autres distribs, j’ai un rslt.


#3

chez moi, le fdisk -l fonctionne trés bien, mais je ne tiens pas gaspiller mes cartouches enmultipliant les commandes “inkillables”, dc je n’essayes pas sur la machine distante.
Mais à mon avis, c’est pas normal ce que tu as chez toi…


#4

Il y a tellement de choses anormales chez moi :cry:
La dernière en date :
je fais un update et un upgrade et je n’ai plus de son sur Alsa ???
Mais ça, je m’en fous, ce qui m’importe c’est de pouvoir compiler mon 2.6.9 et là, je passe sur l’autre topic.
je suis complètement vérolé :cry:


#5

bon, a part ca, personne n’a d’idée ?


#6

Ben ca ne m’étonne pas… Upgrade modifie tellement de choses (sur une sarge) que le son a beaucoup de risque de merder … Surtout pour alsa, qui me paraît en perpétuel développement …

en installant apt-listbugs il te donne une liste des packages susceptibles d’introduire des bugs, et te demandes de confirmer leur maj. ca peut aider à maintenir ton système en état de marche


#7

Non, pas vraiment … Tu es bien connecté en ssh et pas via un terminal serveur sur lequel la machine est elle-même connectée en port-série ? Parce que dans ce cas là, ça fout souvent la m…

Et t’es sûr que X est vraiment arrêté ?


#8

Réponse à jabba :

[quote]debian:~# apt-listbugs -l
E: You need to specify a command.
Usage: apt-listbugs [options] [arguments]
Options:
-h : Display this help and exit.
-s : Severities you want to see [critical,grave].
-T : Tags you want to see.
-S : Stats you want to see [outstanding,pending upload,resolved,done,open,].
-l : Show bugs already existed in your system.
-g : Show newer bugs than upgrade packages.
-D : Show downgraded packages, too.
-H : Hostname of Debian Bug Tracking System [osdn.debian.or.jp].
-p : Port number of the server [80]
-R : Use Release-Critical bug reports
-I : Use debbugs index.db
–indexdir : Directory where index.db located [/~taru/apt-listbugs/]
–pin-priority : Specifies Pin-Priority value [1000]
–title : Specifies the title of rss output.
-f : Retrieve bug reports from BTS forcibly.
-q : Don’t display progress bar.
-c : Specify cache_dir [/var/cache/apt-listbugs/].
-t : Specify cache expire timer in minutes[60].
-C <apt.conf> : Specify apt.conf.
-y : Assume that you select yes for all questions.
-n : Assume that you select no for all questions.
Commands:
apt : apt mode
list <pkg…> : list bug reports of the specified packages
rss <pkg…> : list bug reports of the specified packages in rss
See the manual page for the long options.
debian:~#[/quote]

et ensuite, où je cherche ?


#9

En fait je ne l’ai utiliisé que très basiquement jusqu’à maintenant.
Je l’ai installé et laissé sans aucune configuration.
Apparement, ca suffit pour être averti des upgrades dangereux quand tu lances apt-get upgrade.

En lisant la doc, il semble qu’il y aie pas mal d’options possibles:

Mais bon, on est en train de “pirater” le “post” de MattOTop, pas en train de chercher à résoudre son problème … Sorry MattOTop :confused:


#10

Ok, laissons tomber ça pour l’instant.
J’ai d’autres problèmes à règler avant avec ma compil :cry:


#11

[quote]Ok, laissons tomber ça pour l’instant.
J’ai d’autres problèmes à règler avant avec ma compil [/quote]

Bah, tant qu’à faire essayes de trouver la syntaxe de apt-listbugs pour détecter les paquets buggés qui seraient éventuellement installés sur ton système …
Qui sait, ca pourrait aussi t’aider à résoudre tes problèmes de compil …