Questions supplémentaires à Alexis Delattre


#1

Bonjour à tous,
je commencerai d’abord par dire merci alexis, Merci beaucoup :exclamation:
je mets quand même le lien, bien connu, vers la méthode :
http://people.via.ecp.fr/~alexis/formation-linux/

ben je comprends pas tout non plus alors je vais poser mes questions, comme c’est des choses trés simples, enfin je crois, j’ai bon espoir. :wink:

Questions résolues : :stuck_out_tongue:
Chapitre 11 $2.2.1 configurer les interfaces réseaux :
Différence entre eth0 et Wlan0 ?

Exemple d’interfaces eth0 et wlan0 dans le fichier /etc/network/interfaces:

[code]auto eth0
iface eth0 inet static
address 192.168.0.12
netmask 255.255.255.0
gateway 192.168.0.1

auto wlan0
iface eth0 inet static
address 192.168.0.12
netmask 255.255.255.0
gateway 192.168.0.1
wireless_essid Wanadoo_c241 # le mien
wireless_mode managed
wireless_channel 7
wireless_key 67F43AC3DD32… # et le reste (…) vu que 128 bits la clé … sans “:”[/code]

Les essid : sensible à la casse ? oui (Twistophe)
j’en deduit que mon essid devra bien être noté tel qu’il apparait dans la configuration de ma livebox

La clé Wep : avec ou sans les deux points ? et quelle taille ?

[quote]le nombre de caractère de ta clé WEP / WPA changent suivant la “puissance” de l’encryptage : clé 64 bits = 13 caractères, clé 128 bits = 26 caratcères …
plus loin :
Une clé WEP de 128 bits est quasiment toujours saisie par les utilisateurs comme une suite de 26 symboles hexadécimaux[/quote]
ya pas plus clair.
Questions courantes : :confused:
Aussi je me demande si je peux me connecter en wifi, je n’ai pas de carte réseau mais un connecteur intégré à la carte mère ?
Par défaut, il va le system va construire quelle interface ? celle qui marche, la dernière qui marche ? ou la dernière tout court notifiée dans /interfaces ?

###########################################################################
Vieilles questions : 8)
Chapitre 11 $2.2.1 configurer les interfaces réseaux :

[quote]Dans le cas d’une interface WiFi, il faut tout d’abord installer le package qui gère les extensions wireless des interfaces WiFi :

apt-get install wireless-tools

Ensuite, il suffit d’ajouter les paramètres spécifiques au WiFi aux paramètres normaux de l’interface. Par exemple :
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
address 192.168.0.12
netmask 255.255.255.0
gateway 192.168.0.1 #derniere ligne de eth0 en rj45 ?
wireless_essid mynetwork #première ligne de wlan0 avec adaptateur ?
wireless_mode managed
wireless_channel 7
wireless_key 67:F4:3A:C3:DD:32
[/quote]
Différence entre eth0 et Wlan0 ?
Est-ce que je peux ajouter à l’interface lo une interface (celle actuelle) eth0,
puis une interface wlan0 avec les lignes netmask, gateway et essid seulement ?
Est-ce que “mynetwork” est sensible à la majuscule/minuscule ?
Wireless_key :
c’est toujours un code à 12 caractères ?
ex : chez moi, j’ai un code similaire qui correspond à “stations connectées” et une clé WEP 128 bits qui a au moins le double de caractère, c’est laquelle la bonne ?
il y a une mise en forme particulière, on met les deux points aussi ?

Aussi je me demande si je peux me connecter en wifi, je n’ai pas de carte réseau mais un connecteur intégré à la carte mère ?

voilà pour commencer lol … merci de vos réponses.


#2

[quote=“usinagaz”]Différence entre eth0 et Wlan0 ?
Est-ce que je peux ajouter à l’interface lo une interface (celle actuelle) eth0,
puis une interface wlan0 avec les lignes netmask, gateway et essid seulement ?
Est-ce que “mynetwork” est sensible à la majuscule/minuscule ?
Wireless_key :
c’est toujours un code à 12 caractères ?
ex : chez moi, j’ai un code similaire qui correspond à “stations connectées” et une clé WEP 128 bits qui a au moins le double de caractère, c’est laquelle la bonne ?
il y a une mise en forme particulière, on met les deux points aussi ?

Aussi je me demande si je peux me connecter en wifi, je n’ai pas de carte réseau mais un connecteur intégré à la carte mère ?[/quote]

alors, dans l’ordre :

la différence entre eth0 et wlan0 est le type de technologie utilisé, LAN pour ethx et WLAN pour wlanx

a mon avis, pour chacune de tes cartes, tu dois tout indiquer (ip, netmask, gateway, essid pour le wlan)

les essid sont sensibles à la casse

le nombre de caractère de ta clé WEP / WPA changent suivant la “puissance” de l’encryptage : clé 64 bits = 13 caractères, clé 128 bits = 26 caratcères, …

un extrait de wikipedia.fr :

[quote]Le WEP 64 bits utilise une clé de chiffrement de 40 bits à laquelle est concaténé un vecteur d’initialisation (initialization vector ou IV en anglais) de 24 bits. La clé et le vecteur d’initialisation forment ainsi une clé RC4 de 64 bits permettant de chiffrer les données échangées. Au moment où la norme WEP a été rédigée, les restrictions imposées par le gouvernement des États-Unis d’Amérique sur l’export des moyens cryptographiques limitait la taille des clés. Une fois ces restrictions retirées, les principaux fabricants étendirent le WEP à 128 bits en utilisant une clé de 104 bits.

Une clé WEP de 128 bits est quasiment toujours saisie par les utilisateurs comme une suite de 26 symboles hexadécimaux. Chaque symbole représente 4 bits de la clé WEP. 4 * 26 = 104 bits. En ajoutant le vecteur d’initialisation (IV) de 24 bits, on obtient ce que l’on appelle « une clé WEP de 128 bits ».

Un mécanisme utilisant des clés WEP de 256 bits est disponible. Comme pour les mécanismes précédemment mentionnés, 24 bits sont réservés pour le vecteur d’initialisation (IV), laissant ainsi 232 bits pour la clé de chiffrement. Cette clé est habituellement saisie comme une suite de 58 symboles hexadécimaux. (58 * 4 = 232 bits) + 24 = 256 bits.[/quote]


#3

Je vais encore râler contre une prersonne de bonne volonté:
le tuto d’Alexis ne doit pas être pris comme une bible, car il est truffé de “raccourcis un peu abrupts” de court circuitage de la logique debian, et de recettes obsolètes (par force: une seule personne ne peut pas entretenir à jour un tel document).
Ce document est bien à lire pour comprendre, mais il faut partir du principe qu’il vaut mieux utiliser d’autres tutos pour entamer une manip.

Je rappelle que la documentation debian est de trés haute qualité, et qu’elle est en français.

Voilà. Je remercie Alexis de Lattre pour son boulot, mais pas pour le nombre de personnes qu’il fait arriver ici en disant “Comprends pas, j’ai tout fait comme il dit et ça marche pas !” .


#4

re
merci à vous deux !!
Toi MattOTop pour ton petit coup de gueule toutefois trés respectueux (je suis donc pas le seul à pas comprendre :open_mouth: :stuck_out_tongue: ) qui met en évidence le fait bien entendu que la mise à jour du tuto d’alexis ne va pas de soi, entre autre, et on ne peut pas l’en blâmer …
Toi Twistophe pour tous ces éclaircissements … je lis :

ah … cartes ou interfaces ?
je suppose que ma carte (mère parce que tout est intégré …) peut me permettre de rajouter une interface wlan0, je vais donc tester avec la bonne clé WEP, car j’avais mis une clé 64 bits en héxadécimale (sans les “:”) correspondant à la case “station connectée” (dans ma page de config de la livebox) … :blush: ça pouvait pas marcher …
Au sujet des clés d’ailleurs, les codages sur 256 bits sont bien toujours réservés pour l’armée (car quasiment indéchiffrables, déjà qu’il faut se lever de bonne heure pour décoder une clé 128 bits avec une armada de 200 pc en reseaux calculating the combinations …) , l’armée, qui souhaite pas trop galérer à déchiffrer les codages non-militaires ?


#5

De toutes facons, ce n’est pas toi qui va décider si ta carte est nommée wlanX ou ethX, c’est le systême.
Sinon, cartes me semble juste un abus de language pour interfaces.
Tu peux savoir quelles interfaces sont actives et disponibles, même pour celles non configurées, avec la commande ip (du paquet iproute2 ?):
ip link

Tu peux aussi “forcer” ifconfig à te donner les carac d’une interface inactive, même si elle n’apparait pas dans un “ifconfig” sans arguments, en précisant par exemple:
ifconfig wlan0
si l’interface existe elle doit au moins avoir une mac address.


#6

re,
thanks MattOTop …
aah bon … ok je choisi pas entre wlan0 et eth0, mais alors, vu que j’ai qu’un connecteur réseau intégré à la carte mère, le systeme va nommer comment l’interface qui va naître d’une connection de l’adaptateur 802.11b/g wlan au pc ? je m’y perd là … eth1 ?
Mettons que j’ai le cable rj45 branché, et que je branche l’adaptateur aussi, qu’est ce que je doit mettre dans mon fichier interfaces pour faire des ifup et ifdown ?

ifdown eth0 # je ferme la connection eth0, configurée sur rj45 # actuellement ############## ########### je branche l'adaptateur wifi #### ifup ... # ben ifup quoi ?
Ou bien, les deux sont branché au boot … ça donne quoi ?

pour l’instant, ipconfig me donne normalement eth0 et lo.
ifdown eth0 déconfigure eth0.
ifup eth0 reconfigure eth0: link up, 100Mbps, full duplex, lpa 0x45E1
Aprés un : apt-get iproute apt-get update apt-get upgrade # là petit souci, j'aterri dans la config d'exim v4 # repoussée jusque là, bon
Mince un os … bon les deux première options par défaut, soit entrer pour “ne pas séparer les fichiers”, entrer pour “nom du courriel système” avec valeur=localhost.localdamain… et là, :

[quote]listes d’adresse IP où Exim sera en attente de connexions SMTP entrantes :
127.0.0.1___________[/quote]
aie vite, alexis lol :

[quote]Le serveur de mail installé par défaut sur une Debian est Exim. Je vous propose de le remplacer par Postfix, qui est réputé fiable et facile à configurer :

[/quote]bon je reste avec exim, comme les caractères deux-points des adresses IPv6 doivent être doublées (c’est quoi les adresses IPv6 ??), l’host name de smtp.wanadoo.fr me donne en IP : 193.252.22.57, bon je mets ça alors … (easy, ya pas de deux-points lol), j’entre, je reviens sur la page précédente, sans doute pour entrer une nouvelle IP … là je fais TAB sur OK et je valide, bon j’en sort.
Donc, ip link me donne quelque chose ouffff :

1 : lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
      link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2 : eth0 <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
      link/ether 00:0b:xx:xx:xx:xx mettons... brd ff:ff:ff:ff:ff:ff
3: sit0: <NOARP> mtu 1480 qdisc noop
     link/sit 0.0.0.0 brd 0.0.0.0

Voilà MattOTop … et ifconfig wlan0 :

:blush: ben je vais le brancher aussi peut être … je reviens demain …
merci


#7

c’est pas clair ton histoire…
pourquoi as-tu édité le 1er topic ?

bon, si je comprend bien, tu as une interface eth0 intégré sur ta CM et tu souhaites connecter la dessus un adaptateur WLAN afin de te connecter en wifi sur ta livebox.

[Debian - eth0] <-------> [eth1 - adaptateur - wlan0 ] <-------> [wlan1 - livebox - adsl] <----> [internet]

pour que ca marche, eth0 et eth1 doivent avoir la mm plage IP et le mm netmask, il en va de mm pour wlan0 et wlan1.

si l’adaptateur fais du routage : eth1 est la gateway pour debian, wlan1 est la gateway de ton adaptateur
si il ne sert que de convertisseur, je pense alors que ta gateway est wlan1 (à confirmer).
ton adaptateur doit etre administrable via une interface http, non ?


#8

Voui twistophe, pas clair tu as raison … un peu fatigué le garcon … une nuit blanche à l’actif déjà … (nan pas que sur debian lol).
J’édite le fichier interface, tu vas voir ce que j’essai de faire :

[code]# This file describes the network interfaces available on your system

and how to activate them. For more information, see interfaces(5).

The loopback network interface

auto lo
iface lo inet loopback

The primary network interface : inet dhcp à l’origine, j’ai mis static

ça c’est l’interface qui fonctionne, quand je suis branché avec le cable

rj45 … tout va bien, elle est configurée au boot.

auto eth0
iface eth0 inet static
address 192.168.1.11
netmask 255.255.255.0
gateway 192.168.1.1

ça c’est l’interface que je veux réserver à l’adaptateur, je suppose que

je ne peux pas l’appeler aussi eth0, donc je mets eth1, à tort ???

je veux donc, juste par test, en gardant la rj45 branchée également,

configurer à ma guise eth0 ci-dessus par un ifup eth0 quand elle est down,

et ifdown eth0 quand elle est configurée, une façon de permuter entre les

deux interfaces, eth0 et … c’est là qu’il faut me dire … et eth1 ???

car ensuite, je ferai un ifup eth1, l’adaptateur étant branché bien sur,

pour basculer sur la config avec adaptateur…

auto eth1
iface eth1 inet static
address 192.168.1.11
netmask 255.255.255.0
gateway 192.168.1.1
wireless_mode managed
wireless_essid Wanadoo_c859
wireless_channel 10
wireless_key e2::1f::72::xx::xx::xx::xx::xx::xx::xx::xx::xx::xx
[/code]
Là j’ai doublé les deux-points mais je vais les enlever carrément, j’ai essayé avec et sans, tel que c’est configuré de toute façon.
C’est quoi la commande pour que les interfaces soient actualisées aprés modif de ce fichier déjà ? (restart quelquechose ?)
Je pense que là c’est exactement ce que je veux faire, mais ça passe pas …
Je suis sur que vous allez résoudre le probleme twistophe ou MattOtop en deux temps trois mouvements, moi je peine à combiner toutes les solutions lol … voui, j’essaye de me servir de ma tête :blush:
Merci à vous.


#9

hum… je comprend toujours pas ce que tu veux faire, surement la fatigue de mon coté aussi qui agit ^^

physiquement, tu as quoi ?

1 pc avec 1 interfaces réseau intégré à la CM, 1 livebox et quoi d’autre ? c’est quoi ton adaptateur ?
dans ton fichier interfaces, tel qu’il est, tu configures 2 cartes physiquement différentes. est-ce le cas ?
de plus, en mettant la meme config sur chacune de tes cartes (ip, netmask, gateway, …) le système ne doit pas trop savoir laquelle utiliser.

pour relancer la lecture des paramètres réseaux :

/etc/init.d/networking restart


#10

en relisant ton deernier post, je crois comprendre que tu n’as qu’une carte physique.

tu peux faire de l’ip aliasing en définissant eth0:1, eth0:2, eth0:x
mais je ne vois pas l’interet ^^

le essid et la clé wep se configurent certainement sur ton adaptateur via une interface http.
ta carte réseau, ne devrait pas changer de config à mon avis, tout se joue au niveau de ton adaptateur je pense.


#11

oups on s’est croisé #### je te lis et j’essaie un truc, je disais ça :

Merci, c’est moi qui doit essayer de faire un truc infaisable je pense …
je dois pas encore savoir, de fait, comment ça fonctionne internet, une carte, etc … si si sans dec.
Bon, je n’ai qu’une carte réseau, et c’est même pas une carte, ils disent connecteur intégré, ça remplace une carte…
Donc, ce connecteur, c’est eht0, bon.
Jusqu’à présent, je me connecté avec une rj45 relié à ma livebox sagem.
J’ai un vieux pc, surement aussi avec un connecteur intégré, qui lui est sous windows NT, qui est en liaison à la livebox via l’adaptateur sagem IEE 802.11 b/g WLAN USB 2.0, lui n’a pas la possibilité rj45.
Ainsi, dans un premier temps, je veux tout simplement configurer mon interface réseau avec l’adaptateur, qui semble être reconnu lorsque je le branche sur la debian, mais comme le vieux pc à besoin d’accéder à internet via l’adaptateur, je dois pouvoir le débranché de la debian pour le rebrancher sur le vieux, et faire juste un ifdown “adaptateur” ifup eth0(rj45).
J’aurai donc suivant mes besoins,
un vieux pc à deux états:

  • pas connecté à internet , pas d’adaptateur
  • connecté, avec adaptateur.
    un debian à trois états :
    *connecté soit via eth0 (rj45) ou “adaptateur”, rj45 et adaptéteur étant branchés
    *connecté via eth0 (rj45) (quand le vieux requiert l’adaptateur)

voilà un peu ce que je veux faire, aprés, je veux pas t’effrayer :confused: mais je mettrai un serveur sur la debian, de sorte que le vieux accédera à internet via debian … ouffflà, c’est moi qui me fait peur là … bon lol… tu vois mieux ce que je tente ?


#12

désolé, mais autant je t’ai donné les réfèrences de commandes utiles pour regarder PHYSIQUEMENT l’etat du reseau, autant je sais que je n’y connais rien en wifi (sous linux ou autre, je me refuse à mettre des prises réseau sur les trottoirs).
Mais tout de même: le ‘ip link’ tu l’as fait avec ton wifi activé ?
Es tu sûr que ton materiel wifi à été détecté ?


#13

voila les derniers dmesg, avec branchement et débranchement de l’adaptateur, et rebranchement je pense :

eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth0: no IPv6 routers present
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth0: no IPv6 routers present
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth0: no IPv6 routers present
hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0010
ehci_hcd 0000:00:1d.7: GetStatus port 4 status 001002 POWER sig=se0 CSC
hub 1-0:1.0: port 4, status 0100, change 0001, 12 Mb/s
usb 1-4: USB disconnect, address 5
usb 1-4: usb_disable_device nuking all URBs
usb 1-4: unregistering interface 1-4:1.0
usb 1-4:1.0: uevent
usb 1-4: unregistering device
usb 1-4: uevent
hub 1-0:1.0: debounce: port 4: total 100ms stable 100ms status 0x100
hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0010
ehci_hcd 0000:00:1d.7: GetStatus port 4 status 001803 POWER sig=j CSC CONNECT
hub 1-0:1.0: port 4, status 0501, change 0001, 480 Mb/s
hub 1-0:1.0: debounce: port 4: total 100ms stable 100ms status 0x501
ehci_hcd 0000:00:1d.7: port 4 high speed
ehci_hcd 0000:00:1d.7: GetStatus port 4 status 001005 POWER sig=se0 PE CONNECT
usb 1-4: new high speed USB device using ehci_hcd and address 6
ehci_hcd 0000:00:1d.7: port 4 high speed
ehci_hcd 0000:00:1d.7: GetStatus port 4 status 001005 POWER sig=se0 PE CONNECT
usb 1-4: default language 0x0409
usb 1-4: new device strings: Mfr=16, Product=32, SerialNumber=0
usb 1-4: Product: 802.11b/g USB WLAN
usb 1-4: Manufacturer: ZyDAS
usb 1-4: uevent
usb 1-4: device is bus-powered
usb 1-4: configuration #1 chosen from 1 choice
usb 1-4: adding 1-4:1.0 (config #1, interface 0)
usb 1-4:1.0: uevent
drivers/usb/core/inode.c: creating file '006'
hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0010
ehci_hcd 0000:00:1d.7: GetStatus port 4 status 001002 POWER sig=se0 CSC
hub 1-0:1.0: port 4, status 0100, change 0001, 12 Mb/s
usb 1-4: USB disconnect, address 6
usb 1-4: usb_disable_device nuking all URBs
usb 1-4: unregistering interface 1-4:1.0
usb 1-4:1.0: uevent
usb 1-4: unregistering device
usb 1-4: uevent
hub 1-0:1.0: debounce: port 4: total 100ms stable 100ms status 0x100
hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0010
ehci_hcd 0000:00:1d.7: GetStatus port 4 status 001803 POWER sig=j CSC CONNECT
hub 1-0:1.0: port 4, status 0501, change 0001, 480 Mb/s

c’est là dedans à mon avis, mais où …


#14

non. c’est interressant, et on voit qu’il active quelquechose, mais il manque encore un peu d’info.
Je te disais de taper ‘ip link’, une fois que tu as insèré ton dispositif.
Et pendant que tu y es ‘lsusb’, et la partie de ‘lsusb -v’ qui concerne ton wifi (il faut la reconnaitre, c’est pour eviter de tout recopier).


#15

Bonjour à tous,
alors … [code]

ip link ###:

AVANT BRANCHEMENT:
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:0b:6a:7a:c4:98 brd ff:ff:ff:ff:ff:ff
3: sit0: mtu 1480 qdisc noop
link/sit 0.0.0.0 brd 0.0.0.0

APRES BRANCHEMENT:
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:0b:6a:7a:c4:98 brd ff:ff:ff:ff:ff:ff
3: sit0: mtu 1480 qdisc noop
link/sit 0.0.0.0 brd 0.0.0.0
##########################################################

lsusb ###:

AVANT BRANCHEMENT:
Bus 005 Device 002: ID 046d:c505 Logitech, Inc. Cordless Mouse+Keyboard Receiver
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 0ea0:2168 Ours Technology, Inc. Transcend JetFlash 2.0 / Astone USB Drive
Bus 001 Device 001: ID 0000:0000

APRES BRANCHEMENT:
Bus 005 Device 002: ID 046d:c505 Logitech, Inc. Cordless Mouse+Keyboard Receiver
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 008: ID 079b:004a Sagem
Bus 001 Device 003: ID 0ea0:2168 Ours Technology, Inc. Transcend JetFlash 2.0 / Astone USB Drive
Bus 001 Device 001: ID 0000:0000

lsusb -v ###, juste la fin qui me semble être l’adaptateur:

AVANT BRANCHEMENT hub pour status seulement, pour faire court :
Hub Port Status:
Port 1: 0000.0100 power
Port 2: 0000.0100 power
Port 3: 0000.0100 power
Port 4: 0000.0100 power
Port 5: 0000.0100 power
Port 6: 0000.0100 power
Port 7: 0000.0503 highspeed power enable connect
Port 8: 0000.0000

APRES BRANCHEMENT:
Bus 001 Device 008: ID 079b:004a Sagem
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 255 Vendor Specific Class
bDeviceSubClass 255 Vendor Specific Subclass
bDeviceProtocol 255 Vendor Specific Protocol
bMaxPacketSize0 64
idVendor 0x079b Sagem
idProduct 0x004a
bcdDevice 43.30
iManufacturer 16 ZyDAS
iProduct 32 802.11b/g USB WLAN
iSerial 0
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 46
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
MaxPower 500mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 4
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 0
bInterfaceProtocol 0
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x01 EP 1 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x82 EP 2 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x83 EP 3 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0040 1x 64 bytes
bInterval 1
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x04 EP 4 OUT
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0040 1x 64 bytes
bInterval 1
Device Qualifier (for other device speed):
bLength 10
bDescriptorType 6
bcdUSB 2.00
bDeviceClass 255 Vendor Specific Class
bDeviceSubClass 255 Vendor Specific Subclass
bDeviceProtocol 255 Vendor Specific Protocol
bMaxPacketSize0 64
bNumConfigurations 1

Hub Port Status:
Port 1: 0000.0100 power
Port 2: 0000.0100 power
Port 3: 0000.0100 power
Port 4: 0000.0503 highspeed power enable connect
Port 5: 0000.0100 power
Port 6: 0000.0100 power
Port 7: 0000.0503 highspeed power enable connect
Port 8: 0000.0000

###########################################################
[/code]
Qu’en penses tu MattOTop ?
ça serait sit0 ?


#16

Bon, désolé, je n’y trouve pas les infos que je cherchais, je t’ai faire ça pour rien.
Par contre, je suis allé essayer de deviner quel stick c’etait, et je crois que ca se trouve là:
zd1211.ath.cx/

le module correspondant n’est pas intègré au noyau, donc il faut le compiler avec le module-assistant, si tu connais: aptitude install module-assistant m-a update m-a prepare m-a a-i zd1211-source
Ca devrait te compiler et t’installer le module de ta carte
MAIS il existait un bug, avec le 2.6.12 et hotplug, donc si tu ne retrouves pas zd1211 dans lsmod en ce qui te concerne, il y a l’explication ici avec un script à installer:
pronux.org/wakka.php?wiki=AsusZ81
Bon, pour la suite, j’espere que quelqu’un va prendre la relève.


#17

Non, sit0 fait référence à l’interface IPv6 de ta carte réseau.


#18

bonsoir,
ok Jabba thanks, une piste de moins … :slightly_smiling:
Merci MattOTop … redoutable … mais ce qui m’inquiète actuellement, c’est que je ne sais toujours pas comment je dois éditer mon …/interfaces pour que la connection se configure au boot quelquesoit le mode choisi, rj45 ou adaptateur wifi … Il se peut que je n’ai qu’à spécifier une eth0 avec add essid etc … pour qu’il établisse la connection avec ce qu’il trouve d’opérationel ? je verrais bien …
Redoutable oui :

[quote]Par contre, je suis allé essayer de deviner quel stick c’etait, et je crois que ça se trouve là:
zd1211.ath.cx/
[/quote] En effet, et miracle, dans la catégorie hardware supported, on retrouve du déjà vu Bus 001 Device 008: ID 079b:004a Sagem ==[quote]Sagem XG760A zd1211 079b:004a sagem-online.com [/quote] … tout n’est pas perdu :stuck_out_tongue:
Cependant :

[quote]le module correspondant n’est pas intègré au noyau, donc il faut le compiler avec le module-assistant, si tu connais:Code:
aptitude install module-assistant
m-a update
m-a prepare
m-a a-i zd1211-source

Ca devrait te compiler et t’installer le module de ta carte
[/quote] C’est fort probable, je lis par ailleurs à propos du module-assistant : [quote]Debian a publié une mise à jour de sécurité pour Module-assistant, elle corrige une vulnérabilité qui pourrait être exploitée par un utilisateur malveillant afin de conduire des attaques de type “symlink” et créer/écraser des fichiers arbitraires. Le problème est que certains fichiers temporaires sont créés par “modass/include/generic.mk” de manière insécurisée, ce qui pourrait être exploité par des attaquants locaux afin d’écraser des fichiers arbitraires présents au sein d’un système vulnérable.
Versions Vulnérables
Debian GNU/Linux stable (sarge)
Debian GNU/Linux unstable (sid)
Solution
Debian GNU/Linux stable (sarge) - Utiliser la version 0.9sarge1
Debian GNU/Linux unstable (sid) - Utiliser la version 0.9.10
Références
frsirt.com/bulletins/2408
lists.debian.org/debian-security … 00261.html
[/quote]Tout va bien, un apt-cache policy module-assistant me propose la version 0.9sarge1 0, comme on dit : ça roule !
Bon avant de lancer le fatidique m-a a-i zd1211-source , je le télécharge comme indiqué sur le site que tu m’a donné, en prenant la derniere version je suppose, c’est un zd1211-driver-r74.tgz, là je fais une pause et poste déjà ça, car comment transformer un .tgz en source, faut que je réfléchisse :confused:


#19

re -
j’ai fais un post à part pour ce probleme de driver zd1211 .
Merci :wink: