[R]Désintaller des applis de gnome sans devoir enlever gnome


#1

Hello
je suis sur l’environnement gnome fraichement installé et je trouve qu’il y a des aplis dont je n’ai vraiment pas besoin
seul probleme, des que je veux desintaller une appli il me dit q’uil doit enlever le paquet gnome aussi ??? :confused:

alors voila on sait pas desinstallé sans devoir desinstalle tout??
merci
a+
omlip


#2

si il te demande d’enlever cette dépendance c’est que tu veux désinstaller le serveur X et si tu veux désinstaller une appli comme X essai :

ne met pas un S à window sinon le système risque de faire une allergie !
si je dit pas de connerie


#3
si il te demande d'enlever cette dépendance c'est que tu veux désinstaller le serveur X et si tu veux désinstaller une appli comme X essai : 

bah heu non
suffit d’aller dans synaptic et de vouloir enlever mozilla-browser par exemple

si j’enleve X j’ai plus d’affichage ? non?


#4

ton problème est normal : gnome est un méta paquet, c’est à dire que si tu l’installes tout les logiciels de gnome vont être installés.
A l’inverse tu peux sans problème supprimer un logiciel gnome, ça va supprimer ce méta paquet qui n’est pas important.
chez moi il n’est pas installé, j’ai choisi les applis que je voulais.


#5

Okay je vais tester ca alors
merci du tuyaux

a+
omlip


#6

[quote=“ciol”]ton problème est normal : gnome est un méta paquet, c’est à dire que si tu l’installes tout les logiciels de gnome vont être installés.
A l’inverse tu peux sans problème supprimer un logiciel gnome, ça va supprimer ce méta paquet qui n’est pas important.
chez moi il n’est pas installé, j’ai choisi les applis que je voulais.[/quote]

je confirme

c’est un meta-package qui sera enlevé, ce qui est normal et sans consequence sur tes autres programmes.

cheers.


#7

bon heu oui j’ai eu de probleme sauf que je ne sais plus booter sur XP

je n’ai plus les lignes permettant de booter un windows

alors j’ai rajouter les lignes suivantes ds menu.lst

title WinXp
root(hd0,0)
makeactive
chainloader +1

il met une erreur 12
ce qui veut dire selon le manuel francais de grub ceci

12 : Invalid device requested
    Cette erreur est retournée si la chaîne de périphérique est valide mais que l'erreur ne correspond à aucune autre erreur de périphérique.

youpie je fais quoi avec ca moi?


#8

je ne vois pas le rapport avec le suppression d’un package mais bon …

pour booter sur ton OS non-linux, utilise ça au niveau de /boot/grub/menu.lst (à ajouter à la fin du fichier):

[quote]# This entry automatically added by the Debian installer for a non-linux OS

on /dev/hda1

title Non Linux OS
root (hd0,0)
savedefault
makeactive
chainloader +1
[/quote]

i[/i] doit correspondre à la partition où se situe ton autre OS.


#9

okay voila ca refonctionne j’avais oublie l’espace entre root et (hdx,x)

merci bien

EDIT: pour en revenir au probleme du meta-paquet gnome
si je veux desinstaller mozilla-browser il decide d’enlever ces paquets la

gnome-desktop-environment
gnoe-core

Ce sont aussi des méta paquet ???

merci pour votre aide


#10

up? :laughing: :smiley:


#11

oui, ce sont des meta paquets.
Si tu souhaites t’en assurer, fais un 'apt-cache show ’ (ou aptitude show), pour avoir des infos détaillées sur le paquet qui t’interressent (ou regardes les propriétés du paquet dans synaptic, ca marche aussi).


#12

je te déconseille de désinstaller mozilla-browser, je voulais le supprimer moi aussi mais il te supprime comme tu l’as dit gnome-core qui est assez essentiel (sinon ça ne ressemble plus à du gnome). De mémoire (là je suis pressé et sous windows) gnome-core regroupe nautilus par exemple.
en fait yelp (navigateur d’aide de gnome) dépend de mozilla-browser et gnome-core de yelp…

en résumé tu as :
les applis gnomes <= gnome-core <= gnome-desktop-environment <= gnome
pour ma part je n’ai ni gnome-desktop-… ni gnome.


#13

ciol: tu n’as pas compris l’usage des meta paquets.
Quand on installe un meta paquet, comme il dépend de tout un lot d’autres paquets, il les installe automatiquement.
Si tu supprimes une dépendance du meta paquet, il t’oblige à désinstaller le meta paquet auquel appartient la dépendance, mais toutes les autres dépendances restent.
On peut donc allègrement supprimmer un meta paquet sans danger.


#14

je suis d’accord, c’est que j’ai compris. Mais si gnome sort une super appli de la mort qui tue permettant de gérer tout le système par exemple, hé ben ceux qui auront le métapaquet pourront l’avoir à la première mise à jour. (les autres aussi, mais ils ne seront pas forcément au courant qu’il est sorti).
Par exemple dans une prochaine version de gnome peut être que nautilus sera rendu obsolète par autre chose, et le méta paquet s’occupera de tout ça automatiquement.


#15

Bon je vais tester si jamais ca foire
J’en vois un RAID de Bomb sur vos tetes lol :laughing: :laughing: :laughing:

allez je viendrai editer pour dire quoi!!

EDIT marche sans probleme, je rappelle mes avions :wink: 8) 8)

merci a+

omlip