[Réglé] Config d'IP d'un serveur DNS sur routeur (serveur


#1

Salut à tous,

J’ai un problème depuis que j’ai changé de modem (pour avoir une IP fixe)… j’ai connexion directe par WAN sur internet et quand je configure sur le DHCP le serveur DNS que j’ai (sur debian) je n’ai pas de connection internet.

Pour avoir internet je met un serveur DNS du coté fournisseur, et j’ai ma connexion internet mais plus accès à mon propre serveur DNS.

Pour la configuration il est possible de mettre un serveur primaire et un secondaire, mais mon problème reste que je mette l’IP de mon serveur DNS en premier ou en second)

Est ce que quelqu’un a une idée d’où vient mon problème?

Merci


#2

Ca serait interressant que tu indiques ici /etc/network/interfaces, /etc/resolv.conf et /etc/named.conf.


#3

/etc/network/interfaces :

/etc/resolv.conf

/etc/named.conf :


#4

voici le contenu de /var/named/


#5

Bon, déjà, ton root.hints est foireux:
dig @e.root-servers.net >/var/named/root.hints

Ensuite, ta zone rabobsy, la répetition de MX 10 mail MX 20 mail.friend.rabobsky. me parait bizarre, mais bon.

Finalement, je ne vois aucun redirecteur dans ton named.conf:options { forwarders { 145.253.2.11; };

Par ailleurs,etant donné ton /etc/network/interfaces, si tu déclares partout que ton dns est sur le 192.168.1.11, et si tu laisses ton serveur en “face eth0 inet dhcp” il y a peu de chance que tes clients trouvent ce serveur, à moins que ton serveur dhcp attribue automatiquement l’adresse 11 à ton serveur dns…
Ou bien je n’ai vraiment rien compris à ton pb…


#6

[quote=“MattOTop”]Bon, déjà, ton root.hints est foireux:
dig @e.root-servers.net >/var/named/root.hints

Ensuite, ta zone rabobsy, la répetition de MX 10 mail MX 20 mail.friend.rabobsky. me parait bizarre, mais bon.
[/quote]
Moi j avais compris qu il devait y avoir la répétition… tu peux me dire qu est que je dois enlever?

j ai ajouté mais ca ne marche pas…

[quote=“MattOTop”]
Par ailleurs,etant donné ton /etc/network/interfaces, si tu déclares partout que ton dns est sur le 192.168.1.11, et si tu laisses ton serveur en “face eth0 inet dhcp” il y a peu de chance que tes clients trouvent ce serveur, à moins que ton serveur dhcp attribue automatiquement l’adresse 11 à ton serveur dns…
Ou bien je n’ai vraiment rien compris à ton pb…[/quote]
Le serveur DHCP donne l’IP selon le mac adresse… donc tu as bien compris…

Mais je pense que je pourrais trouver plus facilement la correction si je comprenais l’erreur… merci pour le coup de main!


#7

pardon:options { forwarders { 145.253.2.11; }; };
tu as testé nslookup depuis un client ?


#8

merci beaucoup! ca marche!!!

(désolé pour le décalage de la réponse c’est à cause des collègues qui ne voulaient pas d’interruption de la connection internet) :imp: