Réseau : Impossible de se connecter en Lan (Sans interface graphique)

Tags: #<Tag:0x00007ff8f2384b20> #<Tag:0x00007ff8f2384828> #<Tag:0x00007ff8f2384698>

Bonjour, bonsoir,

En voulant installer debian (dans le but d’héberger un site dessus) sans interface graphique Ce texte sera floutéje me suis vite heurter à un problème. L’ordinateur ne semble pas du tout connecté à internet (alors qu’il est bien brancher en ethernet).
J’ai suivis beaucoup de tuto sur internet pour remédier a ce problème mais rien n’as marché.
J’ai donc réinstaller debian de 0 mais toujours rien.

Quand je débranche le cable lan j’ai bien une réaction de la part du system.

Le résultat de quelques commandes :

Debian GNU/Linux 11 debian-server tty1

debian-server login: root
Password:

Login incorrect
debian-server login: root
Password:
Linux debian-server 5.10.0-13-amd64 #1 SMP Debian 5.10.106-1 (2022-03-17) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extend
permitted by applicable law.
Last login: Thu Apr 28 17:03:53 CEST 2022 on tty1
root@debian-server:~# ping google.fr
ping: google.fr: Échec temporaire dans la résolution du nom
root@debian-server:~# ping 192.168.0.1
ping: connect: Le réseau n'est pas accessible
root@debian-server:~# _

Daignerais-tu décrire cette réaction ?

La connexion internet via ethernet était-elle opérationnelle pendant l’installation ?

Et la sortie des commandes suivantes :

ip addr
ip route
cat /etc/network/interfaces
cat /etc/network/interfaces.d/*
cat /etc/resolv.conf

Si possible en texte et non en image, via redirection dans un fichier récupéré sur une clé USB par exemple.

root@debian-server:~# ip addr
1: 10: (LOOPBACK, UP ,LONER_UP› mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback00:00:00:00:00:00brd00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6::1/128 scope host
valid_ift forever preferred_lft forever
2: enp2SO: «BROADCAST, MULTICAST, UP, LOWER_UP› mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
1ink/ether 00:24:1d:96:a5:5e brdff:ff:ff:ff:ff:ff
inet6 fe80: :224:1dff:fe96:a55e/64 scope 1ink
valid_Ift forever preferred_lft forever
root@debian-server:# ip route
root@debian-server:"#cat/etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces (5)
source/etc/network/interfaces.d/*
# The loopback network interface
auto 10
iface lo inet loopback
# The primary network interface
allow-hotplugenp2s0
iface enp2s0 inet dhcp
1 root@debian-server:~#cat/etc/network/interfaces.d/*
cat:
*/etc/network/interfaces.d/*': Aucun fichier ou dossier de ce type
root@debian-server:~#cat/etc/resolv.conf
search mikadilo.fr
I nameserver 192.168.0.1
1 root@debian-server:~#

Et pour ce qui est de la reaction lorsque je débranche le cable je ne l’ai plus qui s’affiche (j’avais un message avant)

Quand je demande en texte et non en image, je veux dire par copier-coller ou enregistrement dans un fichier, pas par recopie à la main ni par reconnaissance de caractères, trop d’erreurs et il vaut mieux une photo.

Si je peux néanmoins me fier à cette transcription malgré les erreurs, il semblerait que

  • l’interface ethernet est reconnue comme enp2s0,
  • correctement déclarée en DCHP IPv4 dans /etc/network/interfaces,
  • activée avec la liaison ethernet établie,
  • mais n’a pas reçue de configuration IPv4.

Cela peut présager d’un problème de communication avec le serveur DHCP (routeur, box internet ?) qui est censé lui fournir la configuration IPv4.

Voyons les logs DHCP :

grep -i dhc /var/log/syslog

et les logs du noyau concernant l’interface ethernet :

dmesg | grep enp2s0

On peut aussi regarder ce qui se passe en direct lors d’une tentative de configuration :

ifdown  enp2s0
ifup -v enp2s0

Tu n’as pas répondu à ma question concernat la connexion réseau lors de l’installation.

Pour ce qui est du statut de la connexion lors de l’instalation je ne sait pas désolé (J’ai fait l’instalation grâce à un support usb)
Et je ne sait pas comment faire pour enregistrer le fichier désolé.
Pourais tu m’indiquer comment faire s’il te plaît ?
En attendant pour les commandes je vais envoyer une photo (la prochaine fois je pourrais copier coller :sweat_smile:)

Résultat du grep -i dhc /var/log/syslog

Résultat du dmesg | grep enp2s0

Désolé pour les photos encore :sweat:

ah et aussi
Résultat des ifdown enp2s0 et ifup -v enp2s0

Les logs de syslog confirment que le client DHCP n’obtient aucune réponse d’un serveur DHCP.
Pas d’erreurs dans les logs du noyau mais on peut voir que la liaison ethernet tombe plusieurs fois et remonte après quelques secondes. Je vois aussi que le contrôleur ethernet est géré par le pilote r8169, il s’agit donc d’un composant Realtek dont certains ne sont pas forcément très bien gérés par ce pilote ou peuvent avoir besoin d’un firmware du paquet non libre firmware-realtek ou sont mieux gérés par le pilote non libre r8168.

dmesg | grep r8169

Voyons les statistiques ethernet pour voir s’il y a des erreurs ou des paquets perdus :

ip -s link show enp2s0

Tu dois bien avoir vu si l’installateur avait réussi à configurer la connexion, se connecter à un miroir et télécharger des mises à jour ?

Il ne me semble pas qu’il se soit connecté
Pour ce qui est des commandes :

root@debian-server:~# dmesg | grep r8169
[    1.263697] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
[    1.263697] r8169 0000:02:00.0 eth0: RTL8102e/RTL8103e, 00:24:1d:96:a5:5e, XID 34a, IRQ 17
[    1.286342] r8169 0000:02:00.0 enp2s0: renamed from eth0
[    9.539494] RTL8201CP Ethernet r8169-0-200:00: attached PHY driver [RTL8201CP Ethernet] (mii_bus:phy_addr=r8169-0-200:00, irq=IGNORE)
[    1.286342] r8169 0000:02:00.0 enp2s0: Lynk is Down
[   11.340287] r8169 0000:02:00.0 enp2s0: Lynk is Up - 100Mbps/Full - flow control rx/tx
[   11.685947] r8169 0000:02:00.0 enp2s0: Lynk is Down
[   11.248695] r8169 0000:02:00.0 enp2s0: Lynk is Up - 100Mbps/Full - flow control rx/tx
[  101.539469] r8169 0000:02:00.0 enp2s0: Lynk is Down
[  104.464341] r8169 0000:02:00.0 enp2s0: Lynk is Up - 100Mbps/Full - flow control rx/tx
[18098.678165] r8169 0000:02:00.0 enp2s0: Lynk is Down
[18102.289046] r8169 0000:02:00.0 enp2s0: Lynk is Up - 100Mbps/Full - flow control rx/tx
[18255.272707] r8169 0000:02:00.0 enp2s0: Lynk is Down
[18257.698514] r8169 0000:02:00.0 enp2s0: Lynk is Up - 100Mbps/Full - flow control rx/tx
[21484.737887] r8169 0000:02:00.0 enp2s0: Lynk is Down
[21506.388493] RTL8201CP Ethernet r8169-0-200:00: attached PHY driver [RTL8201CP Ethernet] (mii_bus:phy_addr=r8169-0-200:00, irq=IGNORE)
[21506.461191] r8169 0000:02:00.0 enp2s0: Lynk is Down
[21506.461191] r8169 0000:02:00.0 enp2s0: Lynk is Up - 100Mbps/Full - flow control rx/tx
root@debian-server:~# 
root@debian-server:~# ip -s link show enp2s0
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 00:24:1d:96:a5:5e brd ff:ff:ff:ff:ff:ff
    RX: bytes  packets  errors  dropped missed  mcast   
    78189      1038     0       0       0       94    
    TX: bytes  packets  errors  dropped carrier collsns 
    133756     422      0       0       0       0    
root@debian-server:~# 

salut,

quel est le contenu de ton /etc/network/interfaces ?

Pas de mention de firmware manquant pour ce contrôleur ethernet.
Il y a des paquets émis et reçus, et une seule erreur en émission donc a priori rien d’inquiétant.

Reste à déterminer pourquoi aucune réponse d’un serveur DHCP n’est reçue. Idéalement, il faudrait faire une capture de trafic sur une autre machine du réseau pour voir si les requêtes DHCP sont bien émises (et sur cette machine pour voir les paquets reçus, mais pour cela il faudrait installer un programme de capture de paquets comme tcpdump). Tu n’as toujours pas dit quel équipement était censé faire office de serveur DHCP.

Tu pourrais aussi configurer une adresse IP statique inutilisée dans le sous-réseau IP local pour voir si la machine peut communiquer avec d’autres machines du réseau. Par exemple si le réseau a des adresses en 192.168.0.* :

ip addr add 192.168.0.179/24 dev enp2s0

Ensuite tu pourras lancer des pings depuis et vers d’autres machines du réseau local.

La machine pour le dchp est un répéteur wifi sur lequel la machine est connecté en ethernet
j’ai attribué une ip fixe depuis l’interface du répéteur a la machine (192.168.0.100)
Interface du répéteur
https://image.noelshack.com/fichiers/2022/17/7/1651420658-image-2022-05-01-175738697.png

Quand j’essaye de ping :

Microsoft Windows [version 10.0.19044.1645]
(c) Microsoft Corporation. Tous droits réservés.

C:\Users\Mikadilo>ping 192.168.1.10
 
Envoi d'une requête 'Ping'  192.168.1.100 avec 32 octets de données :
Réponse de 192.168.0.102 : Impossible de joindre l'hôte de destination.
Réponse de 192.168.0.102 : Impossible de joindre l'hôte de destination.
Réponse de 192.168.0.102 : Impossible de joindre l'hôte de destination.
Réponse de 192.168.0.102 : Impossible de joindre l'hôte de destination.
 
Statistiques Ping pour 192.168.0.100:
    Paquets : envoyés = 4, reçus = 4, perdus = 0 (perte 0%),

C:\Users\Mikadilo>

Aucun parefeu activé?
As-tu essayé en étant connecté avec un cable.

Et quel est cette machine windows à partir de laquelle tu fais un ping?

Mon ordinateur personnel (connecter en Ethernet au même réseau)
Pour ce qui est des parefeu tu veux dire sur la machine sous Linux ?

j’ai fait la commande avec 192.168.0.100 (ip addr add 192.168.0.100/24 dev enp2s0) et le réseau local fonctionne.
J’arrive a ping mon ordinateur personnel sous windows et j’arrive même à m’y connecter grâce à ssh ! On avance :grinning:

image

Un répéteur n’est pas censé faire office de serveur DHCP, c’est un simple pont. Ce ne serait pas plutôt un routeur wifi classique ?
Quelle est la topologie complète du réseau local ?

Alors tu n’as qu’à définir une configuration statique au lien de DHCP dans le fichier /etc/network/interfaces, ce qui n’est pas incongru pour un serveur.

iface enp2s0 inet static
address 192.168.0.100/24
gateway 192.168.1.X (adresse de la passerelle)
1 J'aime

Pour ce qui est du répéteur il fait routeur / répéteur
Il est connecté à ma livebox orange (Tout ce qui est dans ma chambre est connecté sur le répéteur et le reste sur la box)
Pour ce qui est des adresses :
Le répéteur dans le réseau principal (de la livebox) a pour IP 192.168.1.12
et dans le réseau locale 192.168.0.1
La Livebox elle 192.168.1.1

Pour le gateway je doit mettre l’ip de la livebox du coup ?

J’ai modifié le fichier qui maintenant ressemble à ça
image
j’ai aussi tester de ping mon ordinateur sous windows, la livebox et google
ça veut dire que la machine n’a pas accès au réseau de la livebox du coup ?

Je doute qu’il fasse les deux en même temps. En répéteur, il y aurait le même réseau des deux côtés. En routeur, il y a deux réseaux distincts.

Non, celle du routeur dans le réseau du serveur.

Maintenant que tu peux te connecter au serveur par SSH tu peux copier-coller le texte du terminal au lieu de faire des copies d’écran.
L’option gateway contient une faute de frappe.

1 J'aime

Tout marche :tada:
Le ping google.com marche et le apt get aussi
Merci beaucoup :grin: