[Résolu]2 devices dans mon xorg.conf?


#1

Voici ce que j’ai dans mon fichier xorg.conf:

Section "Device"
Identifier "ATI 9200 SE"
Driver "ati"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Est-ce normal que je vois 2 “device”? J’ai essayé d’en désactiver 1, puis l’autre (en les mettant en commentaire), et dans chaque cas mon interface graphique ne se lance plus disant qu’elle ne trouve pas le device…

Pour info. j’ai installé les derniers drivers Ati (méthode ubuntu)


#2

tu as ptet deux cartes graphiques qui tournent en m^ tps :question:


#3

Boh non.

Par contre j’ai deux sorties video sur ma 9200se, est-ce lié? (une vga et une dvi)


#4

il faudrait le Xorg.conf en entier, je crois.
Sinon, tu as raison de te poser la question, car ca me semble bizarre à moi aussi.


#5

tu dois regarder dans la section “Screen” pour savoir quel “Device” est utilisé

chez moi, ça donne par exemple:

quote="/etc/X11/xorg.conf"
Section “Device”
Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NoLogo"
EndSection

Section "Screen"
Identifier “Default Screen”
Device "NVIDIA Corporation NV34 [GeForce FX 5200]"
Monitor “CPD-E430”
(…)[/quote]

j’en deduis que tu peux avoir plusieurs devices déclarés dans ton xorg.conf, au final un seul sera utilisé.

cheers.


#6

[quote=“ghostintheshell”]tu dois regarder dans la section “Screen” pour savoir quel device est utilisé

chez moi, ça donne par exemple:

quote="/etc/X11/xorg.conf"
Section “Device”
Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NoLogo"
EndSection

Section "Screen"
Identifier “Default Screen”
Device "NVIDIA Corporation NV34 [GeForce FX 5200]"
Monitor “CPD-E430”
(…)[/quote]

j’en deduis que tu peux avoir 257 devices déclarés dans ton xorg.conf, un seul sera utilisé.

cheers.[/quote]Pkoi 257 ? Qu’est ce qui te fait dire qu’un seul sera utilisé ?


#7

j’attendais cette reaction … c’pour ça que j’ai vite modifié avant que les foudres s’abbatent sur moi.

257 parce que 256+1 et ça, ça fait chi*r les programmeurs :smiley:

et puis … pourquoi pas 8)


#8

j’attendais cette reaction … c’pour ça que j’ai vite modifié avant que les foudres s’abbatent sur moi.

257 parce que 256+1 et ça, ça fait chi*r les programmeurs :smiley:

et puis … pourquoi pas 8)[/quote]je répète mes questions, car je ne comprends pas ta réponse. :laughing:
Pkoi 257 ?
Qu’est ce qui te fait dire qu’un seul sera utilisé ?


#9

257 comme j’aurais pu dire 36.000 …

si la section “screen” ne fait reference qu’à un seul “device”, je ne vois pas pourquoi plus d’un device (ndlr: carte graphique) serait utilisé …

plus techniquement parlant:
XOrg -> ServerLayout -> Screen -> Device

v’là mon cher.


#10

VU.
On est d’accord: theoriquement, on peut avoir autant de device qu’on veut, et tous peuvent être utilisés en même temps.
Mais tu as raison de rappeler que la config de X se présente en arbre, et c’est pour ça que le fichier complet est utile, pour voir quelles branches sont accrochées au tronc, et ou… :wink:


#11

J’ai donc viré la 1ère section device et à priori ca tourne bien. Voici mon fichier xorg maintenant (c’est normal que j’ai deux sections screen et 2 sections monitor? :open_mouth: )

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 “aticonfig Screen 0” 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section “Files”
# local font server
# if the local font server has problems, we can fall back on these
FontPath "unix/:7100"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "evdev"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option “XkbModel” "pc105"
Option “XkbLayout” "fr"
Option “XkbVariant” "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "Monitor"
Identifier "4311 FA"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "aticonfig Monitor 0"
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Section "Screen"
Identifier "Default Screen"
Device "ATI Graphics Adapter 0"
Monitor "4311 FA"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig Screen 0"
Device "ATI Graphics Adapter 0"
Monitor "aticonfig Monitor 0"
DefaultDepth 24
Monitor "aticonfig Monitor 0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection


#12

La config correspondant à celle que tu as actuellement peut se simplifier comme ça:[code]Section "ServerLayout"
Identifier "Layout manuel avec config fine"
Screen 0 “Screen manuel” 0 0
InputDevice "Clavier"
InputDevice "Souris"
EndSection

Section “Files”
# local font server
# if the local font server has problems, we can fall back on these
FontPath "unix/:7100"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "evdev"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Clavier"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option “XkbModel” "pc105"
Option “XkbLayout” "fr"
Option “XkbVariant” "latin9"
EndSection

Section "InputDevice"
Identifier "Souris"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "Monitor"
Identifier "Moniteur en autodetection"
EndSection

Section "Device"
Identifier "Carte ATI"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen manuel"
Device "Carte ATI"
Monitor "Moniteur en autodetection"
DefaultDepth 24
Monitor "Moniteur en autodetection"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection[/code]

Mais je te conseillerais plutot quelquechose du genre:[code]Section "ServerLayout"
Identifier "Layout manuel avec config fine"
Screen 0 “Screen manuel avec config fine” 0 0
InputDevice "Clavier"
InputDevice "Souris"
EndSection

Section “Files”
# local font server
# if the local font server has problems, we can fall back on these
FontPath "unix/:7100"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "evdev"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Clavier"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option “XkbModel” "pc105"
Option “XkbLayout” "fr"
Option “XkbVariant” "latin9"
EndSection

Section "InputDevice"
Identifier "Souris"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "Monitor"
Identifier "4311 FA"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Carte ATI"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen manuel avec config fine"
Device "Carte ATI"
Monitor "4311 FA"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection[/code]

tu peux aussi mettre les deux “layouts” ensemble (en ne répètant pas les parties communes), il prendra le premier qu’il trouvera, sauf si tu lances X avec ‘startx --layout “Layout manuel avec config fine”’, auquel cas par exemple, il démarrera avec le layout “Screen manuel avec config fine”.
Tu remarqueras que les deux layouts utilisent le flgrx.
Enfin tout ça pour la comprehension, parcequ’il faudrait gèrer une éventuelle deuxiême tête (sur le DVI), et ne disposant que de nVidia, je ne sais pas comment on fait du multihead avec une ATI.


#13

Merci Mattotop.

Avant de lire ta réponse j’ai fait moi même le ménage dans mon xorg et … j’ai perdu l’acceleration graphique, sans comprendre pourquoi. J’ai beau relire je ne vois pas ce qui cloche… Voici la tête de mon xorg actuellement:

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 “aticonfig Screen 0” 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section “Files”
# local font server
# if the local font server has problems, we can fall back on these
FontPath "unix/:7100"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "evdev"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load “type1” Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option “XkbModel” "pc105"
Option “XkbLayout” "fr"
Option “XkbVariant” "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "Monitor"
Identifier "aticonfig Monitor 0"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig Screen 0"
Device "ATI Graphics Adapter 0"
Monitor "aticonfig Monitor 0"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 8
SubSection "Display"
Depth 8
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes “1280x1024” “1024x768” “800x600” “720x400” "640x480"
EndSubSection
EndSection


#14

Ca roule avec ton xorg mattotop, merci bcp :wink: