[resolu] Clavier usb non reconnu sous debian testing


#1

J’ai un probleme TRES embetant: lorsque je lance ma debian, j’arrive à l’écran de connection gnome et là mon clavier usb n’est pas reconnu, je ne peut donc rien faire… :frowning:

J’ai remarqué une erreur du fihier /lib/modules/kernel 2.6.8-2-386/drivers/char-gentrc.ko.

J’ai été voir ce fichier grâce à un exporateur de partition linux sous windows mais celui-ci n’est pas en caractère reconnue.

Donc que faut il faire pour que cela marche ? (c’est paut être simplement un module à ajouter au démarrage)


#2

Envoie ici ton /etc/X11/xorg.conf et lis les post-it.
Bienvenue à toi.


#3

Merci.
Voilà le fichier:

# xorg.conf (Xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum
#   dpkg-reconfigure xserver-xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"evdev"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"latin9"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"false"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
	Identifier	"NVIDIA Corporation NV43 [GeForce 6600]"
	Driver		"vesa"
	BusID		"PCI:6:0:0"
	Option		"UseFBDev"		"true"
EndSection

Section "Monitor"
	Identifier	"Écran générique"
	Option		"DPMS"
	HorizSync	28-64
	VertRefresh	43-60
	Modeline	"1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV43 [GeForce 6600]"
	Monitor		"Écran générique"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection

#4

Ta gestion USB fonctionne correctement?


#5

Jamais eu de problemes avant.


#6

tu as essayé de le rebrancher “à chaud” ?

Sinon.

emeraude:~$ find /lib/modules/2.6.15emeraude/ -name "*usb*.ko" -print (...) /lib/modules/2.6.15emeraude/kernel/drivers/usb/input/mtouchusb.ko /lib/modules/2.6.15emeraude/kernel/drivers/usb/input/touchkitusb.ko /lib/modules/2.6.15emeraude/kernel/drivers/usb/input/usbhid.ko /lib/modules/2.6.15emeraude/kernel/drivers/usb/input/usbkbd.ko /lib/modules/2.6.15emeraude/kernel/drivers/usb/input/usbmouse.ko (...)modprobe usbkbd ?

mais ça a marché un jour ?
Tu n’as pas de piles qui seraient vides, dedans ?


#7

Le clavier marchait quand j’étais sous stable. Pas de probleme de piles parce que je suis sous windows et ca marche.

Et sinon j’ai déjà essayé de le débrancher/rebrancher et ca n’a rien changé.


#8

Ça n’a rien à voir avec ton clavier mais tu n’as pas de problèmes avec ta carte NVIDIA ?
Bizarre qu’elle fonctionne bien avec “dri” et “vesa” comme driver ? M’enfin, si ça marche, ne change rien.
Pour ton clavier, essaie de commenter 'latin 9’
essaie aussi de mettre ‘true’ ds “émulate 3 boutons”, à moins que tu n’aies une souris différente


#9

space: tu n’as pas dit si tu avais vérifié que le module usbkbd etait chargé ?
ricardo: tu es sûr qu’une modif sur la config de la souris aurait un impact sur le clavier ? Parceque ça me parait bizarre, tt de même :confused:


#10

J’ai bien écrit “essaie” car je n’en ai pas non plus la certitude mais souris et clavier ont bien un rapport quand m^ (lointain ptet) car on peut se servir des deux pour bouger le curseur avec le pavé numérique :wink:


#11

OK


#12

Bon pour résoudre mon probleme j’ai réinstaller debian et là pas de problemes.
Merci de votre aide. :wink:


#13

[quote=“Space”]Bon pour résoudre mon probleme j’ai réinstaller debian et là pas de problemes.
Merci de votre aide. :wink:[/quote]C’est pô bien.
Si c’est un problême que tu as juste aprés l’install, il y a toutes chances qu’il se représente, tu aura perdu le temps d’une reinstallation pour rien, et tu n’aura pas plus d’idée sur comment se résoud ce problême.
Et même sur une machine ancienne, une debian, ça ne se réinstalle pas, ça se répare.