[Résolu] - Cohabité deux réseau --> Windows pfff


#1

Bonjour,

Je cherche à joindre deux réseau pas en un seul, mais pour ce voir sous samba et voisinage réseau sous windaub.

J’utilise une serveur dhcp avec la config suivante

# /etc/dhcpd.conf
# Dernière modification le 14/03/2006

option time-servers ntp.grolier.fr;
option domain-name "xyz;

default-lease-time 600;
max-lease-time 7200;

	# Parents
	subnet 192.168.20.0 netmask 255.255.255.0 {
		option domain-name-servers 192.168.20.1;
		option broadcast-address 192.168.20.255;
		option routers 192.168.20.1;
		range 192.168.20.30 192.168.20.40;
		# Thibaut
		host thibaut {
			hardware ethernet 00:11:D8:4C:03:4D;
			fixed-address 192.168.20.4;
			}
		# Jean-Louis
		host jl2 {
			hardware ethernet 00:0F:B0:95:82:08;
			fixed-address 192.168.20.6;
			}
		}
	# Régis
	subnet 192.168.77.0 netmask 255.255.255.0 {
		option domain-name-servers 192.168.77.1;
		option broadcast-address 192.168.77.255;
		option routers 192.168.77.1;
		range 192.168.77.30 192.168.77.39;
		# serveur02.xyz.tld
		host serveur02 {
			hardware ethernet 00:0B:6A:E3:AE:DB;
			fixed-address 192.168.77.2;
			}
		# Régis Desktop
		host regis {
			hardware ethernet 00:13:D4:93:74:D6;
			fixed-address 192.168.77.3;
			}
		# Routeur wifi
		host routeur wifi {
			hardware ethernet 00:12:17:4A:C2:86;
			fixed-address 192.168.77.40;
			}
		}

Mais je ne vois pas comment faire pour que les deux réseau puissent communiqué. Je sais que celà est possible. Je ne les bridge pas car le réseau du coté de chez mes parents est plus sécurisé que le mien.


#2

pour “lier” ces 2 réseaux, tu as 2 possibilités :

  1. tu achetes un routeur physique
  2. tu configures un routeur logiciel en ajoutant une carte réseau sur une des machines.

#3

Fais des frais non!

J’ai une interface réseau de libre, je configure un réseau partagé en dhcp, je branche mon cable sous mon switch et sa roule?

Le truc est que moi je suis branché directement à une carte réseau, cable de 30 mètres branché à un switch. Du coté de mes parents directement sur le switch.

Là je ne vois pas trop, j’aimerais un peu plus d’information stp. Pendants ce temps je cherche encore sur google!


#4

Je ne comprends pas trop ton problème mais en gros:

Sur ton linux, il faut préciser que tu accèdes au rtéseau parent directement donc tu fais un

route add -net 192.168.20.0 eth0

Là tu ping une machine parents: deux cas peuvent se présenter, elle répond où elle ne répond pas.

Si elle répond: GOTO 2

Si elle ne répond pas (probable), la solution que je vois est de faire un alias:
tu fais

route del -net 192.168.20.0 eth0

ifconfig eth0:1 192.168.20.51 up

ping la machine de tes parents, ça marche.

  1. Après il faut renseigner les machines SMB de leur existence. Le plus simple consiste à configurer le serveur Samba comme serveur WINS ou bien à mettre à jour les fichiers lmhosts des différentes machines.

#5

D’accord merci de ta réponse. Je vais testé sa. Mais je ne peut pas pingué la machine de mon frère, et pourtent elle marche il a accès à internet. Il est sous windaows avec bit defender pro, il faut que je regarde si il ne bloque pas les pings.


#6

Je ne suis pas sur de bien suivre ton réseau…

Ton serveur DHCP est branché sur quelle(s) interface(s) ?
Quelle est la config IP des tes cartes réseaux (/etc/network/interfaces)?
Que t’indique le fichier /etc/default/dhcp3-server ?


#7

Alors…

Le serveur dhcp écoute sur l’interface eth1 (192.168.20.0/24) et eth2 (192.168.77.0/24). Mais je n’utilise pas le dhcp3-server mais juste le paquet dhcp.

# Defaults for dhcp initscript
# sourced by /etc/init.d/dhcp
# installed at /etc/default/dhcp by the maintainer scripts

#
# This is a POSIX shell fragment
#

# On what interfaces should the DHCP server (dhcpd) serve DHCP requests?
#       Separate multiple interfaces with spaces, e.g. "eth0 eth1".
INTERFACES="eth1 eth2"

Le serveur ou ce trouve le serveur dhcp possède les ip 192.168.20.1 et 192.168.77.1


#8

C’est donc ton serveur DHCP qui sert de passerelle entre le deux réseaux ?

Peux-tu faire un “route” sur ton serveur DHCP ?


#9

un service DHCP ne te permettra pas de relié les 2 réseaux…
le seul moyen dont tu disposes pour relier ces 2 réseaux, je me répète, est d’utiliser un routeur (logiciel ou hard).

tu peux configurer un routeur sur ton serveur DHCP :

route add -net 192.168.20.0 netmask 255.255.255.0 eth1

route add -net 192.168.77.0 netmask 255.255.255.0 eth2

ensuite, tu dois configurer tes clients pour qu’ils sachent que du coté 192.168.20.0/24, ils peuvent communiquer vers 192.168.77.0/24 via 192.168.20.1 et inversement pour les clients du coté 192.168.77.0/24, ils peuvent communiquer avec 192.168.20.0/24 via 192.168.77.1.

qu’est ce qu’il y a sur eth0 ??


#10

Il faut surtout activer le routage sur le DHCP si il sert de passerelle entre les deux réseaux…

Les routes :

[quote]#route add -net 192.168.20.0 netmask 255.255.255.0 eth1

route add -net 192.168.77.0 netmask 255.255.255.0 eth2 [/quote]

sont déjà créées puisque les interfaces sont en direct sur le serveur DHCP.

Le truc c’est de faire passer les paquets entre les deux. Et là on rentre dans le forwarding de netfilter. Sans oublier d’indiquer la passerelle aux clients de chaque réseau en l’adresse IP du serveur DHCP correspondant.


#11

en effet, j’ai omis d’activer le routage dans ce que j’ai écrit…

pour cela, il doit éditer son fichier /etc/network/options

[quote]$ cat options
ip_forward=no
spoofprotect=yes
syncookies=no[/quote]

il faut remplacer le ip_forward=no par ip_forward=yes

dites moi si je me trompe :question:


#12

un conseil : avant de mettre en place ton dhcp !

fait le fonctionné avec des adresses statics, j’imagine que tu n’a pas 150 postes chez toi :wink:

et fait comme te dir Twistophe :

perso j’ai configurer mes cartes réseaux et ajouter quelques règles iptables et le tour est joué

[quote]# Nous vidons les chaînes :
iptables -F

Nous supprimons d’éventuelles chaînes personnelles :

iptables -X

Nous les faisons pointer par défaut sur DROP

iptables -P INPUT DROP
iptables -P OUTPUT DROP
iptables -P FORWARD DROP

Nous faisons de même avec toutes les autres tables,

à savoir “nat” et “mangle”, mais en les faisant pointer

par défaut sur ACCEPT. Ca ne pose pas de problèmes

puisque tout est bloqué au niveau “filter”

iptables -t nat -F
iptables -t nat -X
iptables -t nat -P PREROUTING ACCEPT
iptables -t nat -P POSTROUTING ACCEPT
iptables -t nat -P OUTPUT ACCEPT

iptables -t mangle -F
iptables -t mangle -X
iptables -t mangle -P PREROUTING ACCEPT
iptables -t mangle -P INPUT ACCEPT
iptables -t mangle -P OUTPUT ACCEPT
iptables -t mangle -P FORWARD ACCEPT
iptables -t mangle -P POSTROUTING ACCEPT

#localhost et eth0 sont autorisé en entrée et en sortie
iptables -A INPUT -i lo -j ACCEPT
iptables -A OUTPUT -o lo -j ACCEPT
iptables -A INPUT -i eth0 -j ACCEPT
iptables -A OUTPUT -o eth0 -j ACCEPT

translation d’adresse pour tout ce qui transfert la passerelle

restreindre le NAT à une plage IP du réseau local

#iptables -t nat -A POSTROUTING -s 192.168.0.0/255.255.0.0 -o eth1 -j MASQUERADE

#toutes nouvelles connexion etablie et associées provenant d’eth0 peuve sortir sur eth1
#toutes connexion etablies et associées à eth1 peuvent aller vers eth0
iptables -A FORWARD -i eth0 -o eth1 -m state --state NEW,ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i eth1 -o eth0 -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i eth0 -o eth0 -m state --state NEW,ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i eth0 -o eth0 -m state --state ESTABLISHED,RELATED -j ACCEPT

#autorisation des requêtes DNS sur le port udp 53
iptables -A OUTPUT -o eth1 -p udp --sport 1024: --dport 53 -m state --state ! INVALID -j ACCEPT
iptables -A INPUT -i eth1 -p udp --sport 53 --dport 1024: -m state --state RELATED,ESTABLISHED -j ACCEPT

#autorisation des requêtes smtp sur le port 25 de smtp.wanadoo.fr
iptables -A OUTPUT -o eth1 -p tcp --sport 1024: -d smtp.wanadoo.fr --dport 25 -m state --state ! INVALID -j ACCEPT
iptables -A INPUT -i eth1 -p tcp -s smtp.wanadoo.fr --sport 25 --dport 1024: -m state --state RELATED,ESTABLISHED -j ACCEPT

#autorisation du pop sur eth1
iptables -A INPUT -p tcp --dport 110 -i eth1 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 110 -o eth1 -j ACCEPT

#autorisation imap sur eth1
iptables -A INPUT -p tcp --dport 143 -i eth1 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 143 -o eth1 -j ACCEPT

#autorisation http sur eth1
iptables -A INPUT -p tcp --dport 80 -i eth1 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 80 -o eth1 -j ACCEPT

#autorisation https sur eth1
iptables -A INPUT -p tcp --dport 443 -i eth1 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 443 -o eth1 -j ACCEPT

#autorisation ftp sur eth1
iptables -A INPUT -p tcp --dport 21 -i eth1 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 21 -o eth1 -j ACCEPT

#autoriser le ssh du net :wink:
iptables -A INPUT -p tcp --dport ssh -i eth1 -j ACCEPT
iptables -A OUTPUT -p tcp --sport ssh -o eth1 -j ACCEPT

#autorisation terminal serveur
iptables -A INPUT -p tcp --dport 3389 -i eth1 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 3389 -o eth1 -j ACCEPT

#autorisation vnc
iptables -A INPUT -p tcp --dport 5900 -i eth1 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 5900 -o eth1 -j ACCEPT

#autorise ICMP pour smtp , DNS ou ping …
iptables -A INPUT -p icmp -i eth1 -j ACCEPT
iptables -A OUTPUT -p icmp -o eth1 -j ACCEPT
[/quote]

et hop le tour est joué


#13

[quote=“Twistophe”]un service DHCP ne te permettra pas de relié les 2 réseaux…
le seul moyen dont tu disposes pour relier ces 2 réseaux, je me répète, est d’utiliser un routeur (logiciel ou hard).

tu peux configurer un routeur sur ton serveur DHCP :

route add -net 192.168.20.0 netmask 255.255.255.0 eth1

route add -net 192.168.77.0 netmask 255.255.255.0 eth2

ensuite, tu dois configurer tes clients pour qu’ils sachent que du coté 192.168.20.0/24, ils peuvent communiquer vers 192.168.77.0/24 via 192.168.20.1 et inversement pour les clients du coté 192.168.77.0/24, ils peuvent communiquer avec 192.168.20.0/24 via 192.168.77.1.

qu’est ce qu’il y a sur eth0 ??[/quote]

Sur eth0 il n’y a rien pour le moment, bientôt le modem eternet que j’attend!
Les routes sont déjà en place.

Le routage est activé etant donné qu’il me sert de passerelle. Je vais peut être désactivé iptables! Si j’ai rentré une mauvaise entrée dedans… on ne sais jamais, ce n’ai pas mon point fort iptables :frowning:


#14

ton serveur DHCP fonctionne ?
depuis un réseau, tu peux pinger l’autre ?

qu’est ce qui ne fonctionne pas alors ?


#15

Oui le serveur dhcp fonctionne.

Je peut pingué depuis mon poste 192.168.77.3 les adresses 192.168.77.1, 192.168.20.1, et dès que je fais le 192.168.20.4, pas de ping qui fonctionne!

Tous les pc chez mes parents sont sous windows, sauf ma passerelle dans mon ancienne chambre qui est sous sarge.

Et je ne peut pingué aucun des pc de chez eux, et de ma passerelle aussi, donc, le problème est résolu, sa vient de windows. Avec mon portable qui tourne sous ubuntu, je me colle là bas, avec une addresse en 192.168.20.56 je peut pingué mon poste de travail 192.168.77.3

Donc je clos je sujet! Merci à vous tous en tout cas :d


#16

si les clients du coté 192.168.20.0/24 sont sous XP SP2, il y a, qque part dans les options du FW, la possibilité de permettre la réponse au ping, par défaut SP2 ne répond pas au ping.

bonne continuation