[RESOLU] Comment passer la résolution à 1280x1024 ?


#1

Bonjour à tous,

Débutant sous Linux (mais accoutumé à la ligne de commande Unix), j’ai réussi après une semaine de galères à installer une Debian Sarge en RAID 1, et à la faire cohabiter avec un Windows XP en dual boot (merci GRUB).

Du coup, je cherche à mettre en place une interface graphique sympa (les screenshots de lynucs.org m’ont un peu fait rêver, j’avoue).
J’ai déjà essayé Fluxbox et XFce, mais me suis finalement tourné vers Gnome (le KDE de Knoppix ne m’a pas convaincu, mais bon).

Voilà pour l’intro, passons au choses sérieuses :

Matériel :
CG Matrox Mystique 1064SG avec 4 Mo de RAM (antiquité récupérée sur un vieux Cyrix)
Moniteur LCD Hyundai L90D+ (résolution native 1280x1024)
CM ASUS A7N8X-E Deluxe (je pense que l’info est inutile, mais bon)

J’ai configuré XFree de façon à tourner en 1280x1024 en 24 bits, mais Gnome n’est qu’en 1152x864. Ayant subi diverses galères pour faire tourner le serveur X, et ayant vu un post allant dans ce sens, j’ai supprimé le fichier /etc/X11/XF86Config-4 et refait une configuration de XFree.
Curieusement, les paramètres rentrés auparavant étaient toujours sélectionnés par défaut (où donc sont-ils stockés ?).
Reconfiguration faite, j’appelle startx, ce qui provoque une erreur fatale : le fichier XF86Config-4 est introuvable.
Bon, je suis plus à ça près, je désinstalle xserver-xfree86 et le réinstalle avec aptitude, puis le reconfigure. A nouveau, toutes mes entrées précédentes sont sélectionnées par défaut ; ça sent le fichier de conf planqué dans un coin du système.
Reboot.
Connexion, startx, et… toujours du 1152x864 !!

L’examen du fichier /etc/var/XFree86.0.log montre notamment le message d’erreur suivant :
"Need at least 11664 kB video memory at this resolution, bit depth"
Il montre aussi plein de tests de résolution ratés, pour cause de hsync ou de vsync en dehors des bornes, ou de mémoire insuffisante.
J’ai aussi essayé de reconfigurer xserver-xfree86 pour lui faire afficher du 1280x1024, mais là c’est apparemment Gnome qui n’a rien voulu savoir : toujours du 1152x864 en 24 bits.

Ce qui me gêne dans tout ça, c’est que :

  • le 1152x864 sur un LCD prévu pour du 1280x1024, c’est assez moche
  • Windows XP arrive à m’afficher son bureau, lui !!

Quelqu’un a une explication ou une solution (à part aller acheter une nouvelle CG, merci :slight_smile: ??

Merci d’avance !


#2

La meilleure chose à faire est d’installer un max. d’outils de détection hardware.
apt-get install discover1 hwinfo read-edid xdebconfigurator kudzu mdetect gpm

Et ensuite, tu tapes:

xdebconfigurator -diklr
puis:
dexconf

Ca te génère un superbe fichier XF86Config-4 avec quasiment toutes les modes et résolutions supportées par ton matos.

Depuis que j’utilise cette méthode, fini la galère de config. pour X11 ! :smiley:
Il y a des fois des petits détails à modifier à la main mais c’est rare…


#3

J’'oubliais: A ma connaissance, le fichier de config de X11 ne peut pas être placé ailleurs que dans /etc/X11 …

Quelqu’un dans la salle pour confirmer que je ne raconte pas d’âneries :question: :blush:


#4

Merci pour la réponse !

Je viens d’essayer xdebconfigurator, après avoir installé tous les paquets mentionnés (oui, je sais, il est tard, mais bon).

Je ne suis pas allé plus loin : la sortie de la commande était assez édifiante comme ça. En gros :

[...] The EDID data should not be trusted as the VBE call failed [...] parse-edid: IO error reading EDID [...] MONITOR SIZE: 15 inches (380 mm) MONITOR HOR SYNC: 28-50 MONITOR VER REFR: 43-75 MONITOR MODES: 1024x768, 800x600, 640x480 MONITOR MODE: 1024x768 @ 70 Hz MONITOR DEFAULT DEPTH: 16
Hum… Mon moniteur est un 19" (481 mm), avec un HSYNC de 31-80 et un VSYNC de 56-75… Pas tout à fait ce qui a été trouvé, je n’ai donc pas osé pousser plus loin (1152x864 c’est toujours mieux que 1024x768…)

J’ai oublié de préciser, mais j’ai aussi essayé la Knoppix et tout marche au poil avec, comme avec XP… Alors, c’est koikidéconne ?

… M’en vais rebooter à la Knoppix et regarder le XFree, tiens.

Pour l’histoire du fichier de conf caché, comme toi je doute, mais d’un autre côté il m’avait gardé même des paramètres farfelus d’un coup sur l’autre (genre depth=4, tentative justifiée par le fait que ça devrait prendre 6 fois moins de place qu’en 24 bits, et du coup rentrer sur les 4 Mo de la carte…).

Un truc qui me revient : à un moment dans la configuration de xserver-xfree86, on demande la quantité de mémoire de la carte. J’ai laissé le champ vide, mais le texte explicatif laisse penser que si j’en rajoute, ça pourrait bien être le système qui filerait de la RAM (n’étant pas pro en bas-niveau, je vois pas trop comment ça pourrait se résoudre, mais sur le principe ça me paraît envisageable). A suivre.


Bonne nuit


#5

Bon, voilà, le problème est résolu… J’ai suivi ma dernière intuition : aller voir le fichier XF86Config-4 de Knoppix.

Là, j’ai été un peu embêté parce qu’il y avait aussi un fichier XF86Config normal, et même deux liens symboliques (avec “l’extension” ‘.in’). Mais bon, en gros j’ai mis en place mon RAID 1, j’ai monté le supervolume et j’ai copié les 4 fichiers, bien bourrin, vers mon propre /etc/X11 (après avoir renommé le précédent fichier de conf… C’est pas qu’il était indispensable, mais bon, j’ai des réflexes).

Après reboot, me revoilà en 1152x864… Grmbl… Sauf que dans les Préférences de Résolution, est apparu le choix 1280x1024… Bonheur !
Enfin bon, du coup mon wallpaper est à changer, puisque cet écran est plus proche du carré (1280/1024 <> 4/3). Snif, trop DUR !

La solution est crado, mais si ça marche…
Merci pour vos conseils (même si J’ai fait le plus dur :wink: !!


Aurélien


#6

Houlàaaaaa… J’avais pas vu ça :open_mouth:
Evidemment, si tu n’as que 4 MO sur ta carte, ca limite beaucoup…
Je suis pas très doué pour la config de Xwindows mais il me semble que si ça marche sur Knoppix, c’est parce que ce genre de distrib. boote souvent en utilisant le Frame Buffer.
Si je ne me trompe pas, le frame buffer est censé fonctionner à peu près sur n’importe quel type de matériel, sans configuration très poussée, mais avec des perfomances moindres, bien sûr…

Peut-être que tu as booté ta distrib sans le mode Frame Buffer et ta Knoppix en Frame Buffer. Ca pourrait expliquer …


#7

“Frame Buffer”… Ca me rappelle une des options de compilation du noyau, que j’ai finalement pas sélectionnée je crois. Si ma mémoire est bonne, le texte explicatif accompagnant l’option mentionnait que cette option était susceptible de ralentir le système.
Alors du coup, je serai un peu étonné que ça vienne de ça : si cette option n’est pas dans le noyau (j’aime pô les modules donc j’ai compilé le noyau n y incluant direct toutes les options que j’ai trouvées utiles), c’est que mes problèmes de résolution, et surtout la solution appliquée, ne peut provenir de là ?!
Ou alors… Il ya aurait une option à passer au serveur X pour lui préciser le mode framebuffer ?

J’approfondirai les différences entre le XF86Config d’origine et celui de Knoppix, à l’occasion. Et je ferai ptêt une re-compilation du noyau, parce qu’il me manque au moins la gestion d’un de mes deux ports ethernet (une histoire de patch à appliquer aux sources avant la configuration de la compilation).
Et si je trouve de quoi il retourne vraiment, je mettrai à jour le topic.

Merci pour tes commentaires, en tout cas !!


#8

Bah, ca reste quand même le meilleur moyen d’alléger ton kernel, donc de libérer des ressources … Ce qui rendra ton système moins lourd et plus réactif !

Mais y a pô de koi ! :laughing:


#9

Pour ceux que ca pourrais encore interesse
lancer :
xrandr
la liste des resolution disponible
en suite relancer
xrandr -s “n° de la resolution souhaitee”

Ou encore plus simple, mais uniquement sous gnome et kde d’apres ce que j’ai vu
"ctrl" “alt” + et “ctrl” “alt” - :wink:

:smiling_imp:


#10

Bonjour,

Je n’ai pas essayé la commande xrandr, je ne me prononcerai donc pas sur son éventuelle utilité (la page de man semble en effet assez prometteuse… Si j’ai vraiment du temps à tuer, je reprendrai mon ancien fichier de conf XFree et je verrai si ça apporte un plus).

En revanche, je peux affirmer sans crainte de me tromper que [Ctrl]+[Alt]+[+/-] ne m’a été d’aucune utilité, puisqu’elle ne se base apparement que sur les résolutions que le serveur X a jugées possibles lors de son démarrage.

Tout le problème consistait en fait à faire comprendre à XFree qu’il pouvait effectivement utiliser un affichage en 1280x1024, ce en quoi le fichier de conf extrait de la KNOPPIX m’a rendu un immense service.


#11

OK, je dissais juste ca pour aider, n’ayant pas encore eu le probleme :slightly_smiling:, mais ca ne coute rien d’essayer :wink: