[RESOLU] Config ADSL + Modem Ethernet => collisions


#1

Bonjour,

J’utilise actuellement une Debian Sid et une connexion ADSL avec un modem Ethernet Sagem Fast 908.
Je souhaite configurer ma connexion via le fichier /etc/network/interfaces. (/etc/ppp/ppp_on_boot deprecated !!).

J’ai donc ajouter les lignes suivantes :

auto eth0
iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0

auto ppp0
iface ppp0 inet ppp
provider dsl-provider

Tout se passe bien, la connexion s’établit au démarrage. Néanmois j’ai des coupures et mon ifconfig me signale qu’il se passe quelque chose de bizarre pour l’interface eth0 :
collisions:13
Interrupt:5

Merci pour votre aide.


#2

je ne comprend pas le rapport entre ton eth0 et ta connection adsl (le fast 908 est bien en usb, non ?)?

sinon, il y a toujours des collisions sur un réseau (13 au moment ou tu as regardé), et ton eth0 utilise l’interruption 5 (pourquoi pas).

pour tes coupures, ce n’était pas le cas déja avant ?


#3

Ce modem n’est pas en USB mais en Ethernet et donc relié par l’interface eth0. Je pensais que l’interruption n’était pas normal. Il n’y avait pas de coupure avant. Mais ca doit pas très bien fonctionner car j’ai de nombreux ralentissements que j’avais pas avant. J’ai d’autres erreurs avec mon ifconfig , je les posterais ce soir.


#4

normalement, donc, tout est normal, et ta config correspond effectivement à l’équivalent du lancement de ‘pon dsl-provider’.
C’est donc avec pon/poff qu’il faut que tu fasse tes tests.
Tu ne m’as pas répondu: avant d’automatiser, tu n’avais aucun pb ?
Sinon, as tu une directive ‘persist’ qqpart dans /etc/ppp/peers/dsl-provider ?


#5

C’est à dire qu’avant j’utilisais pppoeconf mais celui-ci configure les interfaces avec l’ancienne méthode (script ppp, …). De toute façon j’avais plus la connexion auto à chaque boot et il fallait que j’active la connexion manuellement. Du coup je voudrais passer à la nouvelle méthode avec le fichier interfaces. Pour faire les tests j’utilise ifdown -a et ifup -a. Voici la sortie de mon ifconfig pour mon interface eth0 :

eth0 Lien encap:Ethernet HWaddr 00:01:02:FA:5C:93
inet adr:192.168.0.1 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::201:2ff:fefa:5c93/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:61144 errors:11 dropped:0 overruns:0 frame:17
TX packets:85636 errors:0 dropped:0 overruns:0 carrier:0
collisions:1 lg file transmission:1000
RX bytes:24287405 (23.1 MiB) TX bytes:62006067 (59.1 MiB)
Interruption:5 Adresse de base:0xdc00


#6

oublie le ifdown -a et ifup -a : ta carte eth0 n’a pas besoin d’être coupée. par contre, avec ‘ifup ppp0’ ‘ifdown ppp0’ tu peux faire la même chose plus vite.
Comme je disais, y a t il dans /etc/ppp/peers/dsl-provider un persist ? et aussi ‘mtu 1492’ ?
si tu y mets ‘debug’, et ‘dump’, tu auras aussi une trace dans /var/log/debug, et dans /var/log/messages respectivement.


#7

Ok pour ifdown -a, c’est vrai que c’est pas top sachant que ca enlève l’interface loopback !
Bon j’ai bien persist et mtu 1492 dans mon fichier dsl-provider.
J’ai placé debug et dump dans le fichier et j’ai eu les messages suivants :

kernel: eth0: no IPv6 routers present (dans debug) et :

Apr 18 22:56:14 localhost pppd[6579]: Plugin rp-pppoe.so loaded.
Apr 18 22:56:14 localhost pppd[6579]: Plugin rp-pppoe.so loaded.
Apr 18 22:56:14 localhost pppd[6579]: pppd options in effect:
Apr 18 22:56:14 localhost pppd[6579]: debug^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: persist^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: dump^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: plugin rp-pppoe.so^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: plugin rp-pppoe.so^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: noauth^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: user ^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: eth0^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost last message repeated 2 times
Apr 18 22:56:14 localhost pppd[6579]: noaccomp^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: asyncmap ffffffff^I^I# (from /etc/ppp/options)
Apr 18 22:56:14 localhost pppd[6579]: default-asyncmap^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: mtu 1492^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: lcp-echo-failure 3^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:14 localhost pppd[6579]: lcp-echo-interval 20^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:15 localhost pppd[6579]: hide-password^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:15 localhost pppd[6579]: noipdefault^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:15 localhost pppd[6579]: defaultroute^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:15 localhost pppd[6579]: proxyarp^I^I# (from /etc/ppp/options)
Apr 18 22:56:15 localhost pppd[6579]: usepeerdns^I^I# (from /etc/ppp/peers/dsl-provider)
Apr 18 22:56:15 localhost pppd[6579]: noipx^I^I# (from /etc/ppp/options)
Apr 18 22:56:15 localhost pppd[6580]: pppd 2.4.3 started by root, uid 0
Apr 18 22:56:15 localhost pppd[6580]: PPP session is 44810
Apr 18 22:56:15 localhost pppd[6580]: Using interface ppp0
Apr 18 22:56:15 localhost pppd[6580]: Connect: ppp0 <–> eth0
Apr 18 22:56:15 localhost pppd[6580]: Couldn’t increase MTU to 1500
Apr 18 22:56:15 localhost pppd[6580]: Couldn’t increase MRU to 1500
Apr 18 22:56:15 localhost pppd[6580]: Couldn’t increase MRU to 1500
Apr 18 22:56:16 localhost pppd[6580]: CHAP authentication succeeded: CHAP authentication success, unit 376
Apr 18 22:56:16 localhost pppd[6580]: peer from calling number 00:02:3B:02:65:34 authorized
Apr 18 22:56:16 localhost pppd[6580]: local IP address ..
.

Apr 18 22:56:16 localhost pppd[6580]: remote IP address ..
.

Apr 18 22:56:16 localhost pppd[6580]: primary DNS address ..
.

Apr 18 22:56:16 localhost pppd[6580]: secondary DNS address ...

Le truc bizarre, c’est quand même le MTU qui est de 1500 pour l’interface eth0 et 1492 pour ppp0. Par ailleurs quand j’avais configuré ma connexion via pppoeconf l’interface eth0 n’avait qu’une adresse IPv6 et pas une adresse IPv4 + IPv6 mais peut-être que cela n’a rien à voir.


#8

Voilà j’ai trouvé la solution.
Elle est un peu bizarre mais il suffit de configurer l’interface eth0 avec une adresse IPv6. Je sais pas pourquoi mais maintenant ca marche. J’ai repris l’adresse que me donnait la config avec pppoeconf et je l’ai mis en static dans le fichier /etc/network/interfaces.

Merci pour votre aide.
++