RÉSOLU - debian amd 64 + openoffice


#1

Bonjour,

voilà 6 mois que je suis sous debian 64, j’ai un petit soucis c’est que certain soft comme openOffice ne sont pas encore pret pour la version 64.

Or il parrait que l’on peut faire tourner OpenOffice en chroot 32.

qui peut m’aider ?


#2
  1. Faire un debootstrap i386 sarge sur la machine
  2. installer dchroot
    et mettre une ligne
    i32 [chemin du repertoire de lasarge] dans dchroot.conf

(admettons que ça soit /sarge)
3) installer openoffice sur l’architecture i386

  1. rajouter
    /home /sarge/home none bind 0 0
    /tmp /sarge/tmp none bind 0 0
    proc /sarge/proc proc defaults 0 0
    /var/run/lprng /sarge/var/run/lprng none bind 0 0

dans /etc/fstab (la dernière pourt lprng, pour cups je ne sais pas), cela rendra les choses complètement transparentes pour les utilisateurs, ils verront leurs fichiers et pourront imprimer.

  1. Le plus ennueyx, virer l’option -nolisten tcp de kdm/xdm/gdm
  2. Le lancement de openoffice se fait par

xhost +localhost;dchroot -c i32 -d openoffice

6)bis) Pour une icone dans le bureau de Kde, le fichier ci dessous convient:

[Desktop Entry]
Comment=
Comment[fr]=
Encoding=UTF-8
Exec=xhost +localhost;dchroot -c i32 -d openoffice
GenericName=
GenericName[fr]=
Icon=/sarge/usr/share/icons/hicolor/32x32/apps/ooo_office.xpm
MimeType=
Name=Openoffice
Name[fr]=Openoffice
Path=
StartupNotify=true
Terminal=false
TerminalOptions=
Type=Application
X-DCOP-ServiceType=
X-KDE-SubstituteUID=false
X-KDE-Username=


#3

[quote=“fran.b”]1) Faire un debootstrap i386 sarge sur la machine
2) installer dchroot
et mettre une ligne
i32 [chemin du repertoire de lasarge] dans dchroot.conf
quote]
(admettons que ça soit /sarge)
3) installer openoffice sur l’architecture i386
[/quote]

pour commencer qu’appelle tu faire un debootrap
[/quote]


#4

apt-get install debootstrap

debootstrap sarge /sarge

ça crée une racine complète sarge sous /, après tu y installes apt-get et les paquets nécessaires. Prévoir de la place.

man debootstrap sera + clair


#5

je vais tester tout ça


#6

voilà j’ai installé le debootrap

par contre je suppose qu’il faut créer manuellement le répertoire sarge car la commande
debootstrap sarge /sarge ne fonctionne pas


#7

Oui


#8

Je profite que l’on parle d’installation sous amd64 pour savoir si quelqu’un a réussi à installer gnome-core en testing ?
(pour moi, j’ai des problèmes de dépendances avec eog et gedit)

Comme je ne voudrais pas passer en stable, faut-il que je force l’install ? Est-ce que cela ne va pas poser des problèmes à l’update ?

merci


#9

le répertoire sarge je le créer dans mon home ?


#10

EDIT: Je n’ai rien dit
(si un modo pouvais effacer ce post, merci)


#11

Non, le répertoire sarge devra être accessible par tous les utilisateurs et contient une racine complète. Je privilégierais dans l’ordre suivant la place disponible:

/usr/lib/sarge
/opt/sarge
/sarge

En gros tu peux compter 1.5G.

Par ailleurs, si ça t’intéresse, j’ai fait un certain nombre de paquets amd64 dont une version de binutils qui corrige le bug (assez important) de ld (qui fait des segfaults pour la version de sarge/AMD64.

J’ai compilé pour amd64 les paquets suivants:
amsn amule amule-common amule-daemon amule-utils amule-utils-gui
binutils binutils-dev binutils-doc binutils-multiarch cacheproc
camllight choixreboute clamav clamav-base clamav-daemon clamav-docs
clamav-freshclam clamav-milter clamav-testfiles dejagnu expect-
tcl8.3 expect-tcl8.3-dev expectk-tk8.3 faac faad fricorder gnudoku
idle-python2.4 ksudoku libclamav-dev libclamav1 libebml-dev libfaac-
dev libfaac0 libfaad2-0 libfaad2-dev libid3-3.8.3-dev libid3-
3.8.3c2a libmp4-0 libmp4-dev libwxgtk2.6-0 libwxgtk2.6-dbg
libwxgtk2.6-dev openhackware proll python-glade2 python-gtk2 python-
gtk2-dev python-wxgtk2.6 python-wxtools python-wxversion python2.3-
glade2 python2.3-gtk2 python2.4 python2.4-dbg python2.4-dev
python2.4-doc python2.4-examples python2.4-gdbm python2.4-glade2
python2.4-gtk2 python2.4-minimal python2.4-tk qemu scilab sgt-
puzzles sun-j2re1.4 surveillance transfert wx-common wx2.6-doc
wx2.6-examples wx2.6-headers wx2.6-i18n xmms-mp4 yasm

Tu les trouves sur
deb boisson.homeip.net/amd64/ sarge ./


#12

donc si je te suis bien

je dois crer mon répertoire sarge dans

/usr/lib/sarge
/opt/sarge
/sarge

pour le 1.5 go pas grave j’ai de la marge

Question quand j’ai installé mon dbootratp j’ai pas preciser i386


#13

Arg désolé, il faut lui donner l’argument --arch i386 sinon tu refais une sarge amd64. Je suis désolé… oubli de ma part. :frowning:


#14

tu crois que je peux le désinstaller avec apt-get - remove --purge dboostrap


#15

Non non, le debootstrap est bon, tu fais juste un rm -R du répertoire crée et tu recommences en rajoutant l’option --arch i386 en plus lors de l’appel à debootstrap:

rm -Rf /usr/lib/sarge (vérifies bien que c’est celui là)

debootstrap --arch i386 sarge /usr/lib/sarge

par exemple (après un mkdir)


#16

je vois pas le répertoire dboostrap, normalement il se place ou ?


#17

je viens de lancer apt-get install dboostrap --achi i386, c’est en cours mais ça change car la première fois cela avait mis 10 s.

sinon le dboostrap c’est quoi acxactement ? le noyau


#18

voilà c’est fait par contre j’ai un doute car j’ai en fin de commande des lignes contradictoires.

I: Base system installed successfully.
umount: /usr/lib/sarge/dev/pts: not mounted
umount: /usr/lib/sarge/dev/shm: not mounted
umount: /usr/lib/sarge/proc/bus/usb: not mounted
debian64:/# apt-get install deboostrap --archi i386
E: L’option --archi de la ligne de commande n’est pas reconnue
debian64:/#


#19

debootstrap --arch i386 sarge /usr/lib/sarge

et non

debootstrap --archi i386 sarge /usr/lib/sarge

Sinon, ce répertoire contient une installation complète sarge. Tu le testes en faisant

chroot /usr/lib/sarge

Vérifie que cela correspond bien à une install i386


#20

[quote=“fran.b”]# debootstrap --arch i386 sarge /usr/lib/sarge

et non

debootstrap --archi i386 sarge /usr/lib/sarge

Sinon, ce répertoire contient une installation complète sarge. Tu le testes en faisant

chroot /usr/lib/sarge

Vérifie que cela correspond bien à une install i386[/quote]

je te suis pas bien tu dis

debootstrap --arch i386 sarge /usr/lib/sarge et non
debootstrap --archi i386 sarge /usr/lib/sarge

ou est ka différence ?

en tout je viens de vérifier et voilà ce que j’ai on dirait que c’est bon

debian64:/usr/lib/sarge# ls
bin dev home lib mnt proc sbin sys usr
boot etc initrd media opt root srv tmp var

quand je fais # chroot /usr/lib/sarge
il se passe rien.