(Résolu) Gravure


#1

Salut à tous,

Voila, j’ai récuperé le disque qui était en réparation et j’ai installé Debian testing dessus. Tous c’est bien passé et cela fonctionne correctement. Seul problème qui me reste la gravure. je vous donne le message d’erreure que j’ai lors d’une tentatve de gravure, pour le cas ou. Je vois que l’on me parle de scsi alors que je suis en ide.

[quote]cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive dependent defaults.
cdrecord: Continuing in 5 seconds…
cdrecord: Warning: Running on Linux-2.6.12-1-386
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/hdd’
devname: '/dev/hdd’
scsibus: -2 target: -2 lun: -2
Warning: Open by ‘devname’ is unintentional and not supported.
Linux sg driver version: 3.5.27
Error: Cannot gain SYS_RAWIO capability.Is cdrecord installed SUID root?
: Operation not permitted
cdrecord: Warning: using inofficial version of libscg (ubuntu-0.8ubuntu1 ‘@(#)scsitransp.c 1.91 04/06/17 Copyright 1988,1995,2000-2004 J. Schilling’).
SCSI buffer size: 64512
cdrecord: Asked for SCSI I/O buffer size 64512 bytes, could only get 20480.
cdrecord: This version of cdrecord does not include DVD-R/DVD-RW support code.
cdrecord: See /usr/share/doc/cdrecord/README.DVD.Debian for details on DVD support.
Cdrecord-Clone 2.01.01a03 (i686-pc-linux-gnu) Copyright © 1995-2005 Joerg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
and thus may have bugs that are not present in the original version.
Please send bug reports and support requests to cdrtools@packages.debian.org.
The original author should not be bothered with problems of this version.

TOC Type: 3 = CD-ROM XA mode 2
Using libscg version ‘ubuntu-0.8ubuntu1’.
atapi: 1
Device type : Removable CD-ROM
Version : 0
Response Format: 2
Capabilities :
Vendor_info : 'TDK '
Identifikation : 'DVDRW882N '
Revision : '2.35’
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x000A
Profile: 0x002B
Profile: 0x001B
Profile: 0x001A
Profile: 0x0014
Profile: 0x0013
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A (current)
Profile: 0x0009
Profile: 0x0008 (current)
Using generic SCSI-3/mmc CD-R/CD-RW driver (mmc_cdr).
Driver flags : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
Drive buf size : 1343488 = 1312 KB
FIFO size : 4194304 = 4096 KB
cdrecord: Operation not permitted. Cannot send SCSI cmd via ioctl
Track 01: data 86 MB padsize: 30 KB
Total size: 99 MB (09:50.65) = 44299 sectors
Lout start: 99 MB (09:52/49) = 44299 sectors
[/quote]

Si vous avez une idée, elle sera la bien venu. :smiley:

Jean 8)


#2

adduser cdrom


#3

Tu veux dire au niveau du groupe ?

J’appartiens bien au groupe cdrom et burning.

[quote]jeantux@debian:~$ id
uid=1000(jeantux) gid=1000(jeantux) groupes=4(adm),24(cdrom),29(audio),46(plugdev),107(scanner),1000(jeantux),1001(burning)
jeantux@debian:~$
[/quote]

Ou y a t il quelque chose que j’aurai loupé?

Jean 8)


#4

Tu n’émules pas en scsi dans lilo.conf (ou menu.lst) ?


#5

Normalement non, je n’ai pas de carte scsi à ma connaissance, ensuite j’utilise Grub et je suis sous gnome. (précision que je n’avais pas fait.) :unamused:

Je ne vois pas ce que scsi vient faire dans ma config?

J’ai bien du RAID et du SATA sur ma carte mère, mais vu que je ne m’en sers pas, je les ais désactivés.

Jean :wink:


#6

L’émulation scsi était de rigueur (pour les périph ide) avant le noyau 2.6. Ce n’est pas ton cas, je pense donc je n’ai pas d’idée. Donne-nous qd même un ‘uname -r’.


#7

Ce qui est bizarre, c’est que je n’ai ce problème qu’avec cette version là!!!

Ca va que je ne grave pas à tout va. Si j’en ai vraiment besoin, je passe sous Debian sarge. :wink:

[quote]jeantux@debian:~$ uname -r
2.6.12-1-386
[/quote]

J’aurai bien essayé de passer à 2.6.15.1, mais je n’ai pas bien compris la méthode pour compiler. :unamused:

Je préfère attendre encore un peu et bien me faire la main.

Jean :laughing:


#8

C’est bizarre, on dirait le bug de 2.6.8 :

cdrecord: Operation not permitted. Cannot send SCSI cmd via ioctl 

Essaye de griller en root (je veux dire graver sous root)

Si ça marche, ton 2.6.12 a la varicelle :wink:


#9

C’est tres bien expliqué la 8) 8)
forum.debian-fr.org/viewtopic.php?t=1806


#10

C’est une idée, je vais voir en root si ça passe, j’avais déja essayé sur la config d’avant, mais on ne sais jamais !

En attendant, je suis bien content, j’ai réussis à régler pas mal de problèmes. Le son qui me jouaient encore des tours, les appareils photos qui n’étaient pas reconnu, L’imprimante qui ne se laissait pas faire. Puis sa mise en réseau pour fonctionner avec mon portable. Tout est au poins, sauf le problème de gravure.

Sinon, Ashgenesis, j’ai bien vu ton topic, mais vu la tartine et tous ce qui me restait à mettre au point, j’ai un peu paniqué, mais je veux bien essayer, d’autant que j’ai encore un disque qui est sous testing. Si je peu je tenterai le coup demain (si je ne suis pas trop dérangé)

En attendant, merci à vous. :laughing:

Jean :slightly_smiling:


#11

Bon, j’ai essayé la gravure en root, cela fonctionne bien. J’ai le message suivant avant, mais la gravure ce lance tout de même.

[quote] Erreur montage /media/cdrom1
umount : /media/cdrom1 : not mounted [/quote]

Je ne sais pas si cela peut être la cause du problème ?

Jean :wink:


#12

La nuit porte conseil, je me suis souvenu avoir eu ce message lors de l’installation de DEbian :

[quote]Configuration de cdrecord

Cette option vous permet d’installer cdrecord avec le bit SUID positionné.

Si vous installez cdrecord avec le bit SUIS positionné, vous permettez aux utilisateurs du groupe “cdrom” de graver des cédéroms sans permissions supplémentaires. Cependant, cela peut permettre l’utilisation de cdrecord pour tenter de compromettre la sécurité de votre ordinateur. Dans le doute, vous devriez l’installer sans le bit SUID. Si vous changez d’avis, vous pourrez lancer plus tard :
“dpkg-reconfigure cdrecord”.

Faut’il rendre les binaires cdrecord “SUID” ?

[/quote]

J’ai donc fait un “dpkg-reconfigure cdrecord”. Et c’est partie. Ce GnomeBaker commence à me plaire. Moi qui ne connaissai que K3b. :laughing:

Jean 8)


#13

Oui, tu as tout bon !

Et pas besoin de monter tes cd pour graver (de tte façon, s’ils sont vierges, il n’y a rien à monter). C’est même déconseillé, je pense.


#14

Maintenant, j’aimerai bien réussir à installer la même version de Debian sur mon portable. J’ai voulu essayer hier, mais j’ai eu des problèmes au cour de l’install qui se sont répété après chaque nouvelles tentative à des moment différent de l’install. De plus comme j’ai été dérangé sans arrêt je n’ai pu me concentrer sur ce que je faisait.

Du coup j’ai essayé Mandriva 2006 qui c’est installé facilement (j’avais réussis à graver l’image DVD .ISO) mais je préfère tout de même Debian.

Urpmi n’a pas l’air mal, mais quand on commence à avoir des habitubes, on aime bien garder ses repère. :laughing:

Donc si je peu, je refais un essai aujourd’hui. Pour la compile, je verrai un peu plus tard, maintenant que ça marche … :wink:

Jean 8)