[Résolu] Install Firefox : OK en simple user, erreur en root


#1

Bonjour,

Je souhaite installer Firefox 1.0.7.
J’ai tout d’abord essayé un apt-get install mozilla-firefox mais la version qu’il m’installe est la 1.0.4.
J’ai donc téléchargé le tar.gz de la 1.0.7 sur le site de Mozilla, que j’ai ensuite extrait.
Sous Konsole, en simple user, je peux lancer l’installation de Firefox sans problème, mais si je le fais en root pour que firefox soit disponible pour tous les utilisateurs, j’obtiens le message suivant :

[code]exec /home/max/firefox/firefox-installer
Xlib: connection to “:0.0” refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key

(firefox-installer-bin:3854): Gtk-WARNING **: cannot open display:[/code]

Une idée ?
Merci.


#2

slt,

Si tu peux l’installer avec un simple user fais le, puis apres en root tu change les droits et le propriétaires, tu fais un lien sybolique de /ou/est/ton/firefox a /usr/bin/firefox et normalement il devrait être accessible a tous les users.


#3

le .deb sid en pool, c’est un 1.0.7-1:
ftp2.fr.debian.org/debian/pool/m … 1_i386.deb
s’il manque des dépendances, tu cherches autour dans le pool.


#4

Probablement parce que tu t’es d’abord connecté sous X en user normal et qu’ensuite tu es passé root (avec su) pour ensuite démarrer l’install depuis ta console root, non ?
Si c’est le cas, ça me paraît normal, car si ton installation lance une interface graphique, même l’utilisateur root n’a par défaut pas les droits d’afficher quelque chose sur le display d’un autre utilisateur…

Ouf ! J’espère avoir été assez clair dans mon explication … :unamused:


#5

Mouais … :angry: Ca me paraît un peu bricolage comme solution …


#6

J’ai trouvé la cause du problème en faisant une recherche sur mon code d’erreur.
Apparement, c’est le changement d’identité (su) sous X server qui pose problème.

:arrow_right: Avec le compte qui a démarré X Server :

xhost + su export DISPLAY=$HOST:0.0

Et ca roule… :smiley:

Merci pour vos réponses.

Edit :
Grilled by Jabba


#7

Pour pouvoir avoir une interface graphique après un su -, il suffit de faire un xhost + avant de faire le su, puis de faire un export DISPLAY=:0.0 après être passé en root, et là normalement ça devrait passer.
Autre solution, si tu as autoriser le forward X11 et le RootLogin sur ton serveur ssh, il suffit de faire un ssh root@localhost -X et là aussi tu pourras lancer une interface graphique en tant que root.


#8

Sous debian, on installe du debian…
enfin…


#9

Oui, c’est ça, ça marche. Merci.
J’ai trouvé la même chose sur linuxquestions.org/questions/history/335299

Ah, la, c’est plus compliqué… va falloir que j’étudie les config de sshd et de XFree86… :confused:


#10

[quote=“MattOTop”]Sous debian, on installe du debian…
enfin…[/quote]

C’est à dire ?
Il est pas bien le renard sous Debian ? :smiley:


#11

nonnon, à part le debian-installer et apt, tout le reste est un bien commun à tous les linuxiens.
(même si debian-security râle à cause de la politique de release de mozilla qui empêche la correction des failles- certains veulent arrèter de maintenir mozilla dans debian).
Ce que je voulais dire, c’est qu’il faut éviter de sortir d’apt/dpkg autant que faire se peut: il existe un .deb => on l’installe de préference à toute autre methode.
C’est tout ce que je voulais dire.
Maintenant, la resolution de ton pb a un interet theorique pour moi, mais je ne me sens pas interressé aussi franchement qu’a participer à la bonne integration de composant debian.
C’est filauzofik…


#12

OK, je prends note. Préférer les *.deb.

Mais j’ai essayé avec le package que tu as linké plus haut, et comme tu l’as dit, effectivement j’ai eu pas mal de problème de dépendances sur des lib, et sur un package indiqué comme obsolète.


#13

En fait, l’ideal dans ton cas, serait de rajouter les sources Sid, et de configurer, dans preferences, une priorité en sid de mozilla et des paquets dépendants, en excluant l’install sid de tout autre paquet avec une pririté negative (d’experience, cependant, ca casse apt-build).
Mais à la main, en parcourant l’arborescence du site ou je t’ai indiqué le paquet moz en sid (ou n’importe quel depot debian d’ailleurs), tu peux trouver un à un toutes les versions de paquets dont depend moz en sid.
Mais je le répète, c’est une question de choix.
Comme disent les mongueurs “there’s more than one way to do it”


#14

Oui, ou bien parfois on arrive à trouver des repository contenant ce que l’on cherche, par exemple :
www1.apt-get.org/search.php?quer … %5B%5D=all

Donc pour moi, lorsqu’on ne trouve pas un paquet, le premier réflexe c’est apt-get.org :wink:


#15

Mouais…
C’est une solution, mais on ne sait pas toujours ce que le depot va proposer comme remplacement sur des paquets standard/critique, et à force de rajouter des sources, on finit toujours pas se retrouver avec du pinning.
Je trouve ca un peu pauvre en plus: ca ne vaut pas rpmfind pour RH…
Ce n’est qu’un avis bien sûr, et ca merite tout de même effectivement de s’y interresser.
le resultat chez moi de la multiplication des sources:

emeraude:~$ wc -l /etc/apt/sources.list 232 /etc/apt/sources.list emeraude:~$ wc -l /etc/apt/preferences 209 /etc/apt/preferences
(faites ce que je dis, faites pas ce que je fais) :laughing:


#16

Ouais, en même temps c’est un peu pour éviter ce genre de prises de tête que je suis passé en sid, au moins j’ai toujours les derniéres nouveautés, malgré quelques petits soucis de dépendances de temps à autre.


#17

[quote]Xlib: connection to “:0.0” refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key

(firefox-installer-bin:3854): Gtk-WARNING **: cannot open display:[/quote]
Je ne sais pas si tu as réussi à péréniser l’affaire mais :
1/ il faut vérifier avec

env

que tu as bien
DISPLAY=:0.0
2/ avec un éditeur kedit ou gedit, par exemple ouvrir
/home/ton_user/.bash (ne pas oublier le ‘.’ )
Ds le fichier qui s’ouvre, au début et après la ligne :
if [ “$PS1” ]; then (ou qq chose de ressemblant)
ajouter la ligne :
alias su='xhost + ;su ’