[résolu]: Installer correctement sa carte ipw2100


#1

salut, j’ai suivi ta procedure d’installation comme bien d’autres pour les drivers de
ma 2200 B/G, mais ca ne trouverien quand je fait:
apt-get install linux-headers-2.6.15-1-686

!! !donc je ne peu pas continuer, tu as une idee ?

aswat


#2

ash@seal:~$ apt-cache policy linux-headers-2.6.15-1-686 linux-headers-2.6.15-1-686: Installed: (none) Candidate: 2.6.15-8 Version table: 2.6.15-8 0 550 http://ftp.fr.debian.org etch/main Packages As tu les bonnes sources dans ton fichier /etc/sources.list

Pas de probleme de preferences???


#3

il doit juste te manquer ce dépot

si ca ne marche pas ouvre un autre fil sur le general et poste ton fichier /etc/sources.list


#4

j’ai installé ieeebidule, ca a l’air d’avoir fonctionné
jtenté la métode module-assistant a-i ipw2200
il me sort des centaines d’erreurs (je pese mes mots : /)

ou la compilation dans le dossier des sources avec make && make install, qui me met un message d’erreur avec ieee …

quelqu’un a une autre solution ?


#5

desolé de revenir a la charge, mais j’ai du reinstaller linux et apres plus moyen de reinstaller ma carte wifi. J’ai pourtant essaye les memes trucs que la derniere fois (qui avait fini par marcher), mais rien:
dans la methode ci-dessus, je suis bloqué a l’etape des headers; il me dit:

adrien@X31:~$ uname -a
Linux X31 2.6.15-1-686 #2 Mon Mar 6 15:27:08 UTC 2006 i686 GNU/Linux
adrien@X31:~$ sudo apt-get kernel-headers-2.6.15-1-686
E: L’opération kernel-headers-2.6.15-1-686 n’est pas valable

je me trompe ou ?

Aswat


#6

mon sources.list:

adrien@X31:~$ cat /etc/apt/sources.list

deb ftp2.fr.debian.org/debian/ etch main

deb cdrom:[Debian GNU/Linux testing Etch - Official Snapshot i386 Binary-1 (20060403)]/ etch contrib main

deb ftp2.fr.debian.org/debian/ etch main
deb-src ftp2.fr.debian.org/debian/ etch main

deb security.debian.org/ etch/updates main contrib
deb-src security.debian.org/ etch/updates main contrib

deb ftp2.fr.debian.org/debian etch main contrib non-free


#7

ca ne marchera pas casudo apt-get kernel-headers-2.6.15-1-686

essaye plutot sudo apt-get install linux-headers-2.6.15-1-686


#8

sudo apt-get kernel-headers-2.6.15-1-686 ne fonctionne pas,

je veus bien essayer l’autre
mais il me semble que c pas pr la meme chose si ?


#9

[quote=“aswat”]sudo apt-get kernel-headers-2.6.15-1-686 ne fonctionne pas,

je veus bien essayer l’autre
mais il me semble que c pas pr la meme chose si ?[/quote] mais est ce qu’au moins tu es en 2.6.15-1-686, parceque sinon, installer ces headers là ne servira à rien.
Essayes plutotapt-get install kernel-headers-`uname -r`
ou mieux, pour être au carré:

apt-get install module-assistant m-a update m-a prepare


#10

c fait, je passe a la suite de l’installation


#11

Tu oubliais le parametre install de la commande apt-get. Tu demandais donc a apt-get de kernel-headers et non d’installer le kernel-headers

Et aussi une autre chose a partir des sources 2.6.12 ce n’est plus kernel-source ou kernel-headers mais linux-source et linux-headers

Si tu avais fait une recherche sur kernel-headers-2.6.15-686 tu n’aurais rien trouvé c’est pourquoi il fallait faire un


#12

merci pour cette info, c’est noté, mais j’ai ete confronté a un autre problème pour apt-get install hotplug, il me previens que je suis sur le point de desinstaller une version de linux ou je ne sais pas trop quoi
il me propose de continuer ou d’arreter, j’ai dit anuler,
me suis - je trompé ?


#13

Tu as bien fait d’annuler, hotplug est en conflit avec la dernière version d’udev.


#14

oui j’ai fait annuler
puis j’ai telechargé la version 3.0 du fw de ipw2200B/G

j’ai dezippé ipw2200-source dans /usr/src
jai lancé m-a a-i ipw2200 depuis cd/modules/ipw2200/debian

puis j’ai mis les fichier fw dans /usr/lib/hotplug/firmware

modprobe ipw2200

ne m’affiche rien et la carte wifi n’exixte tjrs pas pour lui.

iwconfig donne:
X31:~# iwconfig
lo no wireless extensions.
eth0 no wireless extensions.

eth1 no wireless extensions.

sit0 no wireless extensions.

j’ai essaye de passer par m-a;
en selectionnant les paquets ieee… et ipw2200,
je prepare avec succes,
je build avec succes, il me propose de les installer je dit oui,
puis il me met ca :

─────────────┤ Configuration de ipw2200-modules-2.6.15-1-686 ├─────────────┐
│ │
│ Un micro-code (« firmware ») supplémentaire est nécessaire │
│ │
│ Le pilote ipw2200 a besoin d’un micro-code supplémentaire pour │
│ fonctionner correctement. Ce micro-code n’est pas actuellement installé │
│ sur votre système ou alors la version installée ne correspond pas à │
│ cette version du pilote ipw2200. │
│ │
│ Le micro-code n’est pas fourni sous forme de paquet Debian parce que sa │
│ licence n’en autorise pas la redistribution. Cependant, il peut être │
│ téléchargé librement depuis la page d’accueil d’Intel. Veuillez │
│ consulter /usr/share/doc/ipw2200-modules-2.6.15-1-686/README.firmware │
│ pour plus d’informations. │


#15

telecharge la version 2.4 du firmware… chez moi c’est passé nickel :slightly_smiling:


#16

ca marche avec le firmware 2.4

quelle galere, merci a vous tous !!!
Aswat


#17

de rien… ca fait plaisir :slightly_smiling:

(mets le [résolu] dans le titre de ton premier message :wink:)


#18

je me suis dit que ca pourais toujours servir donc je poste la methode que j’ai suivie:

Démarche d’installation d’une Intel® PRO/Wireless 2200BG sous debian 2.6.15-1-686

rajouter deb ftp2.fr.debian.org/debian etch main contrib non-free
au fichier sources.list dans /etc/apt/
tout ca en mode root:

apt-get install ipw2200-source
apt-get install module-assistant
apt-get wireless-tools
apt-get install kernel-headers-2.6.15-1-686

m-a update
m-a prepare

Telecharger le firmaware 2.4 qui correspond a la version du driver :
ipw2200.sourceforge.net/firmware.php

Dans /usr/src tar xvzf ipw2200-source.tar.gz
cd modules/ipw2200/debian
module-assistant a-i ipw2200
tar xvzf ipw2200-fw-2.4.tgz
mv *.fw /usr/lib/hotplug/firmware

redemarer et voilà :

adrien@X31:~$ sudo iwconfig eth1
eth1 IEEE 802.11b ESSID:"Mon_reseau"
Mode:Managed Frequency:2.462 GHz Access Point: 00:07:CB:50:A7:E1
Bit Rate=11 Mb/s Tx-Power=20 dBm
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$ Security mode:open
Power Management:off
Link Quality=76/100 Signal level=-53 dBm Noise level=-87 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:1

Si ca ne fonctionne toujours pas apres l’instalation du firmware, utiliser module assistant:

en root vous lancés module-assistant,
PREPARE (configurer le system pour compiler) et ensuite
dans SELECT choisir les modules: ieee80211 et ipw2200.
Puis BUILD, puis INSTALL, et voilà.

aswat