[resolu] iptables netfilter


#1

Voila, sur mon serveur, je suis en train de reinstaller, puisque avant j etais sous ubuntu, mon firewall. Mon script marchais super avant mais la sur ma sarge, j ai installer le script dans /etc/init.d/ et j ai fait un update-rc.d iptables-start defaults

pour le lancement automatique de mon script, j ai ajouter le script dans /etc/network/if-pre-up.d/iptables-start et mon script de stop ds le repertoire approprie. Le firewall demarre sans probleme :[code]debian:~# iptables -v -L
Chain INPUT (policy DROP 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
16 9680 ACCEPT all – lo any anywhere anywhere
0 0 ACCEPT icmp – any any anywhere anywhere
0 0 ACCEPT igmp – any any anywhere anywhere
1389K 1477M ACCEPT all – any any anywhere anywhere state RELATED,ESTABLISHED
0 0 ACCEPT tcp – any any anywhere anywhere tcp dpt:ftp-data
1 52 ACCEPT tcp – any any anywhere anywhere tcp dpt:ftp
0 0 ACCEPT tcp – any any anywhere anywhere tcp dpt:ssh
43 2076 ACCEPT tcp – any any anywhere anywhere tcp dpt:www
35 2797 REJECT all – any any anywhere anywhere reject-with icmp-port-unreachable
0 0 ACCEPT udp – any any anywhere anywhere udp dpts:27000:27015
0 0 ACCEPT udp – any any anywhere anywhere udp dpt:1200

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Chain OUTPUT (policy ACCEPT 694K packets, 28M bytes)
pkts bytes target prot opt in out source destination
debian:~#
[/code]

Donc tout semble bien fonctionner, je peux acceder a mon serveur web, ssh (ouf sinon j etais en galere) , mais pour me connecter au serveur ftp, je dois desactiver le mdoe passif du client ftp? deja sa me fait drole sinon il ne se connecte pas ou du moins pas vraiment et lorsque je fait debian:~# /etc/init.d/networking restart Setting up IP spoofing protection: rp_filter. Reconfiguring network interfaces...ifup: interface lo already configured iptables v1.2.11: invalid portrange (min > max) Try `iptables -h' or 'iptables --help' for more information. done.

Donc la j aime pas vraiment sa mais je vois pas d ou vient le probleme, voici mes regles concernant le ftp:

iptables -A INPUT -p tcp --dport 20 -j ACCEPT
iptables -A INPUT -p tcp --dport 21 -j ACCEPT

merci de votre aide


#2

dsl, j avais pas compris sur le moment mais j avais inverser un range entre le mx et le mini dc resolu.