[Résolu] Loading Debian


#1

Bonjour,
Je suis novice mais j’ai installer une debian (woody puis sid) sur un portable et tout fonctionnait parfaitement (sauf le son ALSA mais c un autre pbl) depuis plusieurs moi maintenant.
Reguliérement, je fais des mises à jour (apt-get update puis apt-get dist-upgrade) mais voila … Hier j’ai donc fait une mise a jour du system qui c’est passé ‘normalement’ mais depuis, au demarrage du PC, apres LILO, j’ai un ecran noir avec ‘Loading Debian…’ et ca ne va pas plus loin !! (Debian, c’est le nom que j’ai donné dans LILO).
Comment retrouver ma debian ? que c’est il passé ? … Je suis obligé de demarrer le PC sur windows maintenant :open_mouth: ! AIDEZ MOI
D’avance merci a qui peut m’éclairer un peu


#2

as tu essayé de booter en mode “single” ?
(linux single, ou linux 1, au prompt de lilo)


#3

Tu dois avoir un Linuxold dans le menu de lilo pour pouvoir booter sur ton ancien noyau. As tu essayé?


#4

comment avoir acces au prompt dans LILO pour avoir le mode “single” ?
Mais c’est vrais que j’ai un linuxold qui est accessible mais comment ‘reparer’ le plus recent ??


#5

pour accéder à un mode “single” au lieu de taper linuxold, tu tapes
’linux 1’… Comment fais tu pour passer en linuxold ?
Sinon, déjà, ca serait utile de savoir si tu boot un linux quelconque. Aprés, il sera peut être possible de corriger les choses…


#6

Oui j’ai bien accés a un linux (l’ancien avec noyau 2.4) parcequ’il m’est proposé dans LILO mais (pour info) comment taper ‘linux 1’ puisque mon LILO ne me propose aucune saisie clavier ? (ya un raccourci clavier à connaitre ?)
Bon ! en tout cas, je peux tjs booter sur mon ancien linux (image=/vmlinuz.old) mais comment faire pour récuperer mon beau Debian (image=/vmlinuz)? … j’C pas du tout ce qui cloche (ya peut être des log accessible pour aider a comprendre)
La, je suis bien décu par linux … ou alors c moi qui suis nul mais j’ai jamais été bloqué comme ça (sans solution) avec du windows :imp:
Mais bon … merci à vous de vous interresser à mon pbl


#7

ptet une étape qui s’est mal terminée quand tu as upgradé ton noyau. Essaye déjà de réinstaller ton boot en relençant lilo, vérifie bien aussi que tu utilises le bon initrd dans le lilo.conf et que les différents liens (initrd, vmlinuz) pointent bien là où il faut


#8

Ben la… Ca fait des lustre que j’utilise grub, je crois que c’est ctrl+X pour passer au prompt lilo.

A priori, si tu ne va pas plus loin que “loading debian” il ne doit pas y avoir la trace de grand chose. Par contre, une fois sous ton linuxold, tu peux dèjà reliloter ton boot: ‘lilo’ tout court, ou ‘lilo -v’ pour verbeux.

ah bon, même pas de partitions ntfs entieres qui disparaissent, jamais une impossibilité de booter en mode sans echec, jamais un pilote graphique figé ?
Ben dis moi, tu es vraiment un veinard, toi :laughing: !!!

De rien, c’est libre… euh non, gratuit :slightly_smiling:


#9

G déjà relancé LILO mais ca ne semble rien changer et le lilo.conf n’a pas été modifié (juste verifié)…
Sinon, pour avoir le prompt avec LILO, il faut utiliser la touche TAB mais ensuite, ‘linux 1’ ou ‘single’ ne marche pas :angry: G un message d’erreur ‘No such image. [Tab] shows list.’ et un nouvel appuis sur TAB me redonne la liste de mes boot disponibles alors je c pas … il faut taper ‘linux 1’ uniquement si on à donné comme label ‘linux’ dans le lilo.conf ???


#10

simer pour votre aide !
J’ai relancer la commande LILO et maintenant ca marche !

En fait, j’ai une configuration un peu particuliere puisque je demarre deja sur le boot.ini de windows qui me propose windows ou LILO. Si je modifie mon LILO, je dois evidement également recréer mon fichier bootsect (512 premier octet de la partion sur laquel est LILO)

Enfin … bref … La réécriture de LILO était bien la bonne solution

Mais si au passage, 8) si je pouvai comprendre comment lancer au prompt de LILO un autre demarrage, ce serai sympa ! Car on ne me propose que les demarrage que j’ai deja dans mon menu… comment lancer linux en mode single :question:


#11

C’est ça…
j’ai aussi utilisé ce type de boot, en ntloader, parceque je n’arrivais pas à faire booter correctement mon 2000 depuis linux en position slave (j’avais installé mon 2000 et mon linux séparéments avant de remonter les deux disques).
puis j’ai découvert l’option: map-drive=0x80 to=0x81 map-drive=0x81 to=0x80
mais tout ca est devenu un mauvais souvenir avec grub…