[RÉSOLU] Localisation avec Login.app et WindowMaker


#1

Bonjour,

Je profite de mon passage à Debian - après plus d’un an sur Ubutu - pour essayer de mettre en oeuvre un environnement cohérent de type NextStep (GNUStep). Tout semble bien marcher,
:question: mais l’interface sous X est en anglais, alors que le système était en français jusque là.

Voici le cheminement :
:arrow_right: installation initiale : XFCE4 -> localisation en fr. OK.
:arrow_right: installation de Login.app, wmaker, workspace, GNUmail, etc.
:arrow_right: désinstallation de gdm, remplacé par Login.app (niveau 2 de inittab).
:arrow_right: écriture de ~/.xsession :

Conséquence : Login.app se charge en anglais et la session X l’est aussi.
:bulb: Par ailleurs, je cherche de la doc sur l’utilisation de Workspace. Qqn a-t-il une idée ?


#2

Bonjour,
qu’est ce que tu as dans /etc/locale.gen ?
tu as essayé un truc genre ‘export LANG=’ dans ton .xsession, ou dans la config de wmaker (que je ne connais pas vraiment je te l’avoues)…


#3

Dans /etc/locale.gen, j’ai ceci :
fr_FR@euro ISO-8859-15

Je vais essayer la variable LANG dans .xsession.

NB : entre-temps, j’ai remis gdm à la place de Login.app et j’ai obtenu un mélange curieux :

  • certaines applications GNUStep sont bien localisées : GNUMail et GWorkspace, par exemple.
  • En revanche, les menus de WindowMaker sont encore en anglais.

#4

Voilà : j’ai remis Login.app pour effectuer des tests cohérents. J’ai ajouté la ligne export LANG=fr_FR au fichier .xsession.
Maintenant, les menus de Wmaker sont bien en français ; en revanche, pas de localisation des Apps comme GNUMail ou GWorkspace…
[/code]


#5

Lors de l’installation de WMMixer, j’ai obtenu les messages d’erreur suivants. Qu’en pensez-vous ?

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "fr_FR"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously deselected package wmmixer.
(Reading database ... 89264 files and directories currently installed.)
Unpacking wmmixer (from .../wmmixer/wmmixer_1.5-4_i386.deb) ...
Setting up wmmixer (1.5-4) ...

#6

dpkg-reconfigure locales
et pour réfèrence:
debian.org/doc/manuals/fr/de … o/ch3.html
(section 3.3)


#7

OK, je regarde cette doc en détail.
En attendant, j’ai en partie amélioré la chose en mettent export LANG=fr_FR@euro dans .xsession : j’avais oublié le @euro que j’ai vu dans /etc/locale.gen.


#8

Bon Login.app est encore en anglais, mais j’ai obtenu une bonne localisation avec la commande set-language-env qui, en plus de .xsession a configuré tous les scripts nécessaires dans mon home. Merci pour le lien vers la doc sur la localisation.