[Résolu]L'ordre de lancement de init.d


#1

Pour lancer un script au démarrage il faut mettre le script dans le répertoire /etc/init.d/ puis faire un update-rc.d pour upgrader les raccourcis de démarrage.

Une petite question dans quel ordre sont exécutés les scripts se trouvant dans init.d? Je ne demande pas ca innocement en fait j’ai une petite gène je doit reconfigurer mon réseau wan a chaque fois que je relance ma machine sans quoi je n’ai aucun accès a internet.

Et je souhaiterais mettre ce script dans init.d pour qu’il fonctionne correctement sans avoir à faire plusieurs fois la même chose (lors du boot il configure le réseau sans succes et je suis obligé de relancer mon script apres etres logger en root pour que ca fonctionne 2lancement de networking c’est long chez moi)

J’ai déja essayer de modifer ca autrement en virant le module prism avec un rmmod mais rien a faire il se relance a chaque fois.

Si vous avez une idées pour m’aider


#2

Quand tu fais un update-rc.d, il crée simplement des liens SNton_script dans les différents répertoire /etc/rc*.d
N est un chiffre par défaut égal à 20 et les scripts sont éxécutés dans l’ordre alphabétique de ces liens. En gros les liens avec N=20 seront éxécutés avant ceux qui ont N=80.
Tu peux spécifier ce chiffre quand tu éxécutes update-rc.d.


#3

Ok merci bien de la réponse je vais essayer de voir si je peux eviter de configurer deux fois mon réseaux pour qu’il fonctionne.

En attendant je vais mettre mon script dans init.d afin que je ne soit pas obligé de le faire manuellement merci.

[Edit]Un tutos sympa sur update-rc.d debian-fr.org/article.php?pa … &article=4 [/Edit]


#4

Sinon, t’as essayé de le configurer dans /etc/network/interfaces tout simplement?


#5

Non je n’y avais pas pensé du tout et pourtant j’ai vu de nombreuses fois que l’on pouvait le faire :blush:

Sinon mon problème viens aussi du fait qu’un module est chargé au démarrage et qu’il me pose problème pour la configuration de mon réseau

Je te montre mon script tu vas comprendre tout de suite je pense

rmmod prism54 iwconfig wlan0 essid linksys channel 11 ifconfig wlan0 192.168.1.100 /etc/init.d/networking restart

deux solutions donc soit je modifie ce script pour qu’il soit de la meme forme que le squelete d’init.d ou alors j’arrive a empecher le mod prism54 de se lancer au démarrage


#6

Je suppose que le module prism54 est chargé par hotplug non? donc tu peux le blacklister en le rajoutant dans le fichier /etc/hotplug/blacklist. Ou sinon tu peux le décharger avant de monter ton interface à l’aide de la directive pre-up dans le fichier interfaces.


#7

Je vais regarder a ca merci il etait déja dans le fichier /etc/modules et je l’ai viré je pensais que ca reglerais le probleme mais non toujours pas.

Je regarde avec hotplug et je te redis quoi merci

Et bien je n’ai rien trouvé dans hotplug qui correspondait au module prism54


#8

s’il ne te sert pas, tu peux carrément le vider de /lib/modules/
je rappelle que /etc/modules FORCE les paquets à cherger au boot, et que pour désactiver un module, il faut faire un alias <module> off dans un des fichiers de modprobe.d.
autre possibilité: si c’est parcequ’il est incompatible avec un autre qui se monte aprés, tu peux rajouter une regle “install” pour ‘rmmoder’ le module. Un exemple chez moi avec nvidia, rivafb et nvidiafb (qui sont mutuellement exclusifs:[quote="/etc/modprobe.d/nvhack"]install rivafb (/sbin/modprobe -r nvidiafb || /sbin/modprobe -r nvidia ) && /sbin/modprobe -i rivafb
install nvidiafb (/sbin/modprobe -r rivafb || /sbin/modprobe -r nvidia ) && /sbin/modprobe -i nvidiafb
install nvidia (/sbin/modprobe -r nvidiafb || /sbin/modprobe -r rivafb ) && /sbin/modprobe -i nvidia[/quote]
mon pb c’etait qu’il m’insmodait nvidiafb au boot, alors que j’avais besoin de nvidia. Maintenant, il me charge toujours le nvidiafb, mais dés qu’X démarre, il est rmmodé et remplacé par nvidia…
Quand je monte un de ces modules, il supprime les autres qui seraient éventuellement chargés.


#9

Merci bien pour toutes ces réponses j’ai enfin pu réussir a faire ce que je désirais maintenant ca fonctionne. Seulement je ne sais pas trop ce que j’ai fait en modifiant certaines données mais je me retrouve sans son??? :open_mouth:

Comment en modifiant des parametres réseaux peut on perdre le son???

Je retrouve le message d’erreur et je vous le poste (il n’apparait que la première fois ou je lance une appli demandant du son)


#10

devfs_mk_dev: could not append to parent for sound/audio Voila le message d’erreur je ne comprend pas trop le lien entre l’audio et le wifi?


#11

parfois, le même chipset fait office de plusieurs choses…
Un peu comme un velo-bateau-helicoptere: dans certains cas extrêmes, ca peut servir :laughing:
Donc si c’est le même module, ou un module qui en dépend, qui gère ton son, tu es :angry:


#12

[quote=“MattOTop”]parfois, le même chipset fait office de plusieurs choses…
Un peu comme un velo-bateau-helicoptere: dans certains cas extrêmes, ca peut servir :laughing:
Donc si c’est le même module, ou un module qui en dépend, qui gère ton son, tu es :angry:[/quote]
Je vais devenir chevre moi :slightly_smiling: a peine un problème résolu qu’un deuxième surviens :imp:

C’est pas grave, va falloir que je modifie tout ça pour qu’il me prenne en compte mon son.
lspci -vv sous root me donne ca pour ma carte son

0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50) Subsystem: DFI Inc: Unknown device 1001 Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- Interrupt: pin C routed to IRQ 12 Region 0: I/O ports at e800 [size=256] Capabilities: [c0] Power Management version 2 Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-) Status: D0 PME-Enable- DSel=0 DScale=0 PME- c’est un audio controller AC97 je devrais pouvoir arranger ca en utilisant alsa?


#13

ah ben normalement, l’AC97, oui, alsa s’en occupe…


#14

Bon ne sachant pas vraiment comment faire je vais faire quelques recherches et je configures tout ca merci pour votre aide


#15

alsa se configure avec alsaconf


#16

slt,

Le demon init est deja parametre dans /etc/inittab tu as une section defaults runlevel avec le chiffre du level et les descriptions qui vont bien, ensuite tu te rend dans le run le level qui va bien puis tu as S1 a SX ils sont lançer respectivement dans l’ordre croissant, le S signifie Start puis les K pour Kill idem avec des chiffres , ils sont killé dans un ordre decroissant…


#17

Merci pour toutes vos réponses ca fonctionne correctement :smiley: :smiley: