[résolu] montage periph amovible icones gnome


#1

Bonjour,

J’ai un soucis (non bloquant mais ennuyeux) depuis la grosse mise à jour gnome/kde de fevrier. Jusqu’alors les CD et les stick usb étaient automatiquement montés et je pouvais parcourir les dossiers avec nautilus en cliquant sur les icones du bureau.

Depuis cette mise j’ai perdu cette fonctionnalité.

Dans ce forum, j’ai lu qu’il avait supprimé hal. Je l’ai donc réinstallé.

J’ai l’impression qu’il y a conflit (ou incohérence) entre plusieurs systémes de montage automatique. En effet si je fais (sous gnome 2.12):
racourcis --> poste de travail , je vois apparaitre une ligne :
USB DISK 2.0 -r–r--r-- root root fichier de configuration desktop inconnue

Si je fais : click droit ouvrir|parcourir|monter j’ai le message d’erreur suivant

Impossible de monter le volume sélectionné
Erreur : le périphérique /dev/sda1 est déja monté sur /media/sda1

Même problème pour un cdrom :
Erreur : le périphérique /dev/scd2 est déja monté sur /media/scd2
kji

Par contre je peux lire et écrire le contenu /media/sda1 (j’ai les bon droits en utilisateur autre que root)

Dans users-admin
J’ai les privilèges utilisateurs pour monter les periphériques amovibles.
J’ai les privilèges pour utiliser les cdrom
Je suis dans les groupes cdrom, floppy, plugdev

Dans /etc/fstab j’ai commenté les lignes relatives aux cdrom :
#/dev/scd0 /media/cdrom0 udf,iso9660 ro,user,noauto 0 0
#/dev/scd1 /media/cdrom1 udf,iso9660 ro,user,noauto 0 0
#/dev/scd2 /media/cdrom2 udf,iso9660 ro,user,noauto 0 0
#/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

J’aimerai tirer tout cela au clair !
Mes questions :
Si je veux retrouver le comportement initial (qui fonctionne identiquement mais parfaitement sous ubuntu 5.10 sur mon portable) quels sont les paquets à installer et à paramétrer ?
Quels paquets ne faut il pas installer simultanément ?
Est ce un problème Système, Gnome ou Nautilus ?

autofs, usbmount, hotplug ne sont pas installés.
gnome-volume-manager(1.4.0-4), hal, hal-device-manager, libhal1, libhal-dev, libhal-storage1(0.5.7-1) ,pmount(0.9.7-2), udev(0.088-2) sont installés
0.088-2

En consultant le web, on trouve plusieurs types de solutions mais c’est difficile de savoir si elle sont valables car chacun à ses préférences, et elles ne sont peut être plus d’actualité. Pour ma part, je me contente de la solution la plus standard possible pour éviter si possible les problèmes lors des mises à jour futures (enfin j’espère) D’autant plus que cela marchait parfaitement après l’installation sans que j’ai eu à intervenir.

Cordialement
PC


#2

Je me réponds pour préciser, que dans gnome-volume-properties, j’ai bien :
Monter les périphériques amovibles à chaud
Monter les média amovible lors de l’insertion
Parcourir les médias amovibles lors de l’insertion

Par contre je n’ai pas sélectionner l’option pour lancer automatiquement les programmes.


#3

En fait c’était un problème de compatibilité entre udev et la version du noyau.

Je suis passé au 2.6.15-1-k7 et cela semble avoir réglé le problème comme indiqué ici :
http://forums.debian.net/viewtopic.php?t=3697&