[resolu]monter une clef usb sur xfce ?


#1

Salut,
Je viens d’installer sarge avec un kernell 2.6 et xfce4 sur un vieux coucou, tout s’est bien passé mais voilà je n’arrive pas à monter ma clef usb. Je cherche depuis un moment sans résultat… :cry: En passant par gnome pas de problème, donc cela viendrait d’xfce ???
Est ce que quelqu’un connait une méthode (automatique si possible) pour monter les périphériques de stockage usb sur xfce please ? :unamused:


#2

forum.debian-fr.org/viewtopic.php?t=3128


#3

Merci, mais ça n’a pas solutionné mon problème, hal et pmount sont installé mais la commande pmount ne fonctionne pas chez moi… dommage pace que le reste du systeme fonctionne bien …


#4

Et avec le paquet usbmount ?

Est-ce que la clef apparait dans dev?


#5

usbmount est installé. Dans /dev j’ai sda et sda1 (normal) mais rien de monter dans media ou même mnt… j’ai essayé également de lancer gnome-volumes-manager mais sans resultat. Peut etre je devrais installer une version plus récente d’xfce4 ?

(ça se mérite une config parfaite ! ;o) )


#6

As-tu essayé ce tuto?

lea-linux.org/cached/index/Fiche … b_%3F.html

Si oui, ou es-tu bloqué?


#7

Un grand merci à toi Capucine, la clef est montée ! Par contre elle est en lecture seule… j’ai fait un chmod 777 clefusb mais ça ne doit pas être la bonne méthode… :confused:


#8

Alors la :question:
Peut etre qu’il faut chomder directement dans dev…
Est-ce que ta clef se monte automatiquement?


#9

la clef ne se monte pas automatiquent… pourtant j’ai ajouté la ligne dans fstab comme dans le tuto … ?
J’ai essayé de changer les permissions avec chmod et dans les propriétés de la clef, mais ça ne s’enregistre pas… pourtant en mode root.


#10

as tu fait le peti test préalable du tuto ?
Qu’a t il donné ?


#11

le petit test à fonctionné, j’arrive à monter la clef et à voir son contenu…


#12

peux tu dire la commande qui t’a permis de monter la clé, et l’entrée de fstab que tu as ajoutée ?


#13

j’ai utilisé cette commande pour monter la clef :
mount -t vfat /dev/sda1 /mnt/clef

et voici ma ligne dans fstab :
/dev/sda1 /mnt/clef vfat rw,noauto,iocharset=iso8859-15,codepage=850,user,exec 0 0

J’ai suivi scrupuleusement le tuto… la clef est montée (manuellement) mais en lecture seule pour les utilisateurs.


#14

Arrrrgllll!
Ma clef est armoire aussi! Ca doit etre la suite de mon bigbang il y a 3 semaines.

Chez moi la clef se monte automatiquement en lecture seule dans /media.
Il n’y a plus que le problème des droits, de l’apparition sur le bureau et dans le poste de travail.
Je vais aller faire un tour sur ma KLA pour voir…


#15

quote="pleifrest"J’ai suivi scrupuleusement le tuto… la clef est montée (manuellement) mais en lecture seule pour les utilisateurs.[/quote]Oui, et c’est normal: n’importe quel user peut monter, mais aprés, seul celui qui a monté la clé ou le root peuvent y ecrire ou la démonter. C’est une precaution de sécurité.
Si tu veux que la clé soit montée partagée et que n’importe quel user puisse ecrire ou demonter la clé, c’est users avec un s au lieu de user qu’il faut mettre dans fstab.
sinon, si pmount ne te permet pas d’automatiser le montage, tu as aussi autofs pour faire de l’automatisation.


#16

Merci à tout les deux, la modif de user en users dans fstab fonctionne.
La clef n’est pas automatiquement montée mais ce n’est pas trop grave du moment que je peux le faire manuellement dans xffm sans passer par root.