[Resolu] mount /dev/hdX Aucun medium trouvé


#1

bonsoir,
décidement, pas de chance moi avec mount, pourriez vous me dire ce qui cloche ?
mon fichier /etc/fstab :

[code]# /etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda9 /home ext3 defaults 0 2
/dev/hda8 /tmp ext3 defaults 0 2
/dev/hda5 /usr ext3 defaults 0 2
/dev/hda6 /var ext3 defaults 0 2
/dev/hda7 none swap sw 0 0
/dev/hdd /media/cdrom0 iso9660 defaults,ro,user,noauto,exec 0 0
/dev/hdc /media/cdrom1 iso9660 defaults,ro,user,noauto,exec 0 0
/dev/fd0 /media/floppy0 auto defaults,user,noauto 0 0
/dev/sda /media/usb0 vfat defaults,noauto,user,sync,uid=1000,gid=1000,umask=022 0 0
[/code]
mon repertoire /media aprés un ls -all:

total 6 drwxr-xr-x 6 root root 1024 2006-04-16 22:58 . drwxr-xr-x 21 root root 1024 2006-04-17 05:58 .. lrwxrwxrwx 1 root root 6 2006-04-16 22:58 cdrom -> cdrom0 drwxr-xr-x 2 root root 1024 2006-04-16 22:58 cdrom0 drwxr-xr-x 2 root root 1024 2006-04-16 22:58 cdrom1 lrwxrwxrwx 1 root root 7 2006-04-16 22:58 floppy -> floppy0 drwxr-xr-x 2 root root 1024 2006-04-16 22:58 floppy0 lrwxrwxrwx 1 root root 4 2006-04-16 22:58 usb -> usb0 drwxr-xr-x 2 root root 1024 2006-04-16 22:58 usb0

Qu’est ce qui ne va pas ?
merci …


#2

“Aucun medium trouvé”

ça c’est le comble du medium :laughing:


#3

cad :question: :blush: :confused: :cry: :wink:


#4

Parfois cela fonctionne en remplaçant sda par sda1 (ou sdb par sdb1 si sur sda on a un disque dur sata)

cela donne dans le fstab :


#5

merci ginkgo biloba, bonjour à tous …
marche pas …
1/
je remplace dans /etc/fstab sda par sda1 —>

mount /dev/sda1 donne : mount: can't find /dev/sda in /etc/fstab or /etc/mtab
Je remets sda au lieu de sda1 dans /etc/fstab, (sic plus haut).
2/ j’édite le fichier /etc/mtab :

/dev/hda1 / ext3 rw,errors=remount-ro 0 0 proc /proc proc rw 0 0 sysfs /sys sysfs rw 0 0 devpts /dev/pts devpts rw,gid=5,mode=620 0 0 tmpfs /dev/shm tmpfs rw 0 0 usbfs /proc/bus/usb usbfs rw 0 0 /dev/hda9 /home ext3 rw 0 0 /dev/hda8 /tmp ext3 rw 0 0 /dev/hda5 /usr ext3 rw 0 0 /dev/hda6 /var ext3 rw 0 0
3/ google sur usbfs :
forum.debian-fr.org/viewtopic.php?t=2931
linux-usb.org/USB-guide/x173.html
4/ suivant la procédure décrite : ça ne fonctionne pas, erreurs.
contenu du repertoire /proc/bus/usb/ :

total 0 drwxr-xr-x 7 root root 0 2006-04-20 09:33 . dr-xr-xr-x 5 root root 0 2006-04-20 09:33 .. dr-xr-xr-x 2 root root 0 2006-04-20 09:33 001 dr-xr-xr-x 2 root root 0 2006-04-20 09:33 002 dr-xr-xr-x 2 root root 0 2006-04-20 09:33 003 dr-xr-xr-x 2 root root 0 2006-04-20 09:33 004 dr-xr-xr-x 2 root root 0 2006-04-20 09:33 005 -r--r--r-- 1 root root 0 2006-04-20 09:33 devices

Je sais pas trop comment faire là, est-ce que je dois exécuter cette commande
en la modifiant légèrement, usbdevfs denient usbfs, comme stipulé dans mon
fichier /etc/mtab ?
mount -t usbdevfs none /proc/bus/usb --> mount -t usbfs none /proc/bus/usb # Donne erreur .

Si dans /etc/fstab, je modifie le system de fichier vfat en usbfs, et que je monte /media/usb0 :
usbfs: unrecognised mount option “uid=1000” or missing value
drivers/usb/core/inode.c: usbfs: mount parameter error:

Que faire ?


#6

1/pas possible. si tu as bien mis ce que te dit gingko, même si c’est mauvais, ça devrait te donner une erreur sur /dev/sda1, et pas /dev/sda. Donc recommences, et copies PRECISEMENT la commande que tu tapes (normalement mount /dev/sda1).
2/surtout pas. La consultation de mtab peut éventuellement te servir, mais certainement pas sa modification: on ne touche pas à mtab.
3/le premier lien que tu mets est ce fil même. Tu es sûr que tu as suivi tes liens ? Parceque tu te serait aperçu que la notion de usbdevfs n’avait rien à voir avec ton problême.
4/donc oublies.

Maintenant, reprenons à ton premier post:
tout ce qu’il y a dans ton fstab initial est bon “à priori”, donc peux tu préciser quel est ton problême ? :laughing:


#7

La première chose à savoir, c’est que tu n’es pas obligé de modifier ton fstab pour faire des tests, et que tu peux tester avec mount directement ce que tu va y mettre.
Par exemple au lieu de mettre ce que dit gb dans fstab, et de faire un mount /dev/sda, l’equivalent sera :mount /dev/sda /media/usb0 -t vfat -o defaults,noauto,user,sync,uid=1000,gid=1000,umask=022, mais pour tester, un petit mount /dev/sda /media/usb0 -t vfat devrait faire l’affaire.
Si ça marche, c’est aprés, que tu modifies ton fstab.

Mais déjà, il faut savoir si ta clé est bien sur sda ou sur sda1 (en es tu sûr, d’ailleurs ?). Regardes donc ce que donne un “fdisk -L /dev/sda” (qui liste les partitions de sda).
Si ça répond bien, donnes le resultat ici pour la suite de la reflection.
Spinon, il va falloir aller regarder dans /var/log/dmesg le message qui aparait quand tu branches ta clé, pour savoir sous quel nom elle apparait dans /dev.

Finalement, les montages dans /media sont gèrés par le systême, et bougent tout seul comme si on était sous windows. Je sais qu’il servent au montage automatique de kde ou gnome, mais je ne les utilises jamais. Donc, AMA, tu les oublies, et tu n’y touches pas, et tu fais comme on le fait traditionnellement, tui va rajouter dans fstab les points de montages ou tu veux monter tes dispositifs perso, mais non pas utiliser ceux qui existe.
Ca veut dire que quand tu auras trouvé la “bonne” commande mount pour monter ta clé, tu ne modifieras pas la ligne /media/usb0, tu en créeras une nouvelle. Typiquement, on crée le répertoire ou on monte par exemple sa clé dans /mnt/cleusb (le nom qu’on veut, mais on le met dans /mnt qui est fait pour ça), et on crée ensuite le point de montage dans fstab pointant dessus.


#8

[quote=“ginkgo biloba”]Parfois cela fonctionne en remplaçant sda par sda1 (ou sdb par sdb1 si sur sda on a un disque dur sata)
cela donne dans le fstab :

et [quote]1/pas possible. si tu as bien mis ce que te dit gingko, même si c’est mauvais, ça devrait te donner une erreur sur /dev/sda1, et pas /dev/sda. Donc recommences[/quote] :confused:
sorry, :stuck_out_tongue: ça marche !!!
En fait, il a pas ajouté tout de suite dans /etc/mtab ce que je peux lire maintenant : /dev/sda1 /media/usb0 usbfs rw, noexec, nosuid, nodev, sync, uid=1000,gid=1000,umask=022 0 0 /dev/sda1 /media/usb0 vfat rw, noexec, nosuid, nodev, sync, uid=1000,gid=1000,umask=022 0 0
Mais :confused: je comprends que la première ligne spécifiant usbfs est erronée, que c’est en modifiant vfat en usbfs dans fstab que ça m’a mis cette ligne … je rectifie (suppression de la ligne contenant usbfs) car sans ça j’ai :

umount /media/usb0 umount: it seems /media/usb0 is mounted multipe times
Pourquoi ce décalage, il y a un update à faire pour qu’il tienne immédiatement compte de la modif dans fstab ?


#9

non non, c’est sans doutes un reliquat de tes tests, et surtout de tes modifs maladroites dans mtab.
Verifies ton fstab pour voir s’il est propre reboote, et tout devrait finalement marcher normalement.
Par contre évites, avant, de faire des ecritures sur ta cle, il n’est pas dit que tout soit sauvé dessus au moment de l’extinction.


#10

merci pour les explications sup[quote=“MattOTop”]Mais déjà, il faut savoir si ta clé est bien sur sda ou sur sda1 (en es tu sûr, d’ailleurs ?). Regardes donc ce que donne un “fdisk -L /dev/sda” (qui liste les partitions de sda).
Si ça répond bien, donnes le resultat ici pour la suite de la reflection.
Spinon, il va falloir aller regarder dans /var/log/dmesg le message qui aparait quand tu branches ta clé, pour savoir sous quel nom elle apparait dans /dev.
[/quote]
OK … pour info, j’ai les logs qui sortent en tty8, déconnection de la clé, reconnection :

... sda: sda1 sd 1:0:0:0 Attached scsi removable disk sda usb-storage: device scan complete sd_mod: can't be loaded (for disk)
mais voyons fdisk -l /dev/sda :

Disk /dev/sda: 130 MB, 130940928 bytes 16 heads, 32 sectors/track, 499 cylinders Units = cylinders of 512 * 512 = 262144 bytes Device Boot Start End Blocks Id System /dev/sda1 * 1 499 127727+ 6 FAT16 Partition 1 has different physical/logical endings: phys=(497, 15, 32) logical=(498, 15, 31) et fdisk -l /dev/sda1 :

[code]Disk /dev/sda1: 130 MB, 130792960 bytes
5 heads, 50 sectors/track, 1021 cylinders
Units = cylinders of 250 * 512 = 128000 bytes

This doesn’t look like a partition table
Probably you selected the wrong device.

 Device Boot      Start         End      Blocks   Id  System

/dev/sda1p1 ? 7679804 9857553 272218546+ 20 Unknown
Partition 1 has different physical/logical beginnings (non-Linux?):
phys=(356, 97, 46) logical=(7679803, 4, 9)
Partition 1 has different physical/logical endings:
phys=(357, 116, 40) logical=(9857552, 1, 1)
Partition 1 does not end on cylinder boundary.
/dev/sda1p2 ? 5320737 7476642 269488144 6b Unknown
Partition 2 has different physical/logical beginnings (non-Linux?):
phys=(288, 110, 57) logical=(5320736, 4, 3)
Partition 2 has different physical/logical endings:
phys=(269, 101, 57) logical=(7476641, 4, 40)
Partition 2 does not end on cylinder boundary.
/dev/sda1p3 ? 2155958 7749410 699181456 53 OnTrack DM6 Aux3
Partition 3 has different physical/logical beginnings (non-Linux?):
phys=(345, 32, 19) logical=(2155957, 2, 42)
Partition 3 has different physical/logical endings:
phys=(324, 77, 19) logical=(7749409, 1, 3)
Partition 3 does not end on cylinder boundary.
/dev/sda1p4 * 5578511 5578596 10668+ 49 Unknown
Partition 4 has different physical/logical beginnings (non-Linux?):
phys=(87, 1, 0) logical=(5578510, 3, 14)
Partition 4 has different physical/logical endings:
phys=(335, 78, 2) logical=(5578595, 4, 50)
Partition 4 does not end on cylinder boundary.

Partition table entries are not in disk order
[/code] où je suspecte la présence d’autres anomalies que celle générée par la référence à sda1 … ?
De toute façon ça marche, je devrais pouvoir y arriver en me servant de sda et non plus sda1 maintenant, je vous tiens au courant … thanks :slightly_smiling:

PS : on peut faire en sorte que la clé soit montée automatiquement à la connection je crois … dangereux ?


#11

[quote=“MattOTop”]Par exemple au lieu de mettre ce que dit gb dans fstab, et de faire un mount /dev/sda, l’equivalent sera :mount /dev/sda /media/usb0 -t vfat -o defaults,noauto,user,sync,uid=1000,gid=1000,umask=022, mais pour tester, un petit mount /dev/sda /media/usb0 -t vfat devrait faire l’affaire.
Si ça marche, c’est aprés, que tu modifies ton fstab.[/quote]
OK, mais non ça veut pas, je reçoit dans l’ordre :

FAT: invalid media value (0x01) VFS: Can't find a valid FAT filesystem on dev sda. mount: wrong fs type, bad option, bad superblock on /dev/sda, missing codepage or other error In some cases useful info is found in syslog - try dmeg | tail or so
et idem
j’ajoute que j’ai changé à la main sda1 en sda dans fstab :confused:
j’attend le diagnostique avant de toucher autre chose lol


#12

euh, c’est bien toi qui disais dans un autre post que tu avais reussi à monter ta clé ?
tu pourrais mettre un petit [résolu] ?


#13

Oui bien sur je vais mettre résolu, mais est-ce que tout est bien propre comme ça devrait être ? ça marche pas en sda, pourtant ma clé c’est sda normalement, pas sda1, mais ça marche avec sda1 :confused:
Bon ok je le mets en résolu, mais que penses-tu des sorties de fdisk -l sda et fdisk -l sda1 ??
Merci à vous.


#14

ce n’est pas sale d’utiliser sda1 au lieu de sda. Ca dépend des distribs, de la manière dont est formattée la clé, et du noyau, mais je ne sais pas pourquoi.

Concernant ton fdisk -l sur sda, tout est normal: on voit bien la partoche sda1 (en fat16), ce qui est confirmé par le message sur tty8: ta clé est bien en sda (et la partition, est en sda1). Le but était surtout de vérifier que pour une raison ou pour une autre (ajout d’un autre support, etc…) elle ne s’était pas retrouvé renommée en sdb(sdb1), ou autre…
Je ne sais pas ce que ça aurait donné dans un cas ou ta partoche aurait été accessible sur sda tout court.

le fdisk sur sda1 n’a aucun sens: fdisk s’applique à un disque, pas à une partition.

tu as compris le coup de tester le montage directement avec mount, avant de le mettre en dur dans fstab ?

sinon, pour ton info, mtab est alimenté tout seul par la commande mount, et sert à d’autres programme à savoir ce qui est vraiment monté et ce qui ne l’est pas. C’est pour ça en fait, qu’il ne faut pas y toucher: ce n’est pas un fichier utilisateur (même root ne devrais pas).


#15

Okay super, un grand merci …