[RESOLU][Newbie] Touchpad


#1

Bonjour.

Jai lu dans la documentation de Debian qu’il fallait modifier le fichier gdm.conf pour utiliser le touchpad et la souris usb.

Cependant , je n’ai pas ce fichier gdm.conf.

j’ai un linux 2.4 sarge.

Un petit conseil ???

Merci d avance .


#2

Bonjour et bienvenue.

Peux-tu donner les sources de la “doc” dont tu parles ?


#3

oui :slightly_smiling:
celle la apt-get install debian-reference

pourquoi ???


#4

et tu le cherches où ton fichier gdm.conf ?

Chez moi, il est dans [quote]/etc/gdm/gdm.conf[/quote]
Mais je ne suis pas sûr que ce soit là qu’il te faille chercher pour activer ta souris ou ton touchpad. Je dirais plutôt du côté de /etc/X11/xorg.conf (Testing/Unstable) ou XF86Config-4 (Stable).


#5

ah si il est la !!
a l 'ndroit que tu dis .
j’au du me tromper de dossier!!

mais je sais plus ce que je dois mettr!

je vais voir et je dis quoi §!
merci


#6

Je confirme, je ne vois pas bien en quoi gdm.conf peut servir à configurer la souris/touchpad :
http://www.ibiblio.org/oswg/oswg-nightly/oswg/en_US.ISO_8859-1/articles/gdm-reference/gdm-reference/x135.html


#7

Merci de tes réponses.
Je regarderais ca à tete reposée.


#8

Wiki Debian sur Synaptics Touchpad

bonne lecture :slightly_smiling:


#9

merci j y vais de cepas


#10

[quote=“Twistophe”]Wiki Debian sur Synaptics Touchpad

bonne lecture :slightly_smiling:[/quote]

alors :

j installe les drivers synaptics . Pas de probleme

j’installe qsynaptics. apt-cache search ksynaptics. il me sort ksynaptics. je l’installe donc.

je rajoute une section input device en plus des autres. comme dans le tuto.
je rajoute cette ligne la InputDevice “Synaptics Mouse” “AlwaysCore” dans la section server layout.
je restart X en redémarrant. et la il me dit que je ne peux démarrer startX

du à mes modifications.


#11

Là, ça colle mieux à ce que je pensais : modification du fichier de X.
Rien à voir avec gdm.conf.

Je suis surpris que skyangel ait pu lire de tels conseils dans la documentation officielle Debian.


#12

[quote=“skyangel”]je restart X en redémarrant. et la il me dit que je ne peux démarrer startX

du à mes modifications.[/quote]
Donne-nous au moins le message d’erreur, ou le fichier /var/log/Xfree86, car sans ça, on ne pourra pas beaucoup t’aider.


#13

[quote=“Korben Dallas”]
Je suis surpris que skyangel ait pu lire de tels conseils dans la documentation officielle Debian.[/quote]

je me suis peut etre trompe tout simplement!!!

je posterais le probleme demain car la j ai pas le pc sous linnux.


#14

Ne t’inquiète pas, tout le monde peut se tromper :slightly_smiling:

A ta disposition demain pour essayer de résoudre ton problème.


#15

cool :slightly_smiling: merci

P.S/ cool ton nom!


#16

Mais non, pas cool, mais [size=150]GREEN[/size] !!


#17

[size=200]super green[/size]


#18

Mais non, pas cool, mais [size=150]GREEN[/size] !![/quote]

Hmmm
sorry de t’avoir véxé :slightly_smiling::slight_smile:

sinon mon touchpad fonctionne :slightly_smiling::slight_smile:

ce que j’ai fait?? je ne sais pas lol !!

non pour etre serieu j’ain installe les drivers synaptics , le pakage ksynaptics , reboot. j’ai pas modifie le fichier XF86Config-4.

et il marche c magique J AIME CA!!


#19

Le touchpad est géré comme une souris ps/2 à 2 boutons normalement. A configurer dans /etc/X11/(xfree… ou xorg.conf)

Le paquet tpconfig te permettra de gérer plus finement l’animal (pour lui apprendre les règles de vie en société :wink: ) Dans la doc, ils disent que tu peux empêcher le “clic en tapant” si tu n’en veux pas, en ajoutant dans le fichier de conf (/etc/default/tpconfig) l’instruction :

OPTIONS="--tapmode=0"

Tu peux aussi modifier /etc/gpm.conf (et non gdm) pour faire coexister une souris usb avec le touchpad en console (sous X c’est possible aussi mais je n’ai pas de tuyau) :

device=/dev/psaux
     responsiveness=
     repeat_type=ms3
     type=autops2
     append="-M -m /dev/input/mice -t autops2"
     sample_rate=

#20

[quote=“skyangel”]sinon mon touchpad fonctionne :slightly_smiling::slight_smile:

ce que j’ai fait?? je ne sais pas lol !![…]
et il marche c magique J AIME CA!![/quote]
Pense aux nombres de fois où on vit ça avec Windows et relativise quand ça arrive sous Debian :slightly_smiling: